Bug 982346 - raise CreatorError("Dependency check failed : %s" % "\n".join(deps)) TypeError: sequence item 0: expected string, tuple found
raise CreatorError("Dependency check failed : %s" % "\n".join(deps)) TypeErro...
Status: CLOSED DUPLICATE of bug 979759
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-08 14:38 EDT by nucleo
Modified: 2013-07-08 20:31 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-08 20:31:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
nightly image build log (288.61 KB, text/x-log)
2013-07-08 14:38 EDT, nucleo
no flags Details

  None (edit)
Description nucleo 2013-07-08 14:38:58 EDT
Created attachment 770612 [details]
nightly image build log

Description of problem:
If dependency check failed there is exception:

Traceback (most recent call last):
File "/usr/bin/livecd-creator", line 237, in <module>
sys.exit(main())
File "/usr/bin/livecd-creator", line 218, in main
creator.install()
File "/usr/lib/python2.7/site-packages/imgcreate/creator.py", line 655, in install
ayum.runInstall()
File "/usr/lib/python2.7/site-packages/imgcreate/yuminst.py", line 220, in runInstall
raise CreatorError("Dependency check failed : %s" % "\n".join(deps))
TypeError: sequence item 0: expected string, tuple found


Version-Release number of selected component (if applicable):
livecd-tools-19.5-1.fc20

Actual results:
Last F20 KDE nightly composes failed but instead of broken deps there is only traceback.
http://koji.fedoraproject.org/koji/taskinfo?taskID=5586192
Comment 1 Brian Lane 2013-07-08 20:31:17 EDT

*** This bug has been marked as a duplicate of bug 979759 ***

Note You need to log in before you can comment on or make changes to this bug.