This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 979759 - livecd-creator yum error rawhide
livecd-creator yum error rawhide
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
: 982346 983393 983776 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-30 05:27 EDT by Manfred Blankenfeld
Modified: 2013-09-29 20:37 EDT (History)
10 users (show)

See Also:
Fixed In Version: livecd-tools-18.17-1.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-14 22:59:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Manfred Blankenfeld 2013-06-30 05:27:09 EDT
Description of problem:
In VirtualBox-4.2.14 I create my own livecds with spin-kickstarts.

Version-Release number of selected component (if applicable):
here I mean rawhide fc20

How reproducible:
start livecd-creator

Steps to Reproduce:
1.livecd-creator fetches repo.xmls
2.yum downloads all packages
3.after this step it stops

Actual results:
no creation is possible since 20130614

Expected results:
building a livecd which can I start in VirtualBox or on HD

Additional info:
Here the output:

Traceback (most recent call last):
File "/bin/livecd-creator", line 237, in <module>
sys.exit(main())
File "/bin/livecd-creator", lin 218, in main
creator.install()
File "/usr/lib/python2.7/site-packages/imgcreate/creator.py", line 655 in install
ayum.runInstall()
File "/usr/lib/python2.7/site-packages/imgcreate/yuminst.py", line 220, in runInstall
raise CreateError("Dependency check failed : %s" % "\n".join(deps))
TypeError: sequence item 0: expected string, tuple found

this error I had also in FC19, but it is solved
Comment 1 Manfred Blankenfeld 2013-07-06 04:07:43 EDT
yum-3.4.3-99.fc20.x86_64
livecd-tools-19.5-1.fc20.x86_64
yum-metadata-parser-1.1.4-8.fc19.x86_64
Comment 2 Brian Lane 2013-07-08 20:31:17 EDT
*** Bug 982346 has been marked as a duplicate of this bug. ***
Comment 3 Manfred Blankenfeld 2013-07-11 04:38:34 EDT
Thank you.

I have seen, that NightlyBuilds from 20130710 (i.e lxcd) cannot be installed in VirtualBox-4.2.16.
After choosing language anaconda shows the second window, but nothing goes on.

No installation, the button "continue" is not active.

ManfredB
Comment 4 Brian Lane 2013-07-11 13:41:41 EDT
*** Bug 983393 has been marked as a duplicate of this bug. ***
Comment 5 Adam Williamson 2013-07-11 20:03:27 EDT
*** Bug 983776 has been marked as a duplicate of this bug. ***
Comment 6 Adam Williamson 2013-07-11 20:04:22 EDT
Manfred: for comment #3, see https://bugzilla.redhat.com/show_bug.cgi?id=983319 , it looks like more or less the same issue.
Comment 7 Manfred Blankenfeld 2013-07-13 11:23:38 EDT
yes, so is it.

But the following points I want to add:

1. NightlyBuilds (without KDE) from 20130711 are usable to install

2. The problem are LiveCDs with KDE.

3. Today I could install FC20 with the netinstall.iso from Fedora19 - the first one. I tried it past, but kernel panic was the result.
Comment 8 Fedora Update System 2013-07-15 19:37:03 EDT
livecd-tools-17.18-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/livecd-tools-17.18-1.fc17
Comment 9 Fedora Update System 2013-07-15 19:42:02 EDT
livecd-tools-18.17-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/livecd-tools-18.17-1.fc18
Comment 10 Fedora Update System 2013-07-15 19:45:01 EDT
livecd-tools-19.6-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/livecd-tools-19.6-1.fc19
Comment 11 Manfred Blankenfeld 2013-07-16 01:13:27 EDT
Thank you!

But my bug-report is for rawhide Fedora 20.

ManfredB
Comment 12 Amit Saha 2013-07-16 01:17:36 EDT
(In reply to Manfred Blankenfeld from comment #11)
> Thank you!
> 
> But my bug-report is for rawhide Fedora 20.

I believe you can download it from here: http://koji.fedoraproject.org/koji/buildinfo?buildID=433682



> 
> ManfredB
Comment 13 Manfred Blankenfeld 2013-07-16 01:29:15 EDT
Thank you very much.

Now I can test it.

ManfredB
Comment 14 Amit Saha 2013-07-16 01:37:01 EDT
(In reply to Manfred Blankenfeld from comment #13)
> Thank you very much.
> 
> Now I can test it.

please be aware that since this is rawhide, building ISOs of the spins may not always succeed, since package dependencies may be failing...
> 
> ManfredB
Comment 15 Manfred Blankenfeld 2013-07-16 04:39:59 EDT
Yes, here is the output:

Dependency check failed: ((´mariadb-server´, ´1:5.5.31´. ´6.fc20´), (´systemd-units´, ´´), 0, 0, none)

I tried to exclude mariadb from installing, but it does not go, the same error.

ManfredB
Comment 16 nucleo 2013-07-16 13:59:13 EDT
(In reply to Manfred Blankenfeld from comment #15)
> Yes, here is the output:
> 
> Dependency check failed: ((´mariadb-server´, ´1:5.5.31´. ´6.fc20´),
> (´systemd-units´, ´´), 0, 0, none)
> 
> I tried to exclude mariadb from installing, but it does not go, the same
> error.
> 
> ManfredB

mariadb-server requires systemd-units provided by systemd
http://koji.fedoraproject.org/koji/rpminfo?rpmID=4127894

So what this error means?
Comment 17 Adam Williamson 2013-07-16 15:29:28 EDT
Not related to this bug, please don't discuss it here.

https://lists.fedoraproject.org/pipermail/devel/2013-July/185241.html
Comment 18 Fedora Update System 2013-07-16 23:01:42 EDT
Package livecd-tools-19.6-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing livecd-tools-19.6-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-13055/livecd-tools-19.6-1.fc19
then log in and leave karma (feedback).
Comment 19 Manfred Blankenfeld 2013-07-17 02:40:40 EDT
you write: systemd-units provided by systemd.

I cannot find systemd-units in systemd and also not in installed systemd on fc19.

Where is the place of the installed systemd-units of systemd?

Earlier versions of fedora had a separate systemd-units package.

But if you can locate systemd-units in an installed system of fc19,
give me the location.

ManfredB
Comment 20 nucleo 2013-07-17 05:50:55 EDT
(In reply to Manfred Blankenfeld from comment #19)
> Where is the place of the installed systemd-units of systemd?
> 
> Earlier versions of fedora had a separate systemd-units package.

No separate package systemd-units, it is now virtually provided by systemd package.
See 'repoquery --whatprovides systemd-units'.
Comment 21 Manfred Blankenfeld 2013-07-17 05:55:24 EDT
Thank you.

ManfredB
Comment 22 Manfred Blankenfeld 2013-07-18 07:36:55 EDT
One question:

Which KDE-prog or KDE-group does need mariadb-server oder mariadb?

Isn´t it possible to exclude this KDE-prog or this KDE-group?

ManfredB
Comment 23 nucleo 2013-07-18 10:28:14 EDT
(In reply to Manfred Blankenfeld from comment #22)
> Which KDE-prog or KDE-group does need mariadb-server oder mariadb?
akonadi-mysql

> Isn´t it possible to exclude this KDE-prog or this KDE-group?
you can try to exclude it but then you need to setup akonadi which driver to use (SQLite or PstthreSQL).
Comment 24 Manfred Blankenfeld 2013-07-18 14:10:40 EDT
@nucleo

thank you, now I could create a livecd.

BUT: anaconda has problems.

The output I will show in a other bug-report.

ManfredB
Comment 25 Fedora Update System 2013-08-14 22:59:33 EDT
livecd-tools-19.6-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 26 Fedora Update System 2013-09-29 20:37:51 EDT
livecd-tools-18.17-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.