Bug 982404 - QE Review: Data Services 6 Getting Started Guide - Various
QE Review: Data Services 6 Getting Started Guide - Various
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ER1
: ---
Assigned To: David Le Sage
Van Halbert
: Documentation
: 1006344 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-08 19:42 EDT by belong
Modified: 2014-02-24 13:44 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-03 20:48:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description belong 2013-07-08 19:42:08 EDT
Van Halbert 2013-07-08 08:42:44 EDT

6.3 Data Federation

In the sentence "When the test query . . . ",  change the word "can" to "will".


6.5 Web Services as a Datasource

This quick start has to be changed from using Twitter, now that Twitter changed its access to require a login.  This has been logged to Teiid.

Also, didn't see the quick start for demonstrating using Hibernate on top of Teiid.

And, there are additional quick starts currently being worked on to be added.

B1. Supported Configurations

JDG support is for version 5.2, which is delivered in EAP 6.1.

Need to add support for OData data source, OData V2 and V3, NA, odata translator type.  

Update MongoDB to use mongodb as the translator type.
Comment 1 belong 2013-07-08 19:43:29 EDT
Created from Comment 4 in 948141
Comment 2 belong 2013-09-13 01:39:34 EDT
Adding information from Bug 1006344 regarding Web Services as a Datasource:

See quick start example: https://docs.jboss.org/author/display/teiidexamples/Web+Services+as+a+Data+Source+Example

as it explains the new web service war that is deployed that Teiid will use to access.
Comment 3 belong 2013-09-13 01:40:29 EDT
*** Bug 1006344 has been marked as a duplicate of this bug. ***
Comment 4 nshendye 2013-09-13 02:10:45 EDT
Van,

Thank you for your comments. If you are happy with the changes I have made to the Getting Started Guide, please set this bug to VERIFIED.

URL: http://documentation-devel.engineering.redhat.com/docs/en-US/Red_Hat_JBoss_Data_Virtualization/6-Beta/html/Getting_Started_Guide/index.html

Regards,
Nilam


*** CHANGES ***

> 6.3 Data Federation
> 
> In the sentence "When the test query . . . ",  change the word "can" to
> "will".

>> Done.
----------------------------------------------------------------------------

> 6.5 Web Services as a Datasource
> 
> This quick start has to be changed from using Twitter, now that Twitter
> changed its access to require a login.  This has been logged to Teiid.

>> Made the changes to this topic to reflect recent changes.
-----------------------------------------------------------------------------

> Also, didn't see the quick start for demonstrating using Hibernate on top of
> Teiid.

>>Added this quickstart to Getting Started Guide.
-----------------------------------------------------------------------------
> B1. Supported Configurations
> 
> JDG support is for version 5.2, which is delivered in EAP 6.1.
> 
> Need to add support for OData data source, OData V2 and V3, NA, odata
> translator type.  
> 
> Update MongoDB to use mongodb as the translator type.

>> Done.
Comment 5 Van Halbert 2013-11-14 19:41:32 EST
The Drools Quickstart has been removed and will not be in the ER4 build.  And there's no guarantee that it will make it into the DV6 release.  Because of this, I would remove it from the documentation.
Comment 6 nshendye 2013-12-03 07:59:44 EST
Hi Van,

I have removed Drools quickstart from the Getting Started Guide.

URL: http://documentation-devel.engineering.redhat.com/docs/en-US/Red_Hat_JBoss_Data_Virtualization/6/html/Getting_Started_Guide/index.html

Regards,
Nilam
Comment 7 nshendye 2013-12-04 01:56:18 EST
Hi Van, 

Refer comment 6. If you are happy with the changes I have made to the Getting Started Guide, please set this bug to VERIFIED.

Thanks,
Nilam

Note You need to log in before you can comment on or make changes to this bug.