Bug 98251 - (TB9efd6ce0) maindialog.py:1292:on_hardwareAddButton_clicked:NameError:global name 'hardwareTypeDialog' is not defined
maindialog.py:1292:on_hardwareAddButton_clicked:NameError:global name 'hardwa...
Status: CLOSED ERRATA
Product: Red Hat Raw Hide
Classification: Retired
Component: redhat-config-network (Show other bugs)
1.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-06-29 01:41 EDT by Barry K. Nathan
Modified: 2007-04-18 12:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-11 10:10:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Barry K. Nathan 2003-06-29 01:41:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030619

Description of problem:
When I click the "New" button on the Hardware tab of r-c-n, it crashes and asks
if I want to save a crash dump.

Version-Release number of selected component (if applicable):
redhat-config-network-1.3.1-1

How reproducible:
Always

Steps to Reproduce:
1. Start r-c-n.
2. Go to the Hardware tab.
3. Click the "New" button (near the top of the window).
    

Actual Results:  r-c-n crashes

Expected Results:  I expect that r-c-n will let me configure another hardware
device.

Additional info:

Here is the "crash dump":

Component: redhat-config-network
Version: 1.3.1
Summary: TB
/usr/src/build/273296-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py:1292:on_hardwareAddButton_clicked:NameError:
global name 'hardwareTypeDialog' is not defined
Traceback (most recent call last):
  File
"/usr/src/build/273296-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 611, in on_addButton_clicked
  File
"/usr/src/build/273296-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 1292, in on_hardwareAddButton_clicked
NameError: global name 'hardwareTypeDialog' is not defined
 
Local variables in innermost frame:
self: <netconfpkg.gui.maindialog.mainDialog instance at 0x925c70c>
args: (<gtk.Button object (GtkButton) at 0x92e91ec>,)
Comment 1 Shawn Edmondson 2003-08-05 02:44:35 EDT
Happens to me too, using the patch from ftp://people.redhat.com/harald/redhat-
config-network/1.2.14-RH9/ on RH9.

Component: redhat-config-network
Version: 1.2.14
Summary: TB9efd6ce0 maindialog.py:1291:on_hardwareAddButton_clicked:NameError: 
global name 'hardwareTypeDialog' is not defined
Traceback (most recent call last):
  File "/var/tmp/redhat-config-network-1.2.14-root/usr/share/redhat-config-
network/netconfpkg/gui/maindialog.py", line 610, in on_addButton_clicked
  File "/var/tmp/redhat-config-network-1.2.14-root/usr/share/redhat-config-
network/netconfpkg/gui/maindialog.py", line 1291, in 
on_hardwareAddButton_clicked
NameError: global name 'hardwareTypeDialog' is not defined

Local variables in innermost frame:
self: <netconfpkg.gui.maindialog.mainDialog instance at 0x8398684>
args: (<gtk.Button object (GtkButton) at 0x86117fc>,)
Comment 2 Harald Hoyer 2003-08-06 05:33:26 EDT
hmm, I cannot reproduce this... Do you have reiserfs by any chance?
Comment 3 Shawn Edmondson 2003-08-06 07:45:02 EDT
Thanks for the reply.

Yes, how about that, I'm running ReiserFS.  Otherwise it's a stock 
RH9 "everything" install on a Dell C840 laptop.  Trying to bring up two 100Mb 
enets and one PCMCIA Lucentish wireless.
Comment 4 Harald Hoyer 2003-08-06 07:58:27 EDT
very strange... such bugreports only come from reiserfs users...
Comment 5 Harald Hoyer 2003-08-06 09:19:10 EDT
please try
ftp://people.redhat.com/harald/redhat-config-network/1.2.15-RH9

the new rawhide version will soon be out..
Comment 6 Shawn Edmondson 2003-08-08 10:29:23 EDT
With 1.2.15, it works perfectly.  The Hardware page automatically displayed the 
correct hardware, and I easily added new devices without error.

Thanks for the great support.
Comment 7 Harald Hoyer 2003-08-11 06:20:30 EDT
well, thx for the bug reports... other users will appreciate the bugfix :)
Comment 8 Harald Hoyer 2003-08-11 10:10:33 EDT
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2003-183.html

Note You need to log in before you can comment on or make changes to this bug.