Bug 982637 - integration.jca.moduledeployment failing tests
integration.jca.moduledeployment failing tests
Status: CLOSED DUPLICATE of bug 985003
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Testsuite (Show other bugs)
6.1.1
Unspecified Unspecified
high Severity high
: ---
: EAP 6.2.0
Assigned To: Pavel Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-09 09:16 EDT by Aleksandar Kostadinov
Modified: 2013-12-15 08:31 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-30 08:20:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error message from InflowJarTestCase.testRegistryConfiguration (25.14 KB, text/plain)
2013-07-09 09:18 EDT, Aleksandar Kostadinov
no flags Details
NameNotFoundException from MultiObjectActivationJarTestCase.testAdminObject (15.47 KB, text/plain)
2013-07-09 09:20 EDT, Aleksandar Kostadinov
no flags Details

  None (edit)
Description Aleksandar Kostadinov 2013-07-09 09:16:25 EDT
Running EAP 6.1.1 ER2 test suite I see these tests very often fail:

> org.jboss.as.test.integration.jca.moduledeployment.MultiObjectActivationJarTestCase
> .testAdminObject
> .testAdminObject1
> .testConnectionFactory
> .testConnectionFactory1
> .testConnections
> .testProperties
> .testProperties2
> .testAdminObject
> .testAdminObject1
> .testConnectionFactory
> .testConnectionFactory1
> .testRegistryConfiguration
hope I got these complete

Also
> org.jboss.as.test.integration.ws.wsa.TestRequiredAddressingTestCase
> .usingLocalWSDLWithOptionalAddressing
> .usingLocalWSDLWithAddressing

There are two kind of failures I see (see attached) but I think they are at least related. I see closed bug 910387, it highly likely is also related.

Reference test jobs:
https://jenkins.mw.lab.eng.bos.redhat.com/hudson/job/eap-61-smoketest-as-testsuite-RHEL6_x86-local-repo-PoC/
https://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/EAP6/view/EAP6-AS-Testsuite/job/eap-60-as-testsuite-RHEL-matrix-OracleJDK6
https://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/EAP6/view/EAP6-AS-Testsuite/job/eap-60-as-testsuite-RHEL-matrix-openJDK6
Comment 1 Aleksandar Kostadinov 2013-07-09 09:18:12 EDT
Created attachment 771015 [details]
error message from InflowJarTestCase.testRegistryConfiguration
Comment 2 Aleksandar Kostadinov 2013-07-09 09:20:11 EDT
Created attachment 771016 [details]
NameNotFoundException from MultiObjectActivationJarTestCase.testAdminObject
Comment 3 Pavel Jelinek 2013-08-12 07:19:25 EDT
Often repeated intermittent fail in testsuite.
Comment 4 Ivo Studensky 2013-08-30 08:20:33 EDT
This should be fixed by https://bugzilla.redhat.com/show_bug.cgi?id=985003.
Feel free to re-open it if happens again.

*** This bug has been marked as a duplicate of bug 985003 ***

Note You need to log in before you can comment on or make changes to this bug.