Bug 982683 - jpackage-utils: support for OpenJDK 8
jpackage-utils: support for OpenJDK 8
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: jpackage-utils (Show other bugs)
19
Unspecified Unspecified
high Severity unspecified
: ---
: ---
Assigned To: Mikolaj Izdebski
Fedora Extras Quality Assurance
: FutureFeature, Triaged
: 983394 (view as bug list)
Depends On:
Blocks: 1149605
  Show dependency treegraph
 
Reported: 2013-07-09 10:50 EDT by Florian Weimer
Modified: 2014-10-16 02:32 EDT (History)
6 users (show)

See Also:
Fixed In Version: 1.7.5-27
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 1149605 (view as bug list)
Environment:
Last Closed: 2013-07-22 23:27:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
jpackage-utils-openjdk8.patch (919 bytes, patch)
2013-07-09 10:50 EDT, Florian Weimer
no flags Details | Diff

  None (edit)
Description Florian Weimer 2013-07-09 10:50:39 EDT
Created attachment 771070 [details]
jpackage-utils-openjdk8.patch

OpenJDK 8 changes the output format for java -fullversion, so the attached patch is needed.

Furthermore, the spec file needs to create both 1.8.0 directories:

@@ -115,10 +117,10 @@ install -dm 755 ${RPM_BUILD_ROOT}${_jvmcommonsysconfdir}
 install -dm 755 ${RPM_BUILD_ROOT}${_javadir}
 install -dm 755 ${RPM_BUILD_ROOT}${_javadir}-utils
 install -dm 755 ${RPM_BUILD_ROOT}${_javadir}-ext
-install -dm 755 ${RPM_BUILD_ROOT}${_javadir}-{1.5.0,1.6.0,1.7.0}
+install -dm 755 ${RPM_BUILD_ROOT}${_javadir}-{1.5.0,1.6.0,1.7.0,1.8.0}
 install -dm 755 ${RPM_BUILD_ROOT}${_jnidir}
 install -dm 755 ${RPM_BUILD_ROOT}${_jnidir}-ext
-install -dm 755 ${RPM_BUILD_ROOT}${_jnidir}-{1.5.0,1.6.0,1.7.0}
+install -dm 755 ${RPM_BUILD_ROOT}${_jnidir}-{1.5.0,1.6.0,1.7.0,1.8.0}
 install -dm 755 ${RPM_BUILD_ROOT}${_javadocdir}
 install -dm 755 ${RPM_BUILD_ROOT}${_mavenpomdir}
 install -dm 755 ${RPM_BUILD_ROOT}${_mavendepmapdir}
Comment 1 Fedora Admin XMLRPC Client 2013-07-10 10:11:27 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Mikolaj Izdebski 2013-07-11 04:13:42 EDT
*** Bug 983394 has been marked as a duplicate of this bug. ***
Comment 3 Mikolaj Izdebski 2013-07-11 08:55:34 EDT
Fixed in jpackage-utils-1.7.5-27
Comment 4 Fedora Update System 2013-07-11 09:02:11 EDT
jpackage-utils-1.7.5-27.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/jpackage-utils-1.7.5-27.fc19
Comment 5 Fedora Update System 2013-07-22 21:12:21 EDT
jpackage-utils-1.7.5-27.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Mikolaj Izdebski 2013-07-22 23:27:26 EDT
I believe that this bug is fixed in jpackage-utils-1.7.5-27,
which is available in updates for Fedora 19, so I am closing this bug now.

The build containing the fix can be found at Koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=432788

Note You need to log in before you can comment on or make changes to this bug.