Bug 1149605 - jpackage-utils: support for OpenJDK 8
Summary: jpackage-utils: support for OpenJDK 8
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: jpackage-utils
Version: 6.6
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Mikolaj Izdebski
QA Contact: Martin Frodl
Russell Dickenson
URL:
Whiteboard:
: 1152598 1208832 (view as bug list)
Depends On: 982683
Blocks: 1159824
TreeView+ depends on / blocked
 
Reported: 2014-10-06 08:12 UTC by Alon Bar-Lev
Modified: 2019-07-11 08:14 UTC (History)
21 users (show)

Fixed In Version: 1.7.5-3.13
Doc Type: Release Note
Doc Text:
Support for OpenJDK 8 added to JPackage Utilities OpenJDK 8 was added to RHEL 6.6 but system Java applications were not able to be run with it due to lack of OpenJDK 8 support in the _jpackage-utils_ package. This has been resolved, and the RHEL 6.7 _jpackage-utils_ package includes support for system applications to be run with OpenJDK 8.
Clone Of: 982683
Environment:
Last Closed: 2015-07-22 05:55:05 UTC


Attachments (Terms of Use)
Proposed patch (3.69 KB, patch)
2014-10-21 08:14 UTC, Mikolaj Izdebski
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:1248 normal SHIPPED_LIVE jpackage-utils enhancement update 2015-07-20 17:50:14 UTC
Red Hat Bugzilla 982683 None CLOSED jpackage-utils: support for OpenJDK 8 2019-03-13 09:43:00 UTC

Internal Links: 982683

Description Alon Bar-Lev 2014-10-06 08:12:16 UTC
+++ This bug was initially created as a clone of Bug #982683 +++

OpenJDK 8 changes the output format for java -fullversion, so the attached patch is needed.

Furthermore, the spec file needs to create both 1.8.0 directories:

@@ -115,10 +117,10 @@ install -dm 755 ${RPM_BUILD_ROOT}${_jvmcommonsysconfdir}
 install -dm 755 ${RPM_BUILD_ROOT}${_javadir}
 install -dm 755 ${RPM_BUILD_ROOT}${_javadir}-utils
 install -dm 755 ${RPM_BUILD_ROOT}${_javadir}-ext
-install -dm 755 ${RPM_BUILD_ROOT}${_javadir}-{1.5.0,1.6.0,1.7.0}
+install -dm 755 ${RPM_BUILD_ROOT}${_javadir}-{1.5.0,1.6.0,1.7.0,1.8.0}
 install -dm 755 ${RPM_BUILD_ROOT}${_jnidir}
 install -dm 755 ${RPM_BUILD_ROOT}${_jnidir}-ext
-install -dm 755 ${RPM_BUILD_ROOT}${_jnidir}-{1.5.0,1.6.0,1.7.0}
+install -dm 755 ${RPM_BUILD_ROOT}${_jnidir}-{1.5.0,1.6.0,1.7.0,1.8.0}
 install -dm 755 ${RPM_BUILD_ROOT}${_javadocdir}
 install -dm 755 ${RPM_BUILD_ROOT}${_mavenpomdir}
 install -dm 755 ${RPM_BUILD_ROOT}${_mavendepmapdir}

--- Additional comment from Fedora Admin XMLRPC Client on 2013-07-10 10:11:27 EDT ---

This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

--- Additional comment from Mikolaj Izdebski on 2013-07-11 04:13:42 EDT ---



--- Additional comment from Mikolaj Izdebski on 2013-07-11 08:55:34 EDT ---

Fixed in jpackage-utils-1.7.5-27

--- Additional comment from Fedora Update System on 2013-07-11 09:02:11 EDT ---

jpackage-utils-1.7.5-27.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/jpackage-utils-1.7.5-27.fc19

--- Additional comment from Fedora Update System on 2013-07-22 21:12:21 EDT ---

jpackage-utils-1.7.5-27.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

--- Additional comment from Mikolaj Izdebski on 2013-07-22 23:27:26 EDT ---

I believe that this bug is fixed in jpackage-utils-1.7.5-27,
which is available in updates for Fedora 19, so I am closing this bug now.

The build containing the fix can be found at Koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=432788

Comment 1 Alon Bar-Lev 2014-10-06 08:14:35 UTC
Cloned to to failures in brew to use build-classpath using rhel-6 candidate.

/usr/bin/build-classpath: error: JAVAVER_LIBDIR /usr/share/java- does not exist or is not a directory

Comment 2 Javier Ramirez 2014-10-15 15:38:16 UTC
A customer also reported this possible solution:

-----

The problem is that jpackage-utils is not yet prepared for Java 8.

You have top add to your rpm jpackage-utils:
/usr/share/java-1.8.0
/usr/lib/java-1.8.0

And the difference of Java 7 and Java 8 is:

# /etc/alternatives/jre_1.7.0/bin/java -version
java version "1.7.0_65"
[...]
# /etc/alternatives/jre_1.8.0/bin/java -version
openjdk version "1.8.0_20"
[...]

Your script /usr/share/java-utils/java-functions has problems with "openjdk version" because it expects "java version" as Java 7 does.

# mkdir /usr/share/java-1.8.0
# mkdir /usr/lib/java-1.8.0
# diff /usr/share/java-utils/java-functions.orig /usr/share/java-utils/java-functions
149,150c149,150
<             -e '/java \(full \)*version "/s/'$re'/<<<\1>>>/' \
<             -e '/java \(full \)*version "/s/.*<<<\([^>]\{1,\}\)>>>.*/\1/p')
---
>             -e '/[java|openjdk] \(full \)*version "/s/'$re'/<<<\1>>>/' \
>             -e '/[java|openjdk] \(full \)*version "/s/.*<<<\([^>]\{1,\}\)>>>.*/\1/p')

------

Comment 3 Florian Weimer 2014-10-15 19:53:09 UTC
This was fixed in Fedora as bug 982683.

Comment 4 Devan Goodwin 2014-10-20 13:18:27 UTC
We're quite blocked on some builds in the absence of this, any chance we could bump the priority?

Comment 7 Mikolaj Izdebski 2014-10-21 08:14:06 UTC
Created attachment 948839 [details]
Proposed patch

Comment 8 Mikolaj Izdebski 2014-10-21 08:53:31 UTC
Reproducer:
# yum install java-1.8.0-openjdk-devel ant
$ JAVA_HOME=/usr/lib/jvm/java-1.8.0 ant -version

Expected results:
Apache Ant version 1.7.1 compiled on April 26 2010

Actual results:
Error: Could not find or load main class org.apache.tools.ant.launch.Launcher

Comment 9 Mikolaj Izdebski 2014-10-21 08:55:43 UTC
*** Bug 1152598 has been marked as a duplicate of this bug. ***

Comment 29 Mikolaj Izdebski 2014-11-28 11:54:19 UTC
Fixed in jpackage-utils-1.7.5-3.13

Comment 32 Stephen Gilson 2015-04-02 16:55:34 UTC
CCS has determined that this bug should be described in the RHEL 6.7 Release Notes. Please update the Doc Text field with a summary feature description.

Comment 33 Mikolaj Izdebski 2015-04-03 11:05:00 UTC
*** Bug 1208832 has been marked as a duplicate of this bug. ***

Comment 35 errata-xmlrpc 2015-07-22 05:55:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-1248.html


Note You need to log in before you can comment on or make changes to this bug.