Bug 982940 - [virtio-win][netkvm]NetKVMConfig can not modify the parameter "init.ConnetctionRate(Mb)" to 1G correctly
Summary: [virtio-win][netkvm]NetKVMConfig can not modify the parameter "init.Connetcti...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win
Version: 6.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Yan Vugenfirer
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-10 07:50 UTC by lijin
Modified: 2013-12-06 08:06 UTC (History)
5 users (show)

(edit)
Cause: 
Bug in INF file incorrectly indicated 1G connection rate.

Consequence: 
While the connection rate could be set from device manager, it was impossible to set 1G rate using command line tool (netsh with NetKVM plugin).

Fix: 
Set the correct connection rate in INF file

Result: 
NetSH can set NIC connection rate correctly.
Clone Of:
(edit)
Last Closed: 2013-11-22 00:14:08 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1729 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2013-11-21 00:39:25 UTC

Description lijin 2013-07-10 07:50:43 UTC
Description of problem:
the value of "init.ConnetctionRate(Mb)" cannot be set to 1G with command "netsh netkvm setparam 0 ConnectRate 1000",but can be set to 1G correctly with command "netsh netkvm setparam 0 ConnectRate 1001",seems there is a little mistake.

Version-Release number of selected component (if applicable):
virtio-win-prewhql-65
kernel-2.6.32-393.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.377.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.boot a win2012 guest with virtio-net-pci
2.Registration in NetSH (instllation):
   1).cmd --> run as administrator
   2).cd path-to-the-netkvm-driver
   3).rundll32 netkvmco.dll,RegisterNetKVMNetShHelper
3.get the index of virtio-net-pci:
   netsh netkvm show devices
4.Read NetKVM parameter value
  netsh netkvm getparam 0 param=ConnectRate
5.Modify NetKVM parameter value to 100M and check the value from device manager
  netsh netkvm setparam 0 ConnectRate 100
6.Modify NetKVM parameter value to 10G and check the value from device manager
  netsh netkvm setparam 0 ConnectRate 10000
7.Modify NetKVM parameter value to 1G and check the value from device manager
  netsh netkvm setparam 0 ConnectRate 1000
8.netsh netkvm setparam 0 ConnectRate 1001


Actual results:
after step6,all values can be set correctly;
after step7,it prompts in cmd that "The parameter is incorrect";
after step8,the command can be execute successfully and from the device manager the value of "init.ConnetctionRate(Mb" has been set to 1G

Expected results:
the value of "init.ConnetctionRate(Mb" can be set to 1G with step7 instead of step8.

Additional info:

Comment 4 Yan Vugenfirer 2013-07-29 12:15:56 UTC
Fixed for OSes Vista and up.

Comment 5 lijin 2013-08-08 06:57:16 UTC
win2012,win2k8R2,win2k8-64,win8-64,win7-64,

win7-32,win8-32,win2k8-32

Reproduced this issue on build65
Verified this issue on build66

steps same as comment #0

Actual Results:
On build65, after "netsh netkvm setparam 0 ConnectRate 1000",it prompt "The parameter is incorrect";
On build66,win2012,win2k8R2,win2k8-64,win8-64 and win7-64 can set the connectrate to 1G correctly;as for guest win7-32,win8-32 and win2k8-32,there is bug 988302 to track another issue.

Based on above,this issue has been fixed already.

Comment 6 Mike Cao 2013-08-20 12:29:27 UTC
Move status to VERIFIED according to comment #5

Comment 8 errata-xmlrpc 2013-11-22 00:14:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1729.html


Note You need to log in before you can comment on or make changes to this bug.