Bug 98300 - new update breaks mail.aliases
new update breaks mail.aliases
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: ypserv (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-30 14:52 EDT by Joe Pruett
Modified: 2007-04-18 12:55 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-04 16:21:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Pruett 2003-06-30 14:52:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030507

Description of problem:
the new makedbm creates maps with spaces on the ends of keys.  the -a option to
makdebm tries to cope with the various formats that alias entries can have, but
chokes on the most common:

alias: real

it creates a key of 'alias ' and data of 'real'.  a workaround is to use:

alias:real

or:

alias real

but the latter doesn't work if real is a :include:file entry.  

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. create mail.aliases from standard /etc/aliases
2. ypmatch ftp mail.aliases
3. ypmatch 'ftp ' mail.aliases
    

Actual Results:  #2 fails, #3 works.

Expected Results:  #2 should work and #3 should fail.

Additional info:
Comment 1 Joe Pruett 2003-07-01 12:53:55 EDT
actually, makedbm seems to be broken in a number of ways.  my netgroup map was broken after the upgrade as well.  i have large groups done as:



netgroup \

        (a,b,c) \

        (d,e,f)



with various kinds of whitespace after netgroup and on each continuation line.  i finally had to go to:

netgroup<tab>\

        etc



to make things work.
Comment 2 zwlu 2003-07-07 00:56:14 EDT
ypserv-2.8-0.80E breaks mail.aliases on Redhat 8 and Redhat 9.

alias:<TAB>value
"alias" will actutally become "alias " (one space)
ypmatch -k alias mail.alias will fail
ypmatch -k "alias " mail.alias  gives
alias  value

while
alias:<spaces>value
works just fine 
that is
ypmatch -k alias mail.aliases give
alias value
Comment 3 Todd Allen 2003-11-12 12:29:49 EST
I've encountered this problem with the Redhat 9 update ypserv-2.8-0.9E.

Rather than try to workaround it by coddling makedbm with aliases
files that are to its liking, I decided to back up to an earlier
version of ypserv's makedbm.

The makedbm in stock RedHat 9's ypserv suffers from the same problem.

But the makedbm from RedHat 8.0's ypserv-2.5-1 doesn't.  I installed
that in place of the broken one in /usr/lib/yp.  It doesn't exhibit
this busted behavior, and the files it produces appear to be
compatible with ypserv-2.8-0.9E.

BTW, it looks like bug 99479 could be another instance of this same bug.
Comment 4 Steve Dickson 2004-10-15 08:27:20 EDT
Fixed in ypserv-2.8-0.9E
Comment 5 Bill Nottingham 2006-08-04 16:21:50 EDT
Red Hat Linux and Red Hat Powertools are currently no longer supported by Red
Hat, Inc. In an effort to clean up bugzilla, we are closing all bugs in MODIFIED
state for these products.

However, we do want to make sure that nothing important slips through the
cracks. If, in fact, these issues are not resolved in a current Fedora Core
Release (such as Fedora Core 5), please open a new issues stating so. Thanks.

Note You need to log in before you can comment on or make changes to this bug.