Bug 983052 - [PATCH] gogoc linux.sh template scrapes ifconfig output improperly
[PATCH] gogoc linux.sh template scrapes ifconfig output improperly
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gogoc (Show other bugs)
19
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Juan Orti
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-10 07:43 EDT by "FeRD" (Frank Dana)
Modified: 2013-07-21 20:35 EDT (History)
1 user (show)

See Also:
Fixed In Version: gogoc-1.2-26.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-21 20:35:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for template/linux.sh to correctly scrape ifconfig output (2.20 KB, patch)
2013-07-10 07:43 EDT, "FeRD" (Frank Dana)
no flags Details | Diff

  None (edit)
Description "FeRD" (Frank Dana) 2013-07-10 07:43:27 EDT
Created attachment 771562 [details]
Patch for template/linux.sh to correctly scrape ifconfig output

Description of problem:
The gogoc client runs a script /etc/gogoc/template/linux.sh to configure the network upon successfully authenticating to the tunnelbroker. This script parses the output of ifconfig to determine configured interface addresses and adjust them accordingly. However, its assumptions about the format of ifconfig output are out of date, causing the script to fail before completion.

The attached patch properly scrapes the output of ifconfig, so that valid command invocations are constructed from the results.

Version-Release number of selected component (if applicable):
gogoc-1.2-25.fc19.i686

Additional info:
Note that the scraping has actually been broken since the ifconfig format changed in Fedora 17 (and this breakage predicted at the time) — see rhbz #784314. However, I suspect the ifconfig command was previously more input-tolerant, for instance accepting 'ifconfig tun del ip:v6:addr' commands without a prefix length, so the broken scraping was still "good enough". This is no longer true in some cases, and anyway it makes sense that gogoc handle the current format completely and correctly.
Comment 1 Juan Orti 2013-07-12 10:39:24 EDT
Thank you for reporting, I've checked your patch and seems correct.
Comment 2 Fedora Update System 2013-07-12 10:59:02 EDT
gogoc-1.2-26.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/gogoc-1.2-26.fc19
Comment 3 "FeRD" (Frank Dana) 2013-07-12 15:52:44 EDT
Agreed, I downloaded & installed the gogoc-1.2-26.fc19 build and everything looks good. Thanks!
Comment 4 Fedora Update System 2013-07-12 17:46:53 EDT
gogoc-1.2-26.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/gogoc-1.2-26.fc18
Comment 5 Fedora Update System 2013-07-12 21:50:03 EDT
Package gogoc-1.2-26.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gogoc-1.2-26.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-12880/gogoc-1.2-26.fc19
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2013-07-21 20:33:18 EDT
gogoc-1.2-26.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2013-07-21 20:35:14 EDT
gogoc-1.2-26.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.