Bug 983317 - add 'get' option to view all volume options
add 'get' option to view all volume options
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: cli (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Atin Mukherjee
:
: 1119209 (view as bug list)
Depends On:
Blocks: 962570
  Show dependency treegraph
 
Reported: 2013-07-10 20:24 EDT by Todd Stansell
Modified: 2015-05-14 13:42 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.7.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-05-14 13:25:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Todd Stansell 2013-07-10 20:24:28 EDT
This is a feature request to add the ability to query volumes for the values of all available options.  I'm thinking about something very similar to 'zfs get', where it would show the option you are asking for (a list of them or all of them) as well as if it was the default value or not.  It's a bit non-intuitive to have to run 'volume set help' to understand what the default values are and then run 'volume info' to see any overrides.

It would be great to be able to do something like:

  # gluster volume get [all|<vol>] [all | <option> ...] | grep timeout

to be able to quickly and easily see what all timeouts are set to.  This would also give a clean and concise way of seeing all possible options you can set what their defaults are without having to parse the multi-line output of 'set help'.

Todd
Comment 1 Kaushal 2014-07-25 03:30:08 EDT
*** Bug 1119209 has been marked as a duplicate of this bug. ***
Comment 2 Kaushal 2014-07-25 03:32:58 EDT
Patch is under review at https://review.gluster.org/8305
Comment 3 Anand Avati 2014-07-28 05:19:25 EDT
REVIEW: http://review.gluster.org/8305 (cli/glusterd: Support of volume get for a specific volume option) posted (#6) for review on master by Atin Mukherjee (amukherj@redhat.com)
Comment 4 Anand Avati 2014-08-25 02:28:16 EDT
REVIEW: http://review.gluster.org/8305 (cli/glusterd: Support of volume get for a specific volume option) posted (#7) for review on master by Atin Mukherjee (amukherj@redhat.com)
Comment 5 Anand Avati 2014-08-26 07:17:55 EDT
COMMIT: http://review.gluster.org/8305 committed in master by Kaushal M (kaushal@redhat.com) 
------
commit c080403393987f807b9ca81be140618fa5e994f1
Author: Atin Mukherjee <amukherj@redhat.com>
Date:   Mon Jun 30 10:33:25 2014 +0530

    cli/glusterd: Support of volume get for a specific volume option
    
    This patch introduces a cli command to display a specific volume option/all
    volume options of a specific volume with the following usage:
    
    Usage: volume get <VOLNAME> <key|all>
    
    Change-Id: Ic88edb33c5509d7a37cd5ade6341e45e3cdbf59d
    BUG: 983317
    Signed-off-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-on: http://review.gluster.org/8305
    Reviewed-by: Kaushal M <kaushal@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 6 Anand Avati 2014-08-26 17:43:44 EDT
REVIEW: http://review.gluster.org/8546 (glusterd: Add xml specific functions in HAVE_LIB_XML block) posted (#2) for review on master by Harshavardhana (harsha@harshavardhana.net)
Comment 7 Anand Avati 2014-08-27 02:24:14 EDT
COMMIT: http://review.gluster.org/8546 committed in master by Kaushal M (kaushal@redhat.com) 
------
commit 861f65463708aedb20f1634c8b3214facc68348c
Author: Harshavardhana <harsha@harshavardhana.net>
Date:   Tue Aug 26 14:40:01 2014 -0700

    glusterd: Add xml specific functions in HAVE_LIB_XML block
    
    Build failure on OSX and also on Linux with '--disable-xml-output'
    introduced in following commit "c080403393987f807b9ca81be140618fa5e994f1"
    
    Change-Id: I0db92c9f5e319dc1932bed9ecc1acc98adb57de3
    BUG: 983317
    Signed-off-by: Harshavardhana <harsha@harshavardhana.net>
    Reviewed-on: http://review.gluster.org/8546
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaushal M <kaushal@redhat.com>
Comment 10 Niels de Vos 2015-05-14 13:25:32 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 11 Niels de Vos 2015-05-14 13:35:26 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 12 Niels de Vos 2015-05-14 13:37:47 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 13 Niels de Vos 2015-05-14 13:42:17 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.