Bug 983393 - livecd-creator crashes with a TypeError
livecd-creator crashes with a TypeError
Status: CLOSED DUPLICATE of bug 979759
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-11 02:46 EDT by Amit Saha
Modified: 2015-07-26 18:15 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-11 13:41:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amit Saha 2013-07-11 02:46:11 EDT
Description of problem:

While trying to build a an ISO, here is what I get:

Traceback (most recent call last):
  File "/usr/bin/livecd-creator", line 237, in <module>
    sys.exit(main())
  File "/usr/bin/livecd-creator", line 218, in main
    creator.install()
  File "/usr/lib/python2.7/site-packages/imgcreate/creator.py", line 655, in install
    ayum.runInstall()
  File "/usr/lib/python2.7/site-packages/imgcreate/yuminst.py", line 221, in runInstall
    raise CreatorError("Dependency check failed : %s" % "\n".join([dep[0] for dep in deps]))
TypeError: sequence item 0: expected string, tuple found


The reason is this line:
CreatorError("Dependency check failed : %s" % "\n".join([dep[0] for dep in deps]))

And it breaks because:

deps = [(('mariadb-server', '1:5.5.31', '6.fc20'), ('systemd-units', ''), 0, 0, None)]

The list items are expected to be strings, rather than tuples, iiuc.


Version-Release number of selected component (if applicable):

livecd-tools-19.5-1.fc19.x86_64

How reproducible:

Always.


Steps to Reproduce:
1. Download kickstart file from https://gist.github.com/amitsaha/5973063/raw/e5b24da0af21179dd78636174e0798fbb6519763/fedora_20_livedvd_scientific.ks
2. Place it in a clone of spin-kickstarts dir
3. livecd-creator <above ks file>

Actual results:

Crash as above.

Expected results:

Error out saying "Dependency check failed". Do not crash with a TypeError.


Additional info:
Comment 1 Amit Saha 2013-07-11 03:18:02 EDT
FWIW, upgraded to rawhide and get the same error.

livecd-tools-19.5-1.fc20.x86_64
Comment 2 Brian Lane 2013-07-11 13:41:41 EDT
Fixed in commit 5e447177b43 it will be in the next build.

*** This bug has been marked as a duplicate of bug 979759 ***
Comment 3 Amit Saha 2013-07-11 21:55:09 EDT
Thanks Brian.

Note You need to log in before you can comment on or make changes to this bug.