Bug 983440 - KMS not enabled in kernel and nouveau driver works degraded
KMS not enabled in kernel and nouveau driver works degraded
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
i686 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-11 04:47 EDT by deflexor
Modified: 2014-08-13 07:54 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1129636 (view as bug list)
Environment:
Last Closed: 2013-09-30 10:07:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log of X server (35.62 KB, text/x-log)
2013-07-11 04:47 EDT, deflexor
no flags Details
dmesg (70.89 KB, text/plain)
2013-09-30 06:05 EDT, deflexor
no flags Details

  None (edit)
Description deflexor 2013-07-11 04:47:42 EDT
Created attachment 772084 [details]
log of X server

Description of problem:

After latest update in Fedora 18 to kernel 3.9 screen resolution dropped to 1024x768 and xorg don't see higher resolutions. Also following errrors appeared in Xorg.0.log:

(EE) [drm] KMS not enabled
(EE) open /dev/dri/card0: No such file or directory
(EE) open /dev/fb0: No such file or directory

The same behaviour appears to be in Fedora 19.

When downgraded to older 3.6.10 kernel the problem disappeared.

Version-Release number of selected component (if applicable):

kernel 3.9.6-200.fc18
xorg-x11-drv-nouveau 1.0.7-1.fc18


How reproducible:

Just boot after upgrade.

Steps to Reproduce:
1. Install Fedora 18
2. run yum update

OR

1. Install Fedora 19

Actual results:

Low screen resolution 1024x768 and no way to make it higher

Expected results:

Natvie screen resolution 1680x1050
Comment 1 Ben Skeggs 2013-09-16 20:38:21 EDT
Post your dmesg output please.
Comment 2 John Ellson 2013-09-27 15:42:27 EDT
I had this problem after fedup to fedora 20.

My problem was caused by having nomodeset on the kernel command line.
 
That should have been removed when I removed the nvidia rpms, but I think they failed to clean up because I'm getting errors from grub2-mkconfig:

    ERROR: sil: invalid metadata checksum in area 3 on /dev/dm-1

According to Google, that is the result of filesystem corruptions caused by kernel suspend mode, which seems possible since I did suspend the laptop by accident recently.

There are reports of this kernel bug going back to 2010 -  apparently not fixed yet.
Comment 3 deflexor 2013-09-30 06:05:03 EDT
Created attachment 805063 [details]
dmesg

dmesg output
Comment 4 deflexor 2013-09-30 06:07:12 EDT
Also tried to boot from F20 alfa4 liveCD and problem has gone. So it looks like this bug implicitly fixed in Fedora 20.
Comment 5 Ben Skeggs 2013-09-30 07:11:25 EDT
Yeah, not a nouveau bug either.  When the kernel hands control of the device to us, the device hasn't been correctly enabled (all our register accesses time out).
Comment 6 Josh Boyer 2013-09-30 10:07:57 EDT
(In reply to Ben Skeggs from comment #5)
> Yeah, not a nouveau bug either.  When the kernel hands control of the device
> to us, the device hasn't been correctly enabled (all our register accesses
> time out).

Which could mean it's a bug in the nouveau kernel driver.  But since it's fixed in F20, that's good enough.
Comment 7 aon.913838005 2014-08-13 06:34:39 EDT
problem reproduced on Fedora 20 with ASUS G75VW notebook
I can confirm this issue. I have installed Fedora 20 on an ASUS G75VW notebook with kernel-3.11.10-301.fc20.x86_64 and was running 1920x1080 screen resolution. I just did an update (yum update) to kernel-3.15.8-200.fc20.x86_64 and failed back to screen resolution 1024x768 without changing anything else.

[root@asus-g75vw log]# egrep -i "boot_image|kms" Xorg.0.log*
Xorg.0.log:[     4.568] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.11.10-301.fc20.x86_64 root=UUID=2ed93c50-4bff-4033-a6ae-a1fb949fb6d5 ro vconsole.font=latarcyrheb-sun16 rhgb quiet LANG=en_US.UTF-8
Xorg.0.log:[     4.579] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
Xorg.0.log.old:[     4.277] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.15.8-200.fc20.x86_64 root=UUID=2ed93c50-4bff-4033-a6ae-a1fb949fb6d5 ro vconsole.font=latarcyrheb-sun16 rhgb quiet LANG=en_US.UTF-8
Xorg.0.log.old:[     4.282] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
Xorg.0.log.old:[     4.288] (EE) [drm] KMS not enabled
[root@asus-g75vw log]# 

[root@asus-g75vw log]# lspci | grep VGA 
01:00.0 VGA compatible controller: NVIDIA Corporation GK107M [GeForce GTX 660M] (rev a1) 
[root@asus-g75vw log]#

On a desktop PC running also kernel-3.15.8-200.fc20.x86_64 with NVIDIA graphics card I can not reproduce the problem

[itsme@mypc01 log]$ lspci | grep -i vga
01:00.0 VGA compatible controller: NVIDIA Corporation GK107 [GeForce GT 640] (rev a1)
[itsme@mypc01 log]$ egrep -i "boot_image|kms" Xorg.0.log*
Xorg.0.log:[     4.032] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.15.8-200.fc20.x86_64 root=UUID=37b4cca8-2239-4557-98c1-f41150eebcc7 ro biosdevname=0 net.ifnames=0 vconsole.font=latarcyrheb-sun16 rhgb quiet
Xorg.0.log:[     4.035] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
Xorg.0.log.old:[     4.267] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.15.8-200.fc20.x86_64 root=UUID=37b4cca8-2239-4557-98c1-f41150eebcc7 ro biosdevname=0 net.ifnames=0 vconsole.font=latarcyrheb-sun16 rhgb quiet
Xorg.0.log.old:[     4.270] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[itsme@mypc01 log]$
Comment 8 aon.913838005 2014-08-13 07:49:01 EDT
extract from dmesg (Fedora 20, 3.15.8-200.fc20.x86_64)

[    1.138057] ACPI Warning: \_SB_.PCI0.PEG0.GFX0._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140214/nsarguments-95)
[    1.138074] ACPI: \_SB_.PCI0.PEG0.GFX0: failed to evaluate _DSM
[    1.138332] nouveau  [  DEVICE][0000:01:00.0] BOOT0  : 0x0e7140a2
[    1.138335] nouveau  [  DEVICE][0000:01:00.0] Chipset: GK107 (NVE7)
[    1.138336] nouveau  [  DEVICE][0000:01:00.0] Family : NVE0
[    1.138360] nouveau  [   VBIOS][0000:01:00.0] checking PRAMIN for image...
[    1.138366] nouveau  [   VBIOS][0000:01:00.0] ... signature not found
[    1.138367] nouveau  [   VBIOS][0000:01:00.0] checking PROM for image...
[    1.138399] nouveau  [   VBIOS][0000:01:00.0] ... signature not found
[    1.138401] nouveau  [   VBIOS][0000:01:00.0] checking ACPI for image...
[    1.164470] nouveau  [   VBIOS][0000:01:00.0] ... appears to be valid
[    1.164475] nouveau  [   VBIOS][0000:01:00.0] using image from ACPI
[    1.164630] nouveau  [   VBIOS][0000:01:00.0] BIT signature found
[    1.164634] nouveau  [   VBIOS][0000:01:00.0] version 80.07.2c.00.15
[    1.164642] nouveau W[   VBIOS][0000:01:00.0] DCB contains no useful data
[    1.164645] nouveau W[   VBIOS][0000:01:00.0] DCB contains no useful data
[    1.164652] nouveau E[   VBIOS][0000:01:00.0] 0xaa21[ ]: unknown opcode 0x00
[    1.164724] nouveau E[ DEVINIT][0000:01:00.0] init failed, -22
[    1.164794] nouveau E[     DRM] failed to create 0x80000080, -22
[    1.165298] nouveau: probe of 0000:01:00.0 failed with error -22


extract from lspci -vv

01:00.0 VGA compatible controller: NVIDIA Corporation GK107M [GeForce GTX 660M] (rev a1) (prog-if 00 [VGA controller])
	Subsystem: ASUSTeK Computer Inc. Device 2115
	Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Interrupt: pin A routed to IRQ 16
	Region 0: Memory at f6000000 (32-bit, non-prefetchable) [size=16M]
	Region 1: Memory at e0000000 (64-bit, prefetchable) [size=256M]
	Region 3: Memory at f0000000 (64-bit, prefetchable) [size=32M]
	Region 5: I/O ports at e000 [size=128]
	Expansion ROM at f7000000 [disabled] [size=512K]
	Capabilities: [60] Power Management version 3
		Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
		Status: D0 NoSoftRst+ PME-Enable- DSel=0 DScale=0 PME-
	Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
		Address: 0000000000000000  Data: 0000
	Capabilities: [78] Express (v2) Endpoint, MSI 00
		DevCap:	MaxPayload 256 bytes, PhantFunc 0, Latency L0s unlimited, L1 <64us
			ExtTag+ AttnBtn- AttnInd- PwrInd- RBE+ FLReset-
		DevCtl:	Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
			RlxdOrd+ ExtTag+ PhantFunc- AuxPwr- NoSnoop+
			MaxPayload 256 bytes, MaxReadReq 512 bytes
		DevSta:	CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr- TransPend-
		LnkCap:	Port #0, Speed 2.5GT/s, Width x16, ASPM L0s L1, Exit Latency L0s <512ns, L1 <4us
			ClockPM+ Surprise- LLActRep- BwNot-
		LnkCtl:	ASPM Disabled; RCB 64 bytes Disabled- CommClk+
			ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
		LnkSta:	Speed 2.5GT/s, Width x16, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
		DevCap2: Completion Timeout: Range AB, TimeoutDis+, LTR-, OBFF Not Supported
		DevCtl2: Completion Timeout: 50us to 50ms, TimeoutDis-, LTR-, OBFF Disabled
		LnkCtl2: Target Link Speed: 2.5GT/s, EnterCompliance- SpeedDis-
			 Transmit Margin: Normal Operating Range, EnterModifiedCompliance- ComplianceSOS-
			 Compliance De-emphasis: -6dB
		LnkSta2: Current De-emphasis Level: -3.5dB, EqualizationComplete-, EqualizationPhase1-
			 EqualizationPhase2-, EqualizationPhase3-, LinkEqualizationRequest-
	Capabilities: [b4] Vendor Specific Information: Len=14 <?>
	Capabilities: [100 v1] Virtual Channel
		Caps:	LPEVC=0 RefClk=100ns PATEntryBits=1
		Arb:	Fixed- WRR32- WRR64- WRR128-
		Ctrl:	ArbSelect=Fixed
		Status:	InProgress-
		VC0:	Caps:	PATOffset=00 MaxTimeSlots=1 RejSnoopTrans-
			Arb:	Fixed- WRR32- WRR64- WRR128- TWRR128- WRR256-
			Ctrl:	Enable+ ID=0 ArbSelect=Fixed TC/VC=ff
			Status:	NegoPending- InProgress-
	Capabilities: [128 v1] Power Budgeting <?>
	Capabilities: [600 v1] Vendor Specific Information: ID=0001 Rev=1 Len=024 <?>
	Kernel modules: nouveau
Comment 9 Josh Boyer 2014-08-13 07:54:58 EDT
Please open a new bug

Note You need to log in before you can comment on or make changes to this bug.