Bug 983460 - Group for repository is mandatory but it's not marked in the dialogs, creating a repository
Group for repository is mandatory but it's not marked in the dialogs, creatin...
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity low
: ER4
: 6.0.0
Assigned To: Alexandre Porcelli
Ivo Bek
:
: 1006834 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-11 05:27 EDT by Ivo Bek
Modified: 2014-08-06 16:16 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:16:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivo Bek 2013-07-11 05:27:05 EDT
Description of problem:

If you look at the dialog to clone a repostory, Repository name and git url are mandatories and they are properly marked but not the group. When I don't select the group, it says that it's mandatory, so to avoid this mistakes it would be good to have the mark there too. The same is for the new repository dialog, the group there isn't marked too.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Maciej Swiderski 2013-09-11 11:09:05 EDT
just for the information - it has already been fixed on master but on request from Alexandre it was not yet merged to 6.0.x as he would like to make some more improvements to be more UF generic.

commit for reference
https://github.com/droolsjbpm/uberfire/commit/db0d1e24a248dc21a7b4dd1a9c74be0702f1de7e
Comment 4 Alexandre Porcelli 2013-09-18 12:44:34 EDT
The upcoming changes won't affect BRMS nor BPMS, based on that I'm setting this BZ as modified.
Comment 6 Zuzana Krejčová 2013-10-15 05:02:15 EDT
*** Bug 1006834 has been marked as a duplicate of this bug. ***
Comment 7 Ivo Bek 2013-10-15 05:15:26 EDT
Verified in BPMS 6.0.0.ER4.

Note: from the time the issue was reported, the creating repository dialog has changed, so it contains organizational unit instead of group.
Comment 8 Ivo Bek 2014-03-19 04:42:23 EDT
qe_test_coverage? the tests for creating a repository should also test that the fields are mandatory and they are properly marked and highlighted.

Note You need to log in before you can comment on or make changes to this bug.