Bug 983660 - man page entry needed for new auto-attach module
man page entry needed for new auto-attach module
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.10
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 5.10
Assigned To: Deon Ballard
IDM QE LIST
:
Depends On:
Blocks: rhsm-rhel510
  Show dependency treegraph
 
Reported: 2013-07-11 12:06 EDT by John Sefler
Modified: 2013-09-30 19:13 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No description necessary
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-30 19:13:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2013-07-11 12:06:43 EDT
Description of problem:
A new subscription-manager module called "auto-attach" has been implemented that is simply used to enable/disable a flag on the registered consumer.  When the flag is true, then the system will attempt to auto-attach subscriptions at the next check-in time determined by the rhsmcertd.autoAttachInterval (configured in /etc/rhsm/rhsm.conf).  When the flag is false, the system will NOT attempt to auto-attach subscriptions for any incompliant products or partial subscriptions at the next autoAttachInterval check-in time.


[root@jsefler-5 ~]# subscription-manager --help
Usage: subscription-manager MODULE-NAME [MODULE-OPTIONS] [--help]

Primary Modules:

  attach         Attach a specified subscription to the registered system
  list           List subscription and product information for this system
  refresh        Pull the latest subscription data from the server
  register       Register this system to the Customer Portal or another subscription management service
  release        Configure which operating system release to use
  remove         Remove all or specific subscriptions from this system
  status         Show status information for this system's subscriptions and products
  unregister     Unregister this system from the Customer Portal or another subscription management service

Other Modules:

  auto-attach    Set if this system runs auto-attach each check-in
  clean          Remove all local system and subscription data without affecting the server
  config         List, set, or remove the configuration parameters in use by this system
  environments   Display the environments available for a user
  facts          View or update the detected system information
  identity       Display the identity certificate for this system or request a new one
  import         Import certificates which were provided outside of the tool
  orgs           Display the organizations against which a user can register a system
  plugins        View and configure subscription-manager plugins
  redeem         Attempt to redeem a subscription for a preconfigured system
  repos          List the repositories which this system is entitled to use
  service-level  Manage service levels for this system
  subscribe      Deprecated, see attach
  unsubscribe    Deprecated, see remove
  version        Print version information


  ^^^^^^^ SEE new Other Module "auto-attach"



[root@jsefler-5 ~]# subscription-manager auto-attach --help
Usage: subscription-manager auto-attach [OPTIONS]

Set if this system runs auto-attach each check-in

options:
  -h, --help            show this help message and exit
  --proxy=PROXY_URL     proxy URL in the form of proxy_hostname:proxy_port
  --proxyuser=PROXY_USER
                        user for HTTP proxy with basic authentication
  --proxypassword=PROXY_PASSWORD
                        password for HTTP proxy with basic authentication
  --enable              try to attach subscriptions for uncovered products
                        each check-in
  --disable             do not try to automatically attach subscriptions each
                        check-in
  --show                show the current auto-attach preference




Version-Release number of selected component (if applicable):
[root@jsefler-5 ~]# subscription-manager version
server type: This system is currently not registered.
subscription management server: 0.8.16-1
subscription-manager: 1.8.13-1.git.1.ba56998.el5
python-rhsm: 1.8.13-1.git.1.fe553db.el5
[root@jsefler-5 ~]# man -P cat subscription-manager | tail -1
version 2.7                      May 23, 2013          subscription-manager(8)
Comment 1 RHEL Product and Program Management 2013-07-11 12:27:59 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 RHEL Product and Program Management 2013-07-24 00:03:43 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 4 Sharath Dwaral 2013-08-05 14:44:26 EDT
Version:
# rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-1.8.16-1.el5
subscription-manager-debuginfo-1.8.16-1.el5
subscription-manager-migration-data-1.11.3.2-1.git.0.14f9d59.el5
subscription-manager-firstboot-1.8.16-1.el5
python-rhsm-1.8.16-1.el5
subscription-manager-migration-1.8.16-1.el5
python-rhsm-debuginfo-1.8.16-1.el5
subscription-manager-gui-1.8.16-1.el5


Verification:

Abstract from subscription-manager man page

AUTO-ATTACH OPTIONS
       The  auto-attach  command  sets  whether the ability to check, attach, and update subscriptions occurs automatically on the system. Auto-attaching subscriptions checks the currently-
       installed products, attached subscriptions, and any changes in available subscriptions every four hours using the rhsmcertd daemon.

       --enable
              Enables the auto-attach option for the system. If there is any change in the subscriptions for the system, any subscriptions expire, or any new products  are  installed,  then
              subscription-manager detects the changes and automatically attaches the appropriate subscriptions so that the system remains covered.

       --disable
              Disables the auto-attach option for the system. If auto-attach is disabled, then any changes in installed products or subscriptions for the system (including expirations) must
              be addressed manually by the administrator.


man -P cat subscription-manager | tail -1
version 2.7                      May 23, 2013          subscription-manager(8)


VERIFIED
       --show Shows whetehr auto-attach is enabled on the systems.
Comment 6 errata-xmlrpc 2013-09-30 19:13:08 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1332.html

Note You need to log in before you can comment on or make changes to this bug.