Bug 983661 - No alert if you create a process definition which already exists
No alert if you create a process definition which already exists
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: jBPM Designer (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity high
: ER4
: 6.0.0
Assigned To: Tihomir Surdilovic
Sona Mala
:
Depends On: 1003498
Blocks: 983634
  Show dependency treegraph
 
Reported: 2013-07-11 12:07 EDT by Sona Mala
Modified: 2014-08-06 16:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:13:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Commit in GIT for DRL (95.98 KB, image/png)
2013-07-11 12:11 EDT, Sona Mala
no flags Details
Commit in GIT for BPMN2 (175.26 KB, image/png)
2013-07-11 12:12 EDT, Sona Mala
no flags Details

  None (edit)
Description Sona Mala 2013-07-11 12:07:29 EDT
Description of problem:
Application does not react if user try to create a process definition which already exist. It just rewrite the last state of process definition (delete all changes and process is empty)

Version-Release number of selected component (if applicable):
6.0.0 DR6

How reproducible:


Steps to Reproduce:
1. go to project authoring (jbpm-playground, Evaluation)
2. create new BPMN2 process definition "evaluation (already exist)


Actual results:
open "Evaluation" process and delete last changes. Until it the process is empty

Expected results:
Alert about conflict (Same behaviour as for DRL file)


Additional info:
There is difference in using git users. Designer use "admin", DRL use "sona" (I log into business-central as user "sona")
Comment 1 Sona Mala 2013-07-11 12:11:54 EDT
Created attachment 772308 [details]
Commit in GIT for DRL
Comment 2 Sona Mala 2013-07-11 12:12:23 EDT
Created attachment 772309 [details]
Commit in GIT for BPMN2
Comment 3 Mauricio Salatino 2013-07-11 18:06:49 EDT
I'm reassigning this to Michael Anstis, because this validation must be performed at VFS or Asset Wizzard level, not in the BPM side at all.
Comment 4 Tihomir Surdilovic 2013-09-16 14:57:16 EDT
fixed in designer master and 6.0.x branches
Comment 6 Sona Mala 2013-10-15 09:31:08 EDT
Verified for ER4.

An alert "File "git://uf-playground/myProject/src/main/resources/org/group/myproject/hello.bpmn2" already exists." is shown (as expected).

Note You need to log in before you can comment on or make changes to this bug.