Bug 983776 - TypeError: sequence item 0: expected string, tuple found (when trying to display a dependency issue during livecd-creator)
TypeError: sequence item 0: expected string, tuple found (when trying to disp...
Status: CLOSED DUPLICATE of bug 979759
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
rawhide
All All
unspecified Severity medium
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-11 20:00 EDT by Adam Williamson
Modified: 2013-07-11 20:03 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-11 20:03:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2013-07-11 20:00:37 EDT
Trying to build a KDE live image from current Rawhide, livecd-creator downloads all the packages, then this happens:

Traceback (most recent call last):
  File "/bin/livecd-creator", line 237, in <module>
    sys.exit(main())
  File "/bin/livecd-creator", line 218, in main
    creator.install()
  File "/usr/lib/python2.7/site-packages/imgcreate/creator.py", line 655, in install
    ayum.runInstall()
  File "/usr/lib/python2.7/site-packages/imgcreate/yuminst.py", line 220, in runInstall
    raise CreatorError("Dependency check failed : %s" % "\n".join(deps))
TypeError: sequence item 0: expected string, tuple found

The same error is visible in the nightly composes in Koji, so it's not just me. Looks like the code for printing out dependency errors needs adjusting for some reason.
Comment 1 Adam Williamson 2013-07-11 20:03:27 EDT

*** This bug has been marked as a duplicate of bug 979759 ***

Note You need to log in before you can comment on or make changes to this bug.