Bug 983926 - unable to automatically play another song in pragha
unable to automatically play another song in pragha
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pragha (Show other bugs)
19
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
:
: 951971 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-12 05:53 EDT by Jan Hutař
Modified: 2013-10-09 10:44 EDT (History)
3 users (show)

See Also:
Fixed In Version: pragha-1.1.2.1-2.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-08 07:27:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pragha --debug 4 --log-file=pragha.log (7.51 KB, text/plain)
2013-07-29 05:18 EDT, Jan Hutař
no flags Details

  None (edit)
Description Jan Hutař 2013-07-12 05:53:50 EDT
Description of problem:
I'm unable to convince pragha to play one song after another one. It keeps playing only one and then I have to go back and manually double-click another one.


Version-Release number of selected component (if applicable):
pragha-1.1.1-3.fc19.x86_64


How reproducible:
always


Steps to Reproduce:
1. Open pragha and in "lateral panel" select multiple songs (clicking with
   Ctrl or Shift key pressed)
2. Right click on them and select "Replace and play"
3. First issue: I would expect first of them starts, but still silent.
   At least they appear in a main panel
4. Double click on a first song in a main panel - it starts to play it
   Note that you can not use "Play / Pause Track" button as it do not
   have any effect


Actual results:
After first song finishes, second song is not started.


Expected results:
After first song finishes, second song is started. I can use remote `pragha --next` as expected. I can use "Play / Pause Track" button as expected.


Additional info:
Maybe I'm just missing some concept here.
Comment 1 Christoph Wickert 2013-07-12 08:55:47 EDT
(In reply to Jan Hutař from comment #0)

> Steps to Reproduce:
> 1. Open pragha and in "lateral panel" select multiple songs (clicking with
>    Ctrl or Shift key pressed)
> 2. Right click on them and select "Replace and play"
> 3. First issue: I would expect first of them starts, but still silent.

Works fine her.

>    At least they appear in a main panel
> 4. Double click on a first song in a main panel - it starts to play it
>    Note that you can not use "Play / Pause Track" button as it do not
>    have any effect

Works fine here, too.

> Actual results:
> After first song finishes, second song is not started.

Works for me as well.

Yo you see anything on the console if you start pragha from a terminal? Any errors in .xsession-errors? Does this affect all users or only one?
Comment 2 Jan Hutař 2013-07-15 05:31:21 EDT
Strange, on command line:

$ pragha --debug 4

** (pragha:11076): WARNING **: Binding 'XF86AudioPlay' failed!

** (pragha:11076): WARNING **: Binding 'XF86AudioPrev' failed!

** (pragha:11076): WARNING **: Binding 'XF86AudioNext' failed!

** (pragha:11076): WARNING **: Binding 'XF86AudioMedia' failed!

Nothing appears in ~/.xsession-errors.

Do you have some ideas on what might be wrong?
Comment 3 mati86dl 2013-07-18 10:33:28 EDT
Hi Jan,
I am the developer of Pragha. I find curious your issue. Never could reproduce it, but you're not the first. :S

Reproducible with any file? some special format are you using?

Try:
$ pragha --debug 4 --log-file=debug

..and attach the file debug. (For some reason pragha does not print the debug on the screen, but it works fine with the file)

Note: It's slow, and make a very large file. mmm.. Could do with a clean install to improve this.

$ mv ~/.config/pragha ~/.config/pragha2
$ pragha --debug 4 --log-file=debug

(Open two files and play the first)
(When "locked", close pragha and send the file debug =)

Then recovery your library:
$ mv ~/.config/pragha2 ~/.config/pragha

Regards,
Matias.
Comment 4 Jan Hutař 2013-07-29 05:16:14 EDT
Good catch. When I have emptied ~/.config/pragha and just added two files all worked as expected.

So I have used that "Do you want to import your music library [Yes] [No]" banner, clicked "[Yes]". Then went to Library -> /home/username/Music -> selected 2 track and Right clicked -> Replace and Play.

Again, worked fine.

Then I have configured: Tools -> Preferences -> General -> Restore last playlist (uncheck it).

And then I was finally able to reproduce. Attaching generated debug log.
Comment 5 Jan Hutař 2013-07-29 05:18:27 EDT
Created attachment 779697 [details]
pragha --debug 4 --log-file=pragha.log
Comment 6 mati86dl 2013-07-30 23:09:27 EDT
Yeahh..
Finally able reproduce the error.. :S

These days will be busy, but the weekend check it!.

Thanks, and regards.
Matias.
Comment 7 mati86dl 2013-07-31 10:35:41 EDT
Ohh.. Already found the bug..
..you are motivated to build and test a bit?.

Changing the line no 1067 of init.c should be solved:
- cwin->cstate->playlist_change = TRUE;
+ cwin->cstate->playlist_change = FALSE;

The weekend release a new version with the fix. =)
Comment 8 Jan Hutař 2013-08-07 03:39:33 EDT
Thanks! Works exactly as expected with patch from comment #7.
Comment 9 mati86dl 2013-08-23 15:15:14 EDT
Hi,
Sorry for the delay..

Just release pragha 1.1.2.1. Bugfixes only, except that now highlight the categories in the library.. ;)

News:
	Highlight the headers on library view.
	Disable all video features of playbin.

Bugs fixed:
	Fix unable to automatically play another song in pragha. [1]
	Fix regression on 1.1.2: Return to import playlists.     [2]
	Fix save fuse_folders option when not set folder structure view.
	No insensitive albumart_in_osd toggle button when change show sytray option.
	Fix wrong min glib version. g_thread_unref need 2.31
	Fix updating library view after rescan. [3]
	Dbus: fix crash on get current state.
	Drop unneeded ref from GtkActionGroups.
	Free GtkUIManagers.
	Notify: change actoin ids to well known.
	Notify: delete stragne asserts

Note that is the news between 1.1.2.1 and 1.1.2. Not until 1.1.1. =)

Download on http://code.google.com/p/dissonance/downloads/list

[1] This bug!!.
[2] Fix the regresion that stopped the upgrade to 1.1.2: https://bugzilla.redhat.com/show_bug.cgi?id=946963
[3] Only for this should have done a release six months ago! haha.. :)

Also fix the bug [abrt] pragha-1.1.1-3.fc19: add_folder_file:.. https://bugzilla.redhat.com/show_bug.cgi?id=957252 (Formely fixed in 1.1.2)

Also fix the bug. [abrt] pragha-1.1.1-1.fc17: _IO_ftell: Process /usr/bin/pragha was killed... https://bugzilla.redhat.com/show_bug.cgi?id=892283 (Formely un bug of taglib but adds a fix in 1.1.2)

Regards,
Matias
Comment 10 Christoph Wickert 2013-09-27 12:37:41 EDT
OMG, I completely misses this one, will update ASAP.
Comment 11 Christoph Wickert 2013-09-27 14:03:45 EDT
*** Bug 951971 has been marked as a duplicate of this bug. ***
Comment 12 Fedora Update System 2013-09-27 14:42:24 EDT
pragha-1.1.2.1-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/pragha-1.1.2.1-1.fc20
Comment 13 Fedora Update System 2013-09-27 14:43:08 EDT
pragha-1.1.2.1-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/pragha-1.1.2.1-1.fc19
Comment 14 Fedora Update System 2013-09-27 14:43:42 EDT
pragha-1.1.2.1-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/pragha-1.1.2.1-1.fc18
Comment 15 Fedora Update System 2013-09-28 21:33:10 EDT
Package pragha-1.1.2.1-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pragha-1.1.2.1-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-17894/pragha-1.1.2.1-1.fc18
then log in and leave karma (feedback).
Comment 16 Fedora Update System 2013-10-08 07:27:23 EDT
pragha-1.1.2.1-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2013-10-08 07:35:22 EDT
pragha-1.1.2.1-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2013-10-09 10:44:34 EDT
pragha-1.1.2.1-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.