Bug 984039 - ibus-libpinyin using 100% cpu
ibus-libpinyin using 100% cpu
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus-libpinyin (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peng Wu
Fedora Extras Quality Assurance
:
: 988408 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-12 11:24 EDT by Luiz Corte Real
Modified: 2013-08-01 23:42 EDT (History)
5 users (show)

See Also:
Fixed In Version: ibus-libpinyin-1.6.91-2.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-01 23:23:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ibus-libpinyin backtrace when unresponsive (4.67 KB, text/plain)
2013-07-19 09:06 EDT, Luiz Corte Real
no flags Details
My table.conf (602 bytes, text/plain)
2013-07-30 09:47 EDT, Luiz Corte Real
no flags Details

  None (edit)
Description Luiz Corte Real 2013-07-12 11:24:01 EDT
Description of problem:
When activating pinyin input using GNOME's widget in the status bar, the process ibus-engine-lib starts but eats 100% cpu. Also, trying to type any text doesn't work (it doesn't show the character selection window).

Version-Release number of selected component (if applicable):
1.6.91-1.fc19

How reproducible:
Always happens when I activate it

Steps to Reproduce:
1. Click on the input selection method widget
2. Choose "Chinese (Intelligent Pinyin)"

Actual results:
100% cpu usage and no pinyin input

Expected results:
Typing pinyin and seeing a list of chinese characters to choose from
Comment 1 Peng Wu 2013-07-15 00:47:58 EDT
Could you use gdb to post the back trace of the ibus-engine-libpinyin?
1. run $gdb attach `pidof /usr/libexec/ibus-engine-libpinyin`
2. use 'where' to get the back trace, and post it here.
Comment 2 Luiz Corte Real 2013-07-19 09:06:25 EDT
Created attachment 775800 [details]
ibus-libpinyin backtrace when unresponsive
Comment 3 Peng Wu 2013-07-21 22:39:48 EDT
Please upload the "/usr/lib64/libpinyin/data/table.conf" to analyze this bug.

BTW, which arch are you using?
Comment 4 Peng Wu 2013-07-25 23:38:59 EDT
Do you also use Germany Locale/Format?
Comment 5 Peng Wu 2013-07-26 00:42:05 EDT
Or other locales, which don't use "0.276607" as the numeric format?
Comment 6 Peng Wu 2013-07-30 01:37:13 EDT
*** Bug 988408 has been marked as a duplicate of this bug. ***
Comment 7 Fedora Update System 2013-07-30 03:51:13 EDT
ibus-libpinyin-1.6.91-2.fc18,libpinyin-0.9.93-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ibus-libpinyin-1.6.91-2.fc18,libpinyin-0.9.93-2.fc18
Comment 8 Fedora Update System 2013-07-30 03:51:24 EDT
ibus-libpinyin-1.6.91-2.fc19,libpinyin-0.9.93-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/ibus-libpinyin-1.6.91-2.fc19,libpinyin-0.9.93-2.fc19
Comment 9 Luiz Corte Real 2013-07-30 09:47:47 EDT
Created attachment 780671 [details]
My table.conf

Sorry for the delay. This is my table.conf. Also, yes, I use a locale where 0.297 is not separated by . (I use the french locale)
Comment 10 Fedora Update System 2013-08-01 23:23:21 EDT
ibus-libpinyin-1.6.91-2.fc19, libpinyin-0.9.93-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2013-08-01 23:42:41 EDT
ibus-libpinyin-1.6.91-2.fc18, libpinyin-0.9.93-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.