Bug 984134 - kvm-intel module not being loaded on boot since 3.11(?)
kvm-intel module not being loaded on boot since 3.11(?)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
rawhide
x86_64 All
unspecified Severity medium
: ---
: ---
Assigned To: udev-maint
Fedora Extras Quality Assurance
:
: 991716 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-12 18:51 EDT by Adam Williamson
Modified: 2013-08-07 15:03 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-07 14:58:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2013-07-12 18:51:31 EDT
I have my desktop running Rawhide. On my last few boots - I think since the move to kernel 3.11 - the kvm-intel module is not loaded on boot; I have to manually load it (and restart libvirtd.service, but I think that's a libvirtd bug...) before I can run any VMs.

[adamw@adam ~]$ modinfo kvm-intel
filename:       /lib/modules/3.11.0-0.rc0.git3.1.fc20.x86_64/kernel/arch/x86/kvm/kvm-intel.ko
license:        GPL
author:         Qumranet
alias:          x86cpu:vendor:*:family:*:model:*:feature:*0085*
depends:        kvm
intree:         Y
vermagic:       3.11.0-0.rc0.git3.1.fc20.x86_64 SMP mod_unload 
signer:         Fedora kernel signing key
sig_key:        39:6B:81:E1:5F:3E:FC:8E:1C:65:1F:67:7A:42:D1:F1:FA:FE:D1:5B
sig_hashalgo:   sha256
parm:           vpid:bool
parm:           flexpriority:bool
parm:           ept:bool
parm:           unrestricted_guest:bool
parm:           eptad:bool
parm:           emulate_invalid_guest_state:bool
parm:           vmm_exclusive:bool
parm:           fasteoi:bool
parm:           enable_apicv:bool
parm:           enable_shadow_vmcs:bool
parm:           nested:bool
parm:           ple_gap:int
parm:           ple_window:int

[adamw@adam ~]$ cat /proc/cpuinfo 
processor	: 0
vendor_id	: GenuineIntel
cpu family	: 6
model		: 42
model name	: Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz
stepping	: 7
microcode	: 0x17
cpu MHz		: 3706.000
cache size	: 8192 KB
physical id	: 0
siblings	: 8
core id		: 0
cpu cores	: 4
apicid		: 0
initial apicid	: 0
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 popcnt tsc_deadline_timer aes xsave avx lahf_lm ida arat epb xsaveopt pln pts dtherm tpr_shadow vnmi flexpriority ept vpid
bogomips	: 7004.76
clflush size	: 64
cache_alignment	: 64
address sizes	: 36 bits physical, 48 bits virtual
power management:

(there's 8 identical outputs, as it's a quad core HT CPU).

Not sure what other info you might need.
Comment 1 Adam Williamson 2013-07-12 19:29:52 EDT
<dgilmore> adamw: udev should load it
<nirik> adamw: in the past qemu loaded those modules, but systemd/udev folks said "no need, it should get loaded by udev" so they dropped loading it... so it sounds to me like udev isn't doing what is expected?
Comment 2 Josh Boyer 2013-08-05 10:15:35 EDT
*** Bug 991716 has been marked as a duplicate of this bug. ***
Comment 3 Adam Williamson 2013-08-07 14:58:43 EDT
This seems to be OK in recent kernels - pretty sure it was fixed at least by rc3, it's definitely fixed in rc4.
Comment 4 Satish Balay 2013-08-07 15:03:36 EDT
Perhaps the fix is in systemd [.f20] - as I has this issue on f19 with rc4

kernel-3.11.0-0.rc4.git0.2.fc20.x86_64
systemd-204-9.fc19.x86_64

I can workarround it though...

Note You need to log in before you can comment on or make changes to this bug.