Bug 984136 - Provide MSI machine installer for client
Provide MSI machine installer for client
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: mingw-virt-viewer (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.3.0
Assigned To: Marc-Andre Lureau
Desktop QE
:
Depends On: 983111
Blocks: 885200
  Show dependency treegraph
 
Reported: 2013-07-12 19:02 EDT by Marc-Andre Lureau
Modified: 2015-09-22 09 EDT (History)
6 users (show)

See Also:
Fixed In Version: spice-client-msi-3.3-6
Doc Type: Enhancement
Doc Text:
This update provides a new virt-viewer MSI installer which is more administrator-friendly, robust, and follows Windows Installer practices.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 09:46:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marc-Andre Lureau 2013-07-12 19:02:47 EDT
spin of from 885200

Mass windows deployment of spice client via msi

MSI installers are a great way for AD Administrators to deploy items like the SPICE/Desktop Viewer application to all the relevant users/systems en mass

+MSI is the recommended practice using Windows Installer mechanism.
Comment 1 David Jaša 2013-07-19 12:35:55 EDT
qa_ack+

There will be two separate .msi installers: one for mingw-remote-viewer and other for usbclerk (handled at bug 984137).
Comment 5 Marc-Andre Lureau 2013-07-25 13:43:30 EDT
virt-viewer version scheme doesn't match very well with windows minor update mechanism. Currently, we will need to bump 0.5.6 -> 0.5.7 to perform update. We may want to switch v-v version scheme. See also this thread:  https://www.redhat.com/archives/virt-tools-list/2013-July/msg00138.html
Comment 8 Marc-Andre Lureau 2013-11-07 15:42:27 EST
though the current MSI installs fine, upgrade is currently broken. This can be verified by taking candidate build version. After upgrade, some files will be missing such as remote-viewer.exe!

I am moving back this bug to assign, I think I know what's going on, and I will submit a new build asap.,
Comment 9 Marc-Andre Lureau 2013-11-07 15:43:58 EST
In case someone read this later, I think the reason is that we have multiple file in the same components (multiple files share the same generated component UUID), and we get hit by this:

http://stackoverflow.com/questions/1602831/wix-one-file-per-component-or-several-files-per-component
Comment 12 Charlie 2013-11-27 20:25:46 EST
This bug is currently attached to errata RHEA-2013:15512. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 14 errata-xmlrpc 2014-01-21 09:46:30 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0034.html

Note You need to log in before you can comment on or make changes to this bug.