Bug 984157 - SELinux is preventing /usr/bin/df from 'getattr' accesses on the directory /sys/fs/cgroup.
SELinux is preventing /usr/bin/df from 'getattr' accesses on the directory /s...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:7ac478f7d16175a2e68bc705513...
:
: 984161 984162 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-13 01:51 EDT by Mark
Modified: 2013-07-20 05:33 EDT (History)
3 users (show)

See Also:
Fixed In Version: selinux-policy-3.12.1-65.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-20 05:33:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark 2013-07-13 01:51:51 EDT
Description of problem:
SELinux is preventing /usr/bin/df from 'getattr' accesses on the directory /sys/fs/cgroup.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that df should be allowed getattr access on the cgroup directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep df /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:rabbitmq_beam_t:s0
Target Context                system_u:object_r:cgroup_t:s0
Target Objects                /sys/fs/cgroup [ dir ]
Source                        df
Source Path                   /usr/bin/df
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           coreutils-8.21-11.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-63.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.9-301.fc19.x86_64 #1 SMP Thu
                              Jul 4 15:10:36 UTC 2013 x86_64 x86_64
Alert Count                   2
First Seen                    2013-07-13 01:50:48 EDT
Last Seen                     2013-07-13 01:50:48 EDT
Local ID                      6dd10d89-c0b8-45e7-8c5e-c4a24e453196

Raw Audit Messages
type=AVC msg=audit(1373694648.25:673): avc:  denied  { getattr } for  pid=4100 comm="df" path="/sys/fs/cgroup" dev="tmpfs" ino=6928 scontext=system_u:system_r:rabbitmq_beam_t:s0 tcontext=system_u:object_r:cgroup_t:s0 tclass=dir


type=SYSCALL msg=audit(1373694648.25:673): arch=x86_64 syscall=stat success=no exit=EACCES a0=22c6b70 a1=7fff9c4766b0 a2=7fff9c4766b0 a3=0 items=0 ppid=4098 pid=4100 auid=4294967295 uid=989 gid=988 euid=989 suid=989 fsuid=989 egid=988 sgid=988 fsgid=988 ses=4294967295 tty=(none) comm=df exe=/usr/bin/df subj=system_u:system_r:rabbitmq_beam_t:s0 key=(null)

Hash: df,rabbitmq_beam_t,cgroup_t,dir,getattr

Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.9.9-301.fc19.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-07-15 10:07:11 EDT
*** Bug 984161 has been marked as a duplicate of this bug. ***
Comment 2 Miroslav Grepl 2013-07-15 10:07:18 EDT
*** Bug 984162 has been marked as a duplicate of this bug. ***
Comment 3 Miroslav Grepl 2013-07-15 10:09:17 EDT
Has been added.
Comment 4 Fedora Update System 2013-07-17 07:53:43 EDT
selinux-policy-3.12.1-65.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/selinux-policy-3.12.1-65.fc19
Comment 5 Fedora Update System 2013-07-18 02:02:12 EDT
Package selinux-policy-3.12.1-65.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.12.1-65.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-13172/selinux-policy-3.12.1-65.fc19
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2013-07-20 05:33:45 EDT
selinux-policy-3.12.1-65.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.