Bug 984162 - SELinux is preventing /usr/bin/df from 'getattr' accesses on the directory /media/sf_Fedora18_shared.
SELinux is preventing /usr/bin/df from 'getattr' accesses on the directory /m...
Status: CLOSED DUPLICATE of bug 984157
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:e6bc1061fc544f4237197c9db60...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-13 01:55 EDT by Mark
Modified: 2013-07-15 10:07 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-15 10:07:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark 2013-07-13 01:55:44 EDT
Description of problem:
SELinux is preventing /usr/bin/df from 'getattr' accesses on the directory /media/sf_Fedora18_shared.

*****  Plugin restorecon (99.5 confidence) suggests  *************************

If you want to fix the label. 
/media/sf_Fedora18_shared default label should be mnt_t.
Then you can run restorecon.
Do
# /sbin/restorecon -v /media/sf_Fedora18_shared

*****  Plugin catchall (1.49 confidence) suggests  ***************************

If you believe that df should be allowed getattr access on the sf_Fedora18_shared directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep df /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:rabbitmq_beam_t:s0
Target Context                system_u:object_r:vmblock_t:s0
Target Objects                /media/sf_Fedora18_shared [ dir ]
Source                        df
Source Path                   /usr/bin/df
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           coreutils-8.21-11.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-63.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.9-301.fc19.x86_64 #1 SMP Thu
                              Jul 4 15:10:36 UTC 2013 x86_64 x86_64
Alert Count                   2
First Seen                    2013-07-13 01:50:48 EDT
Last Seen                     2013-07-13 01:50:48 EDT
Local ID                      8b09782b-d90d-44cf-acdb-84480fca3865

Raw Audit Messages
type=AVC msg=audit(1373694648.29:686): avc:  denied  { getattr } for  pid=4100 comm="df" path="/media/sf_Fedora18_shared" dev="vboxsf" ino=0 scontext=system_u:system_r:rabbitmq_beam_t:s0 tcontext=system_u:object_r:vmblock_t:s0 tclass=dir


type=SYSCALL msg=audit(1373694648.29:686): arch=x86_64 syscall=stat success=no exit=EACCES a0=22c7780 a1=7fff9c4766b0 a2=7fff9c4766b0 a3=0 items=0 ppid=4098 pid=4100 auid=4294967295 uid=989 gid=988 euid=989 suid=989 fsuid=989 egid=988 sgid=988 fsgid=988 ses=4294967295 tty=(none) comm=df exe=/usr/bin/df subj=system_u:system_r:rabbitmq_beam_t:s0 key=(null)

Hash: df,rabbitmq_beam_t,vmblock_t,dir,getattr

Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.9.9-301.fc19.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-07-15 10:07:18 EDT

*** This bug has been marked as a duplicate of bug 984157 ***

Note You need to log in before you can comment on or make changes to this bug.