Bug 984300 - strongswan.service systemd unit file is broken
strongswan.service systemd unit file is broken
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: strongswan (Show other bugs)
19
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Jamie Nguyen
Fedora Extras Quality Assurance
:
: 986128 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-14 11:55 EDT by Jamie Nguyen
Modified: 2013-08-03 20:12 EDT (History)
3 users (show)

See Also:
Fixed In Version: strongswan-5.0.4-5.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-03 15:13:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jamie Nguyen 2013-07-14 11:55:49 EDT
Description of problem:

strongswan.service doesn't work. It contains this line:

  ExecStart=@sbindir@/@ipsec_script@ start --nofork

When it should look like this:

  ExecStart=/usr/sbin/strongswan start --nofork


Steps to reproduce:

# systemctl start strongswan
# systemctl status strongswan
[/usr/lib/systemd/system/strongswan.service:6] Executable path is not absolute, ignoring: sbindir...--nofork
strongswan.service lacks ExecStart setting. Refusing.


Version-Release number of selected component (if applicable):

strongswan-5.0.2-2.fc19
Comment 1 Fedora Update System 2013-07-16 08:18:31 EDT
strongswan-5.0.4-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/strongswan-5.0.4-4.fc19
Comment 2 Fedora Update System 2013-07-16 08:22:03 EDT
strongswan-5.0.4-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/strongswan-5.0.4-4.fc18
Comment 3 Fedora Update System 2013-07-16 08:26:07 EDT
strongswan-5.0.4-4.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/strongswan-5.0.4-4.el6
Comment 4 Fedora Update System 2013-07-16 15:04:54 EDT
Package strongswan-5.0.4-4.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing strongswan-5.0.4-4.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-10866/strongswan-5.0.4-4.el6
then log in and leave karma (feedback).
Comment 5 Jamie Nguyen 2013-07-19 02:57:56 EDT
*** Bug 986128 has been marked as a duplicate of this bug. ***
Comment 6 Fedora Update System 2013-07-25 03:08:28 EDT
strongswan-5.0.4-5.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/strongswan-5.0.4-5.fc19
Comment 7 Fedora Update System 2013-07-25 03:09:30 EDT
strongswan-5.0.4-5.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/strongswan-5.0.4-5.fc18
Comment 8 Fedora Update System 2013-08-03 15:13:27 EDT
strongswan-5.0.4-4.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2013-08-03 20:10:22 EDT
strongswan-5.0.4-5.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2013-08-03 20:12:02 EDT
strongswan-5.0.4-5.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.