Bug 984348 - [abrt] hplip-3.13.6-2.fc19: pexpect.py:468:__spawn:OSError: [Errno 13] Permission denied
[abrt] hplip-3.13.6-2.fc19: pexpect.py:468:__spawn:OSError: [Errno 13] Permis...
Status: CLOSED DUPLICATE of bug 969973
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
abrt_hash:17ecf7d4daae6a8ebf46b746504...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-14 22:52 EDT by Håkon Løvdal
Modified: 2013-07-15 09:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-15 09:09:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (898 bytes, text/plain)
2013-07-14 22:52 EDT, Håkon Løvdal
no flags Details
File: core_backtrace (523 bytes, text/plain)
2013-07-14 22:52 EDT, Håkon Løvdal
no flags Details
File: environ (2.81 KB, text/plain)
2013-07-14 22:52 EDT, Håkon Løvdal
no flags Details

  None (edit)
Description Håkon Løvdal 2013-07-14 22:52:10 EDT
Description of problem:
From hp-systray program, press the "Diagnose HPLIP Device" hammer icon. A terminal window appeared and some messages were printed before eventually it closed (due to the crash).

Version-Release number of selected component:
hplip-3.13.6-2.fc19

Additional info:
reporter:       libreport-2.1.5
cmdline:        /usr/bin/python /usr/bin/hp-doctor -i -w
dso_list:       hplip-gui-3.13.6-2.fc19.x86_64
executable:     /usr/bin/hp-doctor
kernel:         3.9.9-302.fc19.x86_64
runlevel:       N 5
uid:            500

Truncated backtrace:
pexpect.py:468:__spawn:OSError: [Errno 13] Permission denied

Traceback (most recent call last):
  File "/usr/bin/hp-doctor", line 292, in <module>
    num_errors, num_warns = core.validate(DEPENDENCY_RUN_AND_COMPILE_TIME, False)
  File "/usr/share/hplip/check.py", line 400, in validate
    installed_ver = get_version(self.hplip_dependencies[s][d][5])
  File "/usr/share/hplip/installer/dcheck.py", line 250, in get_version
    status, output = utils.run(cmd)
  File "/usr/share/hplip/base/utils.py", line 1244, in run
    child = pexpect.spawn(cmd, timeout=timeout)
  File "/usr/share/hplip/base/pexpect.py", line 369, in __init__
    self.__spawn()
  File "/usr/share/hplip/base/pexpect.py", line 468, in __spawn
    os.execv(self.command, self.args)
OSError: [Errno 13] Permission denied

Local variables in innermost frame:
i: 1023
self: <base.pexpect.spawn object at 0x1301b10>
max_fd: 1024

Potential duplicate: bug 904896
Comment 1 Håkon Løvdal 2013-07-14 22:52:19 EDT
Created attachment 773486 [details]
File: backtrace
Comment 2 Håkon Løvdal 2013-07-14 22:52:22 EDT
Created attachment 773487 [details]
File: core_backtrace
Comment 3 Håkon Løvdal 2013-07-14 22:52:27 EDT
Created attachment 773488 [details]
File: environ
Comment 4 Håkon Løvdal 2013-07-14 23:01:59 EDT
Actually, the window did not close. Here is the capture:


[Pasting the text here reveals a lot more than what is visible in the window (I saw just the red errors and violet warnings), apparently the bulk of the text is printed in black colour which is invisible on back background. That is definately a bug, please fix as well (or do I have to create a separate bug report?)]


HP Linux Imaging and Printing System (ver. 3.13.6)
Self Diagnse Utility and Healing Utility ver. 1.0

Copyright (c) 2001-13 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

 

Checking for Deprecated items....
error: This distro (i.e fedora  19) is either deprecated or not yet supported.
The diagnosis is limited on unsupported platforms. Do you want to continue?(y=yes, n=no*):yes
error: Please enter 'y', 'n', 'q' or press <enter> for the default of 'n'.
The diagnosis is limited on unsupported platforms. Do you want to continue?(y=yes, n=no*):y


Checking for HPLIP updates....
error: Failed to locate hp-upgrade utility


Checking for Dependencies....
warning: fedora-19 version is not supported. Using fedora-18 versions dependencies to verify and install...

---------------
| SYSTEM INFO |
---------------

 Kernel: 3.9.9-302.fc19.x86_64 #1 SMP Sat Jul 6 13:41:07 UTC 2013 GNU/Linux
 Host: superlangbein.andeby.dns
 Proc: 3.9.9-302.fc19.x86_64 #1 SMP Sat Jul 6 13:41:07 UTC 2013 GNU/Linux
 Distribution: fedora 19
 Bitness: 64 bit


-----------------------
| HPLIP CONFIGURATION |
-----------------------

HPLIP-Version: HPLIP 3.13.6
HPLIP-Home: /usr/share/hplip
warning: HPLIP-Installation: Auto installation is not supported for fedora distro  19 version 

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf.  Generated from hplip.conf.in by configure.

[hplip]
version=3.13.6

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/HP
ppdbase=/usr/share/ppd
doc=/usr/share/doc/hplip-3.13.6
icon=/usr/share/applications
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv/hp
bin=/usr/bin

# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
libusb01-build=no
pp-build=yes
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=yes
foomatic-drv-install=yes
foomatic-ppd-install=no
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=no
internal-tag=3.13.6
restricted-build=no
ui-toolkit=qt4
qt3=no
qt4=yes
policy-kit=no
lite-build=no
udev-acl-rules=yes
udev_sysfs_rules=no
hpcups-only-build=no
hpijs-only-build=no


Current contents of '/var/lib/hp/hplip.state' file:
Plugins are not installed. Could not access file: No such file or directory

Current contents of '~/.hplip/hplip.conf' file:
[installation]
date_time = 07/15/2013 04:43:36
version = 3.13.6

[settings]
systray_visible = 0
systray_messages = 0

[last_used]
device_uri = "hp:/usb/Deskjet_F300_series?serial=CN727G503Y04KH"
printer_name = Deskjet-F300-series
working_dir = .

[commands]
scan = /usr/bin/xsane -V %SANE_URI%

[refresh]
rate = 30
enable = false
type = 1

[polling]
enable = false
interval = 5
device_list = 

[fax]
voice_phone = 
email_address = 

[upgrade]
notify_upgrade = false
last_upgraded_time = 1373854197.39322
pending_upgrade_time = 0


 <Package-name>        <Package-Desc>      <Required/Optional> <Min-Version> <Installed-Version> <Status>   <Comment>

--------------------------
|  External Dependencies |
--------------------------

 gs                   Ghostscript               REQUIRED        7.05            9.07            OK         -
 network              Network-wget              OPTIONAL        -               1.14            OK         -
 dbus                 DBus                      REQUIRED        -               -               OK         -
 scanimage            Shell-Scanning            OPTIONAL        1.0             1.0.23          OK         -
 policykit            Admin-Policy-framework    OPTIONAL        -               0.111           OK         -
 xsane                SANE-GUI                  OPTIONAL        0.9             0.999           OK         -
 cups                 CUPS                      REQUIRED        1.1             1.6.2           OK         'CUPS Scheduler is running'

-------------------------
|  General Dependencies |
-------------------------

 reportlab            Python-PDF-Lib            OPTIONAL        2.0             2.5             OK         -
 libcrypto            OpenSSL-Crypto-Lib        REQUIRED        -               1.0.1           OK         -
 pil                  Python-Image-Lib          OPTIONAL        -               1.1.7           OK         -
 pyqt4-dbus           PyQt4-DBUS                REQUIRED        4.0             4.10.1          OK         -
 libjpeg              JPEG-Lib                  REQUIRED        -               -               OK         -
 libpthread           POSIX-Threads-Lib         REQUIRED        -               2.17            OK         -
 python-dbus          Python-DBUS               REQUIRED        0.80.0          1.1.1           OK         -
 python-devel         Python-SDK                REQUIRED        2.2             2.7.5           OK         -
 pyqt4                Python-Qt4                REQUIRED        4.0             4.10.1          OK         -
 cups-devel           CUPS-SDK                  REQUIRED        -               1.6.2           OK         -
 sane-devel           SANE-SDK                  REQUIRED        -               1.0.23          OK         -
 libusb               USB-Lib                   REQUIRED        -               1.0             OK         -
 sane                 Scan-Lib                  REQUIRED        -               1.0.23          OK         -
 cups-image           CUPS-Image-Lib            REQUIRED        -               1.6.2           OK         -
 libnetsnmp-devel     SNMP-Networking-SDK       REQUIRED        5.0.9           5.7.2           OK         -
 python-xml           Python-XML-Lib            REQUIRED        -               2.1.0           OK         -
 python-notify        Desktop-notifications     OPTIONAL        -               -               OK         -

------------------------------
|  Compile Time Dependencies |
------------------------------

 gcc                  gcc-Compiler              REQUIRED        -               4.8.1           OK         -
 libtool              Build-tools               REQUIRED        -               2.4.2           OK         -
 make                 GNU-Build-tools           REQUIRED        3.0             3.82            OK         -

----------------------
|  Python Extentions |
----------------------

 cupsext              CUPS-Extension            REQUIRED        -               3.13.6          OK         -
 pcardext             PhotoCard-Extension       REQUIRED        -               3.13.6          OK         -
 hpmudext             IO-Extension              REQUIRED        -               3.13.6          OK         -

-----------------------
|  Scan Configuration |
-----------------------

 hpaio                HPLIP-SANE-Backend        REQUIRED        -               3.13.6          OK         'hpaio found in /etc/sane.d/dll.conf'
 scanext              Scan-SANE-Extension       REQUIRED        -               3.13.6          OK         -

------------------------------
| DISCOVERED SCANNER DEVICES |
------------------------------

device `hpaio:/usb/Deskjet_F300_series?serial=CN727G503Y04KH' is a Hewlett-Packard Deskjet_F300_series all-in-one
device `v4l:/dev/video0' is a Noname Chicony WebCam virtual device


--------------------------
| DISCOVERED USB DEVICES |
--------------------------

  Device URI                               Model                 
  ---------------------------------------  ----------------------
  hp:/usb/Deskjet_F300_series?serial=CN72  HP Deskjet F300 series
  7G503Y04KH                                                     

---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------

 
Deskjet-F300-series
-------------------
Type: Printer
Device URI: hp:/usb/Deskjet_F300_series?serial=CN727G503Y04KH
PPD: /etc/cups/ppd/Deskjet-F300-series.ppd
PPD Description: HP Deskjet f300 Series, hpcups 3.13.6
Printer status: printer Deskjet-F300-series is idle.  enabled since Mon 15 Jul 2013 04:07:22 AM CEST      ready to print
Communication status: Good

Deskjet_F380
------------
Type: Printer
Device URI: hp:/usb/Deskjet_F300_series?serial=CN727G503Y04KH
PPD: /etc/cups/ppd/Deskjet_F380.ppd
PPD Description: HP Deskjet f300 Series, hpcups 3.13.6
Printer ready to printr Deskjet_F380 is idle.  enabled since Mon 15 Jul 2013 03:55:43 AM CEST
Communication status: Good

NRG_NRG_SP_C232SF
-----------------
Type: Unknown
Device URI: dnssd://NRG%20SP%20C232SF%20(095b61)._printer._tcp.local/
PPD: /etc/cups/ppd/NRG_NRG_SP_C232SF.ppd
PPD Description: NRG  DSm615 PS
Printer status: printer NRG_NRG_SP_C232SF is idle.  enabled since Sun 13 Nov 2011 09:35:34 PM CET
warning: Printer is not HPLIP installed. Printers must use the hp: or hpfax: CUPS backend for HP-Devices.


--------------
| PERMISSION |
--------------

groups          user-groups                    Required        -        -        OK       hlovdal sys disk lp dialout wireshark mock

USB             Deskjet-F300-series            Required        -        -        OK       Node:'/dev/bus/usb/002/004' Perm:'  root  lp rw- rw- rw- rw- ---'

-----------
| SELINUX |
-----------

warning: SELinux      enabled      Optional   -   -   INCOMPAT 'SELinux needs to be disabled for Plugin printers and Fax functionality.'
 

Checking Permissions....
SELinux Status
--------------
SELinux is enabled. Needs to be disabled


ENTER ROOT/SUPERUSER PASSWORD
-----------------------------
Please enter the root/superuser password:
Comment 5 Jiri Popelka 2013-07-15 09:09:11 EDT

*** This bug has been marked as a duplicate of bug 969973 ***

Note You need to log in before you can comment on or make changes to this bug.