This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 984447 - Dir rename fails on smb mount
Dir rename fails on smb mount
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: samba (Show other bugs)
2.1
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Raghavendra Talur
Sudhir D
:
Depends On:
Blocks: 956495
  Show dependency treegraph
 
Reported: 2013-07-15 05:26 EDT by Ujjwala
Modified: 2013-09-23 18:32 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.12rhs.beta5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:32:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ujjwala 2013-07-15 05:26:36 EDT
Description of problem:
Dir rename fails on smb mount on both windows and Linux client. The issue is seen on all volume types - distribute, replicate and dis-rep

Version-Release number of selected component (if applicable):
glusterfs 3.4.0.12rhs.beta3 built on Jul  6 2013 14:35:17


How reproducible:
Always

Steps to Reproduce:
1. Create a volume of any type.
2. SMB mount it on both Linux and Windows client.
3. On linux client, create a dir and try to rename it. It fails with the error, file exists.
root@RHEL6 [Jul-15-2013- 5:09:23] >mkdir test
root@RHEL6 [Jul-15-2013- 5:09:33] >ls test
root@RHEL6 [Jul-15-2013- 5:09:37] >mv test abc
mv: cannot move `test' to `abc': File exists
root@RHEL6 [Jul-15-2013- 5:09:44] >echo $?
1

4. On windows explorer, right click and select new folder. A folder named "New Folder" will be created. Try to rename it. IT errors out with the message: The file or folder does not exist.

Actual results:
The rename operation fails.

Expected results:
Rename should pass.

Additional info:
Comment 3 Christopher R. Hertel 2013-07-21 05:03:48 EDT
Is this related to Bug 981318?
Comment 4 Raghavendra Talur 2013-07-22 07:30:02 EDT
No Chris, it is a different bug.
Comment 5 Ujjwala 2013-07-24 06:25:53 EDT
Verified it on build glusterfs 3.4.0.12rhs.beta5 built on Jul 18 2013 07:00:38
works fine.
Comment 8 Scott Haines 2013-09-23 18:32:16 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.