Bug 984586 - Cannot start a VM with USB Native - Exit message: internal error Could not format channel target type.
Cannot start a VM with USB Native - Exit message: internal error Could not fo...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity high
: ---
: 3.3.0
Assigned To: Martin Perina
Jiri Belka
infra
:
Depends On:
Blocks: 918494 950768 994609 996127
  Show dependency treegraph
 
Reported: 2013-07-15 10:03 EDT by Jiri Belka
Modified: 2016-02-10 14:13 EST (History)
8 users (show)

See Also:
Fixed In Version: is10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 994609 (view as bug list)
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine.log, vdsm.log, libvirtd.log (11.25 KB, application/x-tar)
2013-07-15 10:03 EDT, Jiri Belka
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 17268 None None None Never
oVirt gerrit 17708 None None None Never

  None (edit)
Description Jiri Belka 2013-07-15 10:03:18 EDT
Created attachment 773768 [details]
engine.log, vdsm.log, libvirtd.log

Description of problem:
Something is wrong when create VM xml on vdsm.

...snip...
                <channel type="spicevmc">
                        <target name="com.redhat.spice.0" type="virtio"/>
                </channel>
                <graphics autoport="yes" keymap="es" listen="0" passwd="*****" passwdValidTo="1970-01-01T00:00:01" port="-1" tlsPort="-1" type="spice">
                        <channel mode="secure" name="main"/>
                        <channel mode="secure" name="inputs"/>
                        <channel mode="secure" name="cursor"/>
                        <channel mode="secure" name="playback"/>
                        <channel mode="secure" name="record"/>
                        <channel mode="secure" name="display"/>
                        <channel mode="secure" name="usbredir"/>
                        <channel mode="secure" name="smartcard"/>
                </graphics>
                <channel type="spicevmc"/>
                <channel type="spicevmc"/>
                <channel type="spicevmc"/>
                <channel type="spicevmc"/>
...snip...

See 4 times lines with 'spicevmc'. Next lines following in vdsm.log are:

2013-07-15 11:53:17.131+0000: 2489: error : virDomainChrDefaultTargetType:5319 : XML error: target type must be specified for channel device
...snip...
2013-07-15 11:53:17.241+0000: 2489: error : virDomainChrDefFormat:12840 : internal error Could not format channel target type

Version-Release number of selected component (if applicable):
is5

How reproducible:
100%

Steps to Reproduce:
1. create a vm with usb native (my case: win7 64bit, desktop)
2. start vm
3.

Actual results:
2013-Jul-15, 15:53
	
VM test1 is down. Exit message: internal error Could not format channel target type.

Expected results:
up and running

Additional info:
Comment 1 Itamar Heim 2013-07-15 10:35:28 EDT
dup of bug 950768?
Comment 2 Jiri Belka 2013-07-15 10:53:30 EDT
I don't know but there's difference in vdsm.log:

* BZ950765

Thread-253548::ERROR::2013-02-28 02:28:12,282::vm::631::vm.Vm::(_startUnderlyingVm) vmId=`28c6d8a2-6ba7-4ac2-94dc-fc2ff70f7a7d`::The vm start process failed
Traceback (most recent call last):
  File "/usr/share/vdsm/vm.py", line 597, in _startUnderlyingVm
  File "/usr/share/vdsm/libvirtvm.py", line 1448, in _run
  File "/usr/lib64/python2.6/site-packages/vdsm/libvirtconnection.py", line 83, in wrapper
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 2489, in createXML
libvirtError: internal error process exited while connecting to monitor: qemu-kvm: -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2: Duplicate ID 'usb' for device

Thread-253548::DEBUG::2013-02-28 02:28:12,293::vm::965::vm.Vm::(setDownStatus) vmId=`28c6d8a2-6ba7-4ac2-94dc-fc2ff70f7a7d`::Changed state to Down: internal error process exited while connecti
ng to monitor: qemu-kvm: -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2: Duplicate ID 'usb' for device

* BZ984586 (this one)

Thread-568191::ERROR::2013-07-15 13:53:17,530::vm::2008::vm.Vm::(_startUnderlyingVm) vmId=`a02b7ffd-56b1-4bce-9cff-a325830245e4`::The vm start process failed
Traceback (most recent call last):
  File "/usr/share/vdsm/vm.py", line 1968, in _startUnderlyingVm
    self._run()
  File "/usr/share/vdsm/vm.py", line 2841, in _run
    self._connection.createXML(domxml, flags),
  File "/usr/lib64/python2.6/site-packages/vdsm/libvirtconnection.py", line 112, in wrapper
    ret = f(*args, **kwargs)
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 2645, in createXML
    if ret is None:raise libvirtError('virDomainCreateXML() failed', conn=self)
libvirtError: internal error Could not format channel target type
Comment 3 Andrew Cathrow 2013-07-20 21:26:20 EDT
Jiri,

Can you retest this with the build from 950768 so we can verify if it's a dupe?
Comment 4 Jiri Belka 2013-07-22 03:46:02 EDT
Cannot reproduce on is6. VM starts and xml part in vdsm.log does not contains reported duplicated lines.
Comment 5 Jiri Belka 2013-07-22 08:11:23 EDT
I obviously did not have 'USB Native' in comment#4.

I _CAN_ still reproduce with w7 64bit (desktop) and USB Native configured.
Comment 8 Omer Frenkel 2013-07-22 12:00:10 EDT
this bug cause because of commit b649768599959e4433438e04271b13ccecbe1b8c
for some reason device with type 'redir' was changed to 'channel'
i verified that changing back ro redir fix this.
i will check what other changes were made and why before submitting the fix.
Comment 10 Michal Skrivanek 2013-08-07 07:04:30 EDT
merged to master:
http://gerrit.ovirt.org/gitweb?p=ovirt-engine.git;a=commit;h=bc80454abf7f2573182d5bbe61fc1dee83c2e9b5

yet needs to get in to engine_3.3 branch too...
Comment 12 Jiri Belka 2013-08-12 04:12:56 EDT
Doesn't work on is9.1. mperina@ informed the diff wasn't merged to downstream...
Comment 13 Martin Perina 2013-08-12 04:16:45 EDT
Even when both patches (master and ovirt-engine-3.3 branch) has been merged on August 6th, they are not included in is9.1 (created on August 8th). Even stranger this is that patch for bug 994191 that has been merged on August 8th and this one IS INCLUDED in is9.1 build.

Could some please fix this?
Comment 14 Jiri Belka 2013-08-16 09:35:03 EDT
ok, is10.
Comment 15 Itamar Heim 2014-01-21 17:24:10 EST
Closing - RHEV 3.3 Released
Comment 16 Itamar Heim 2014-01-21 17:25:08 EST
Closing - RHEV 3.3 Released
Comment 17 Itamar Heim 2014-01-21 17:28:42 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.