Bug 98461 - RHEL3: backward compatibility is broken between new ifenslave and old bonding module
RHEL3: backward compatibility is broken between new ifenslave and old bonding...
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
http://sourceforge.net/projects/bonding/
:
Depends On:
Blocks: 98457
  Show dependency treegraph
 
Reported: 2003-07-02 13:25 EDT by Need Real Name
Modified: 2013-07-02 22:12 EDT (History)
3 users (show)

See Also:
Fixed In Version: 2.4.21-1.1931.2.349.2.2.ent
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-03 09:53:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-07-02 13:25:25 EDT
Description of problem:
Due to a bug fix published by Jay Vosburgh to better handle setting bond's mac 
address, backward compatibility is broken. It is impossible to use a new 
version of ifenslave (1.0.11) to enslave adapters to an old version of bonding 
(say 20030320 and below) since it requires that the master interface be down 
but the config application doesn't handle that.

Version-Release number of selected component (if applicable):
kernel-2.4.20-1.1931.2.231.2.11.ent

How reproducible:
Use an old version of bonding (e.g. the one supplied in vanilla 2.4.21) with a 
recent version of ifenslave (e.g. the one found in Jeff's net-drivers-2.4).

Steps to Reproduce:
1. insmod bonding mode=1
2. ifconfig bond0 <ip-addr>
3. ifenslave bond0 eth0
    
Actual results:
Operation fails with an error message that bond's mac address couldn't be set 
from that of the first slave and bond is left without a valid MAC address.

Expected results:
enslave operation succeeds and bond gets the MAC address of the first slave.

Additional info:
A bug fix patch was sent by me on June 30th to both Jeff Garzik and jay 
Vosburgh. It is a slightly modified re-send of a patch we sent on May 29th that 
didn't make it in.
Comment 1 Larry Troan 2003-07-16 09:48:24 EDT
ISSUE TRACKER 25885 OPENED AS SEV 1
Comment 3 Need Real Name 2003-07-17 06:18:00 EDT
Once this bug is fixed, #98457 needs to be checked again.
Comment 4 Need Real Name 2003-07-30 06:09:15 EDT
Still exists in Beta1 kernel version kernel-2.4.21-1.1931.2.349.2.2.ent
a fix can be taken from
ftp://ftp.kernel.org/pub/linux/kernel/people/jgarzik/patchkits/2.4/2.4.21-rc8-
netdrvr2.patch.bz2

Note You need to log in before you can comment on or make changes to this bug.