Bug 984624 - [abrt] libreoffice-core-4.1.0.1-8.fc19: QTransform::type: Process /usr/lib64/libreoffice/program/soffice.bin was killed by signal 11 (SIGSEGV)
[abrt] libreoffice-core-4.1.0.1-8.fc19: QTransform::type: Process /usr/lib64/...
Status: CLOSED DUPLICATE of bug 977068
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
abrt_hash:f2b4acb11a21bc27b94662cb2c9...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-15 10:53 EDT by qub.box
Modified: 2013-07-16 00:21 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-16 00:21:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (90.70 KB, text/plain)
2013-07-15 10:54 EDT, qub.box
no flags Details
File: cgroup (140 bytes, text/plain)
2013-07-15 10:54 EDT, qub.box
no flags Details
File: core_backtrace (16.36 KB, text/plain)
2013-07-15 10:54 EDT, qub.box
no flags Details
File: dso_list (26.89 KB, text/plain)
2013-07-15 10:54 EDT, qub.box
no flags Details
File: environ (2.11 KB, text/plain)
2013-07-15 10:54 EDT, qub.box
no flags Details
File: limits (1.29 KB, text/plain)
2013-07-15 10:54 EDT, qub.box
no flags Details
File: maps (131.90 KB, text/plain)
2013-07-15 10:54 EDT, qub.box
no flags Details
File: open_fds (997 bytes, text/plain)
2013-07-15 10:54 EDT, qub.box
no flags Details
File: proc_pid_status (940 bytes, text/plain)
2013-07-15 10:54 EDT, qub.box
no flags Details
File: var_log_messages (354 bytes, text/plain)
2013-07-15 10:55 EDT, qub.box
no flags Details

  None (edit)
Description qub.box 2013-07-15 10:53:57 EDT
Description of problem:
i only tried save new "Writer" document, but blank window crashed, and save as dialog keep going hang.

Version-Release number of selected component:
libreoffice-core-4.1.0.1-8.fc19

Additional info:
reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --writer --splash-pipe=5
crash_function: QTransform::type
executable:     /usr/lib64/libreoffice/program/soffice.bin
kernel:         3.9.9-301.fc19.x86_64
runlevel:       N 5
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 QTransform::type at painting/qtransform.cpp:2048
 #1 QRasterPaintEngine::drawImage at painting/qpaintengine_raster.cpp:2166
 #2 QRasterPaintEngine::drawPixmap at painting/qpaintengine_raster.cpp:2057
 #3 QPainter::drawPixmap at painting/qpainter.cpp:5344
 #4 drawPixmap at /usr/include/QtGui/qpainter.h:852
 #5 KFileItemDelegate::paint at /usr/src/debug/kdelibs-4.10.4/kio/kio/kfileitemdelegate.cpp:1303
 #6 QListView::paintEvent at itemviews/qlistview.cpp:1039
 #7 QWidget::event at kernel/qwidget.cpp:8532
 #8 QFrame::event at widgets/qframe.cpp:557
 #9 QAbstractItemView::viewportEvent at itemviews/qabstractitemview.cpp:1644
Comment 1 qub.box 2013-07-15 10:54:05 EDT
Created attachment 773802 [details]
File: backtrace
Comment 2 qub.box 2013-07-15 10:54:10 EDT
Created attachment 773803 [details]
File: cgroup
Comment 3 qub.box 2013-07-15 10:54:15 EDT
Created attachment 773804 [details]
File: core_backtrace
Comment 4 qub.box 2013-07-15 10:54:26 EDT
Created attachment 773805 [details]
File: dso_list
Comment 5 qub.box 2013-07-15 10:54:32 EDT
Created attachment 773806 [details]
File: environ
Comment 6 qub.box 2013-07-15 10:54:36 EDT
Created attachment 773807 [details]
File: limits
Comment 7 qub.box 2013-07-15 10:54:42 EDT
Created attachment 773808 [details]
File: maps
Comment 8 qub.box 2013-07-15 10:54:46 EDT
Created attachment 773809 [details]
File: open_fds
Comment 9 qub.box 2013-07-15 10:54:57 EDT
Created attachment 773811 [details]
File: proc_pid_status
Comment 10 qub.box 2013-07-15 10:55:02 EDT
Created attachment 773812 [details]
File: var_log_messages
Comment 11 David Tardon 2013-07-16 00:21:03 EDT

*** This bug has been marked as a duplicate of bug 977068 ***

Note You need to log in before you can comment on or make changes to this bug.