Bug 977068 - [abrt] libreoffice-core-4.1.0.0-7.beta2.fc19: QTransform::type: Process /usr/lib64/libreoffice/program/soffice.bin was killed by signal 11 (SIGSEGV)
[abrt] libreoffice-core-4.1.0.0-7.beta2.fc19: QTransform::type: Process /usr/...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
abrt_hash:f2b4acb11a21bc27b94662cb2c9...
:
: 981088 983948 984624 988643 989087 995911 1033501 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-23 03:53 EDT by Guy Carmin
Modified: 2014-07-08 10:39 EDT (History)
51 users (show)

See Also:
Fixed In Version: libreoffice-4.1.3.2-7.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-09 07:49:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (99.77 KB, text/plain)
2013-06-23 03:53 EDT, Guy Carmin
no flags Details
File: cgroup (141 bytes, text/plain)
2013-06-23 03:53 EDT, Guy Carmin
no flags Details
File: core_backtrace (16.58 KB, text/plain)
2013-06-23 03:53 EDT, Guy Carmin
no flags Details
File: dso_list (29.29 KB, text/plain)
2013-06-23 03:53 EDT, Guy Carmin
no flags Details
File: environ (2.08 KB, text/plain)
2013-06-23 03:53 EDT, Guy Carmin
no flags Details
File: limits (1.29 KB, text/plain)
2013-06-23 03:54 EDT, Guy Carmin
no flags Details
File: maps (135.07 KB, text/plain)
2013-06-23 03:54 EDT, Guy Carmin
no flags Details
File: open_fds (841 bytes, text/plain)
2013-06-23 03:54 EDT, Guy Carmin
no flags Details
File: proc_pid_status (947 bytes, text/plain)
2013-06-23 03:54 EDT, Guy Carmin
no flags Details
File: var_log_messages (352 bytes, text/plain)
2013-06-23 03:55 EDT, Guy Carmin
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 69002 None None None Never

  None (edit)
Description Guy Carmin 2013-06-23 03:53:17 EDT
Version-Release number of selected component:
libreoffice-core-4.1.0.0-7.beta2.fc19

Additional info:
reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --impress '/home/gcarmin/Documents/Presentations/Topics/RHEV/RHEV3-1_Customer Presentation02.odp' --splash-pipe=5
crash_function: QTransform::type
executable:     /usr/lib64/libreoffice/program/soffice.bin
kernel:         3.9.4-301.fc19.x86_64
runlevel:       N 5
uid:            18451
xsession_errors: 

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 QTransform::type at painting/qtransform.cpp:2048
 #1 QRasterPaintEngine::drawImage at painting/qpaintengine_raster.cpp:2166
 #2 QRasterPaintEngine::drawPixmap at painting/qpaintengine_raster.cpp:2057
 #3 QPainter::drawPixmap at painting/qpainter.cpp:5344
 #4 drawPixmap at /usr/include/QtGui/qpainter.h:852
 #5 KFileItemDelegate::paint at /usr/src/debug/kdelibs-4.10.4/kio/kio/kfileitemdelegate.cpp:1303
 #6 QListView::paintEvent at itemviews/qlistview.cpp:1039
 #7 QWidget::event at kernel/qwidget.cpp:8532
 #8 QFrame::event at widgets/qframe.cpp:557
 #9 QAbstractItemView::viewportEvent at itemviews/qabstractitemview.cpp:1644
Comment 1 Guy Carmin 2013-06-23 03:53:30 EDT
Created attachment 764258 [details]
File: backtrace
Comment 2 Guy Carmin 2013-06-23 03:53:34 EDT
Created attachment 764259 [details]
File: cgroup
Comment 3 Guy Carmin 2013-06-23 03:53:46 EDT
Created attachment 764260 [details]
File: core_backtrace
Comment 4 Guy Carmin 2013-06-23 03:53:53 EDT
Created attachment 764261 [details]
File: dso_list
Comment 5 Guy Carmin 2013-06-23 03:53:58 EDT
Created attachment 764262 [details]
File: environ
Comment 6 Guy Carmin 2013-06-23 03:54:03 EDT
Created attachment 764263 [details]
File: limits
Comment 7 Guy Carmin 2013-06-23 03:54:43 EDT
Created attachment 764264 [details]
File: maps
Comment 8 Guy Carmin 2013-06-23 03:54:51 EDT
Created attachment 764265 [details]
File: open_fds
Comment 9 Guy Carmin 2013-06-23 03:54:55 EDT
Created attachment 764266 [details]
File: proc_pid_status
Comment 10 Guy Carmin 2013-06-23 03:55:00 EDT
Created attachment 764267 [details]
File: var_log_messages
Comment 11 julborre 2013-07-11 16:43:39 EDT
Hi

I was editing some document on Writer and have Impress open with an empty slideshare and then suddenly both programs just closed and the crash notifier popped up on my kde desktop running on Fedora 19. Weird.

I lost some 10 minutes of editing.
Comment 12 David Tardon 2013-07-16 00:21:04 EDT
*** Bug 984624 has been marked as a duplicate of this bug. ***
Comment 13 Gilboa Davara 2013-07-23 13:14:54 EDT
I managed to reproduce this bug by:
- File -> Open.
- Leave dialog box open for a couple of minutes.
- Boom.

FWIW I'm using KDE 4.10.

- Gilboa
Comment 14 David Tardon 2013-07-29 04:17:34 EDT
*** Bug 981088 has been marked as a duplicate of this bug. ***
Comment 15 David Tardon 2013-07-29 04:18:03 EDT
*** Bug 983948 has been marked as a duplicate of this bug. ***
Comment 16 David Tardon 2013-07-29 04:18:49 EDT
*** Bug 989087 has been marked as a duplicate of this bug. ***
Comment 17 Jacek Wielemborek 2013-08-05 13:51:51 EDT
I just tried to open a new window. Perhaps could have pressed some other keystroke in the process.

reporter:       libreport-2.1.6
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --writer --splash-pipe=5
crash_function: QTransform::type
executable:     /usr/lib64/libreoffice/program/soffice.bin
kernel:         3.9.6-200.fc18.x86_64
package:        libreoffice-core-4.1.0.4-5.fc19
reason:         Process /usr/lib64/libreoffice/program/soffice.bin was killed by signal 11 (SIGSEGV)
reported_to:    uReport: BTHASH=0439a7daffd26cd25fb4481693496398ba47ff85
runlevel:       N 5
uid:            1000
Comment 18 David Tardon 2013-08-12 04:52:36 EDT
*** Bug 995911 has been marked as a duplicate of this bug. ***
Comment 19 Paul Grabbe 2013-08-21 03:52:15 EDT
Program crashed as I tried to save after making many edits. Opened a text file and was trying to save as odt. File recovery was successful after restarting Writer.

reporter:       libreport-2.1.6
backtrace_rating: 4
crash_function: QTransform::type
executable:     /usr/lib64/libreoffice/program/soffice.bin
kernel:         3.10.7-200.fc19.x86_64
package:        libreoffice-core-4.1.0.4-6.fc19
reason:         Process /usr/lib64/libreoffice/program/soffice.bin was killed by signal 11 (SIGSEGV)
runlevel:       N 5
uid:            1000
Comment 20 Kovács György 2013-08-30 12:05:01 EDT
1. Create spreadsheet
2. Click Save-As
3. Write file name into the dialog box
4. without clicking any further buttons LibreOffice Calc accidentally exit during typing

I can't reproduce if I want to do that, but it happened many times in the past

Version: 4.1.1.2
Build ID: 4.1.1.2-2.fc19

reporter:       libreport-2.1.6
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --calc
crash_function: QTransform::type
executable:     /usr/lib64/libreoffice/program/soffice.bin
kernel:         3.10.9-200.fc19.x86_64
package:        libreoffice-core-4.1.1.2-2.fc19
reason:         Process /usr/lib64/libreoffice/program/soffice.bin was killed by signal 11 (SIGSEGV)
runlevel:       N 5
uid:            1000
Comment 21 Damian Wrobel 2013-09-07 11:18:04 EDT
Just have tried to save very simple one line length document.

reporter:       libreport-2.1.6
backtrace_rating: 4
cmdline:        /usr/lib/libreoffice/program/soffice.bin --writer /home/dawid/Documents/e-praca-dawid-wrobel.odt --splash-pipe=5
crash_function: QTransform::type
executable:     /usr/lib/libreoffice/program/soffice.bin
kernel:         3.10.10-200.fc19.i686.PAE
package:        libreoffice-core-4.1.1.2-2.fc19
reason:         Process /usr/lib/libreoffice/program/soffice.bin was killed by signal 11 (SIGSEGV)
runlevel:       N 5
uid:            1000
Comment 22 Mark Walker 2013-09-20 07:05:01 EDT
Open a .docx file. Leave it open while copy/paste a table from it to a new file. Try to save the new file as HTML. LibreOffice closes, and recovers the original file and a blank Untitled file.

reporter:       libreport-2.1.7
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --writer --splash-pipe=5
crash_function: QTransform::type
executable:     /usr/lib64/libreoffice/program/soffice.bin
kernel:         3.10.11-200.fc19.x86_64
package:        libreoffice-core-4.1.1.2-4.fc19
reason:         Process /usr/lib64/libreoffice/program/soffice.bin was killed by signal 11 (SIGSEGV)
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 23 Sergio Monteiro Basto 2013-09-20 17:20:01 EDT
I open a save dialog box which seems modal , try block others windows , and after I try click in menu in other window and crash , bottom line crash with modal window that try to block all others windows and seems that is wrong , not just in openoffice
Comment 24 EMR_Fedora 2013-10-24 11:56:36 EDT
This seems to be a problem with the file open/save dialog box. It is repeatable, and makes using libreoffice impossible. It has been over two months since this problem cropped up, and I can't wait any longer, must switch to open office, for now.
Comment 25 Rex Dieter 2013-10-24 12:05:02 EDT
One workaround is to try removing the kde native integration bits,

yum remove libreoffice-kde
Comment 26 Kevin Kofler 2013-10-24 19:33:00 EDT
*** Bug 988643 has been marked as a duplicate of this bug. ***
Comment 27 Stephan Bergmann 2013-10-25 04:53:47 EDT
(In reply to Rex Dieter from comment #25)
> One workaround is to try removing the kde native integration bits,
> 
> yum remove libreoffice-kde

...another might be to enable "Tools - Options... - LibreOffice - General - Open/Save dialogs - Use LibreOffice dialogs"
Comment 28 Sergio Monteiro Basto 2013-10-31 13:55:41 EDT
(In reply to Stephan Bergmann from comment #27)
> ...another might be to enable "Tools - Options... - LibreOffice - General -
> Open/Save dialogs - Use LibreOffice dialogs"

yes this works here , but  LibreOffice dialogs are ugly .

Now I will try: yum remove libreoffice-kde
Comment 29 Caolan McNamara 2013-11-22 09:32:51 EST
*** Bug 1033501 has been marked as a duplicate of this bug. ***
Comment 30 Reartes Guillermo 2014-07-08 10:39:26 EDT
I am using F20, it happened only once.

ABRT pointed to this bugreport, but i put the password wrong. So i tried to report it today and there is no option to do so. So i CCd me manually.

I don't like abrt behaviour ATM. 
I am not sure if it helps, since this is closed.

This happened after i tried to save to a .doc (current doc was odf).
It seems i clicked onto an existing .doc and it crashed.
The intention was to click it and change a digit in the name.


ABRT DATA:

[System Logs]:
jul 07 17:21:40 grimjow.espada kernel: soffice.bin[31778]: segfault at 118 ip 00007f6f018f3db0 sp 00007fffc3ce11c8 error 4 in libQtGui.so.4.8.6[7f6f0157e000+a96000]
jul 07 17:21:42 grimjow.espada abrt-hook-ccpp[32445]: Saved core dump of pid 31778 (/usr/lib64/libreoffice/program/soffice.bin) to /var/tmp/abrt/ccpp-2014-07-07-17:21:40-31778 (161685504 bytes)
[User Logs]:

kernel: 3.14.9-200.fc20.x86_64
component: libreoffice 
reason: soffice.bin killed by SIGSEGV

pkg_release: 1.fc20
pkg_version: 4.2.5.2

Note You need to log in before you can comment on or make changes to this bug.