Bug 984745 - spice client crashes at first Shift-Ctrl-V in Microsoft Outlook
spice client crashes at first Shift-Ctrl-V in Microsoft Outlook
Status: CLOSED DUPLICATE of bug 906558
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-gtk (Show other bugs)
6.4
x86_64 Linux
high Severity medium
: rc
: ---
Assigned To: Christophe Fergeau
Desktop QE
:
Depends On: 826036
Blocks: 906558 906560
  Show dependency treegraph
 
Reported: 2013-07-15 17:05 EDT by Nikhil Gupta
Modified: 2013-07-19 15:42 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 826036
Environment:
Last Closed: 2013-07-19 15:42:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
core and sosreport (12.35 MB, application/x-gzip)
2013-07-15 17:05 EDT, Nikhil Gupta
no flags Details

  None (edit)
Description Nikhil Gupta 2013-07-15 17:05:21 EDT
Created attachment 773905 [details]
core and sosreport

+++ This bug was initially created as a clone of Bug #826036 +++

Description of problem:
virt-viewer-0.5.2-18.el6_4.2: Process /usr/bin/remote-viewer was killed by signal 6 (SIGABRT)

Version-Release number of selected component (if applicable):
spice-gtk-0.14-7.el6.x86_64

How reproducible:
Attached video
  
Actual results:

virt-viewer-0.5.2-18.el6_4.2: Process /usr/bin/remote-viewer was killed by signal 6 (SIGABRT)
abrt_version:   2.0.8
backtrace_rating: 0
cgroup:         
cmdline:        remote-viewer --spice-controller
executable:     /usr/bin/remote-viewer
kernel:         2.6.32-358.el6.x86_64
pid:            40134
pwd:            /home/jauser
reported_to:    file: /tmp/outlookfoldercrash.log
time:           Tue 18 Jun 2013 09:34:56 AM EDT
uid:            500
username:       jauser
xsession_errors: 

backtrace:      Text file, 12490 bytes
build_ids:      Text file, 4305 bytes
dso_list:       Text file, 5484 bytes
maps:           Text file, 47390 bytes
sosreport.tar.xz: Binary file, 534756 bytes
var_log_messages: Text file, 9526 bytes

comment:
:Right click folder in outlook 2010 >> make new folder >> start to list folders >> viewer , not VM, crashes. You can get back into it.
:Please see case #00853751
: 

environ:
:ORBIT_SOCKETDIR=/tmp/orbit-jauser
:XSUNTRANSPORT=shmem
:HOSTNAME=vmclient-04
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:TERM=dumb
:SHELL=/bin/bash
:XDG_SESSION_COOKIE=ee5b11e8d1b868daa30696c100000015-1371487177.49068-1941585661
:HISTSIZE=1000
:XRE_PROFILE_NAME=
:GTK_RC_FILES=/etc/gtk/gtkrc:/home/jauser/.gtkrc-1.2-gnome2
:QTDIR=/usr/lib64/qt-3.3
:QTINC=/usr/lib64/qt-3.3/include
:MOZILLA_FIVE_HOME=/usr/lib64/firefox
:NSS_SSL_CBC_RANDOM_IV=1
:IMSETTINGS_MODULE=none
:XRE_PROFILE_LOCAL_PATH=
:USER=jauser
:XRE_START_OFFLINE=
:LD_LIBRARY_PATH=/usr/lib64/xulrunner:/usr/lib64/firefox:/usr/lib64/firefox/plugins:/usr/lib64/firefox
:SSH_AUTH_SOCK=/tmp/keyring-SgZvmf/socket.ssh
:GNOME_KEYRING_SOCKET=/tmp/keyring-SgZvmf/socket
:GNOME_DISABLE_CRASH_DIALOG=1
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/2552,unix/unix:/tmp/.ICE-unix/2552
:USERNAME=jauser
:LIBPATH=/usr/lib64/firefox:/usr/lib64/firefox
:MOZ_APP_LAUNCHER=/usr/bin/firefox
:MOZ_PLUGIN_PATH=/usr/lib64/mozilla/plugins-wrapped:/usr/lib64/firefox/plugins-wrapped
:FONTCONFIG_PATH=/etc/fonts:/usr/lib64/firefox/res/Xft
:DESKTOP_SESSION=gnome
:PATH=/usr/lib64/qt-3.3/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/jauser/bin
:MAIL=/var/spool/mail/jauser
:QT_IM_MODULE=xim
:PWD=/home/jauser
:XMODIFIERS=@im=none
:GDM_KEYBOARD_LAYOUT=us
:GNOME_KEYRING_PID=2542
:LANG=en_US.utf8
:KDE_IS_PRELINKED=1
:XRE_PROFILE_PATH=
:GDM_LANG=en_US.utf8
:KDEDIRS=/usr
:XSUNSMESIZE=512
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
:SPICE_FOREIGN_MENU_SOCKET=/tmp/spicec-sGCD4A/spice-foreign
:SHLVL=1
:HOME=/home/jauser
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:DYLD_LIBRARY_PATH=/usr/lib64/firefox:/usr/lib64/firefox
:LOGNAME=jauser
:MOZ_LAUNCHED_CHILD=
:MOZ_GRE_CONF=/etc/gre.d/gre64.conf
:CVS_RSH=ssh
:QTLIB=/usr/lib64/qt-3.3/lib
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-XoMtzAvOAP,guid=9da66153a8b286a593979e5700000b8d
:SPICE_XPI_SOCKET=/tmp/spicec-sGCD4A/spice-xpi
:NO_EM_RESTART=
:'LESSOPEN=|/usr/bin/lesspipe.sh %s'
:SHLIB_PATH=/usr/lib64/firefox:/usr/lib64/firefox
:XRE_BINARY_PATH=
:WINDOWPATH=1
:DISPLAY=:0.0
:XUL_APP_FILE=
:NO_AT_BRIDGE=1
:G_BROKEN_FILENAMES=1
:XAUTHORITY=/var/run/gdm/auth-for-jauser-rRKTxI/database

event_log:
:2013-06-18-09:38:20> Analyzing coredump 'coredump'
:2013-06-18-09:38:20  Generating backtrace
:2013-06-18-09:38:22  Backtrace is generated and saved, 12490 bytes
:2013-06-18-09:38:35> Element 'xsession_errors' saved
:2013-06-18-09:40:07> Can't open '/tmp/' for writing. Please select another file: /tmp/outlookfoldercrash.log
:2013-06-18-09:40:07  The report was appended to /tmp/outlookfoldercrash.log


Expected results:


Additional info:

--- Additional comment from John L Magee on 2012-05-29 08:45:18 EDT ---

> The outlook problem still exists. It only crashes the client, not the whole
> VM. If you open the outlook link on the desktop I sent, hit SHIFT-CTRL-V
> together to open the Move dialog, the client crashes. When the spice client
> is then started again, the expected dialog box appears. From this point on,
> until the VM is restarted, the SHIFT-CTRL-V works without issue.

Alon has the means to reproduce

--- Additional comment from Marc-Andre Lureau on 2012-05-29 08:50:41 EDT ---

Which spice client? virt-manager? spicec? virt-viewer?

--- Additional comment from Alon Levy on 2012-05-29 09:29:13 EDT ---

I think it's both, since the problem is in common, here is a stack trace from running remote-viewer:

(qemu) (/home/alon/bin/spice2:3258): Spice-Warning **: ../spice-common/common/canvas_base.c:741:canvas_get_lz: a palette is missing (for bpp to rgb decoding)

(/home/alon/bin/spice2:3258): Spice-CRITICAL **: ../spice-common/common/canvas_base.c:1128:canvas_get_image_internal: condition `surface != NULL' failed
#0  0x0000003b0560e090 in __read_nocancel () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007fdf5f1f3b92 in spice_backtrace_gstack () at backtrace.c:100
#2  0x00007fdf5f1f3c4f in spice_backtrace () at backtrace.c:131
#3  0x00007fdf5f1fd176 in spice_logv (log_domain=0x7fdf5f2b6a79 "Spice", log_level=SPICE_LOG_LEVEL_CRITICAL, strloc=0x7fdf5f2b7480 "../spice-common/common/canvas_base.c:1128", function=0x7fdf5f2b81e0 "canvas_get_image_internal", format=0x7fdf5f2b6b33 "condition `%s' failed", args=0x7fdf54e55708) at log.c:108
#4  0x00007fdf5f1fd23f in spice_log (log_domain=0x7fdf5f2b6a79 "Spice", log_level=SPICE_LOG_LEVEL_CRITICAL, strloc=0x7fdf5f2b7480 "../spice-common/common/canvas_base.c:1128", function=0x7fdf5f2b81e0 "canvas_get_image_internal", format=0x7fdf5f2b6b33 "condition `%s' failed") at log.c:123
#5  0x00007fdf5f1e52de in canvas_get_image_internal (canvas=0x29287c0, image=0x465b520, want_original=1, real_get=0) at ../spice-common/common/canvas_base.c:1128
#6  0x00007fdf5f1e5735 in canvas_touch_image (canvas=0x29287c0, image=0x465b520) at ../spice-common/common/canvas_base.c:1269
#7  0x00007fdf5f1e7d9e in canvas_draw_copy (spice_canvas=0x29287c0, bbox=0x465b4c4, clip=0x465b4d8, copy=0x465b4e8) at ../spice-common/common/canvas_base.c:2133
#8  0x00007fdf5f1ca476 in display_handle_draw_copy (channel=0x2562e00 [SpiceDisplayChannel], in=0x46a22f0) at channel-display.c:1254
#9  0x00007fdf5f1cb174 in spice_display_handle_msg (channel=0x2562e00 [SpiceDisplayChannel], msg=0x46a22f0) at channel-display.c:1433
#10 0x00007fdf5f1c09a3 in spice_channel_recv_msg (channel=0x2562e00 [SpiceDisplayChannel], msg_handler=0x7fdf5f1cb0ba <spice_display_handle_msg>, data=0x0) at spice-channel.c:1838
#11 0x00007fdf5f1c0f29 in spice_channel_iterate_read (channel=0x2562e00 [SpiceDisplayChannel]) at spice-channel.c:2000
#12 0x00007fdf5f1c11c9 in spice_channel_iterate (channel=0x2562e00 [SpiceDisplayChannel]) at spice-channel.c:2058
#13 0x00007fdf5f1c199c in spice_channel_coroutine (data=0x2562e00) at spice-channel.c:2215
#14 0x00007fdf5f1f2737 in coroutine_trampoline (cc=0x2562eb8) at coroutine_ucontext.c:56
#15 0x00007fdf5f1f2420 in continuation_trampoline (i0=39202488, i1=0) at continuation.c:49
#16 0x0000003b04e45f30 in ?? () from /lib64/libc.so.6
#17 0x0000000002563280 in ?? ()
#18 0x0000000000000000 in ?? ()

--- Additional comment from Alon Levy on 2012-05-29 09:30:18 EDT ---

ignore the "(qemu)" up there, I run both qemu+remote-viewer from the same script with the same stdout. You can see the error comes closely after a warning - I imagine that warning might be important.

Alon

--- Additional comment from Fedora Admin XMLRPC Client on 2012-10-15 02:12:40 EDT ---

This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

--- Additional comment from Fedora Update System on 2013-02-06 14:54:20 EST ---

spice-gtk-0.17-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/spice-gtk-0.17-1.fc18

--- Additional comment from Fedora Update System on 2013-02-07 21:28:53 EST ---

Package spice-gtk-0.17-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing spice-gtk-0.17-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-2081/spice-gtk-0.17-1.fc18
then log in and leave karma (feedback).

--- Additional comment from Fedora Update System on 2013-02-13 13:55:59 EST ---

spice-gtk-0.18-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/spice-gtk-0.18-1.fc18

--- Additional comment from Fedora Update System on 2013-04-03 00:39:23 EDT ---

spice-gtk-0.18-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 4 Nikhil Gupta 2013-07-19 15:42:56 EDT

*** This bug has been marked as a duplicate of bug 906558 ***

Note You need to log in before you can comment on or make changes to this bug.