Bug 906558 - spice client crashes at first Shift-Ctrl-V in Microsoft Outlook
spice client crashes at first Shift-Ctrl-V in Microsoft Outlook
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-gtk (Show other bugs)
6.5
x86_64 Linux
high Severity high
: rc
: 6.5
Assigned To: Yonit Halperin
Desktop QE
: ZStream
: 895221 984745 (view as bug list)
Depends On: 826036 984745
Blocks: 906560 988924
  Show dependency treegraph
 
Reported: 2013-01-31 16:51 EST by Yonit Halperin
Modified: 2013-11-21 03:25 EST (History)
22 users (show)

See Also:
Fixed In Version: spice-gtk-0.20-1.el6
Doc Type: Bug Fix
Doc Text:
Cause: The first time you SHIFT-CTRL-V on a message window in outlook. Consequence: Spice-gtk client crashes. Fix: Cache palettes of un-rendered bitmaps Result: The client no longer crashes at first Shift-Ctrl-V in Microsoft Outlook .
Story Points: ---
Clone Of: 826036
: 906560 (view as bug list)
Environment:
Last Closed: 2013-11-21 03:25:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix not caching palettes of un-rendered bitmaps (2.04 KB, patch)
2013-01-31 16:53 EST, Yonit Halperin
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 343333 None None None Never

  None (edit)
Description Yonit Halperin 2013-01-31 16:51:41 EST
+++ This bug was initially created as a clone of Bug #826036 +++

Description of problem:

The first time you SHIFT-CTRL-V on a message window in outlook, the client crashes.

Version-Release number of selected component (if applicable):

all versions.

  
--- Additional comment from John L Magee on 2012-05-29 08:45:18 EDT ---

> The outlook problem still exists. It only crashes the client, not th ewhole
> VM. If you open the outlooklink on the desktop I sent, hit SHIFT-CTRL-V
> together to open the Move dialog, the client crashes. When the spice client
> is then started again, the expected dialog box appears. From this point on,
> until the VM is restarted, the SHIFT-CTRL-V works without issue.

Alon has the means to reproduce

--- Additional comment from Marc-Andre Lureau on 2012-05-29 08:50:41 EDT ---

Which spice client? virt-manager? spicec? virt-viewer?

--- Additional comment from Alon Levy on 2012-05-29 09:29:13 EDT ---

I think it's both, since the problem is in common, here is a stack trace from running remote-viewer:

(qemu) (/home/alon/bin/spice2:3258): Spice-Warning **: ../spice-common/common/canvas_base.c:741:canvas_get_lz: a palette is missing (for bpp to rgb decoding)

(/home/alon/bin/spice2:3258): Spice-CRITICAL **: ../spice-common/common/canvas_base.c:1128:canvas_get_image_internal: condition `surface != NULL' failed
#0  0x0000003b0560e090 in __read_nocancel () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007fdf5f1f3b92 in spice_backtrace_gstack () at backtrace.c:100
#2  0x00007fdf5f1f3c4f in spice_backtrace () at backtrace.c:131
#3  0x00007fdf5f1fd176 in spice_logv (log_domain=0x7fdf5f2b6a79 "Spice", log_level=SPICE_LOG_LEVEL_CRITICAL, strloc=0x7fdf5f2b7480 "../spice-common/common/canvas_base.c:1128", function=0x7fdf5f2b81e0 "canvas_get_image_internal", format=0x7fdf5f2b6b33 "condition `%s' failed", args=0x7fdf54e55708) at log.c:108
#4  0x00007fdf5f1fd23f in spice_log (log_domain=0x7fdf5f2b6a79 "Spice", log_level=SPICE_LOG_LEVEL_CRITICAL, strloc=0x7fdf5f2b7480 "../spice-common/common/canvas_base.c:1128", function=0x7fdf5f2b81e0 "canvas_get_image_internal", format=0x7fdf5f2b6b33 "condition `%s' failed") at log.c:123
#5  0x00007fdf5f1e52de in canvas_get_image_internal (canvas=0x29287c0, image=0x465b520, want_original=1, real_get=0) at ../spice-common/common/canvas_base.c:1128
#6  0x00007fdf5f1e5735 in canvas_touch_image (canvas=0x29287c0, image=0x465b520) at ../spice-common/common/canvas_base.c:1269
#7  0x00007fdf5f1e7d9e in canvas_draw_copy (spice_canvas=0x29287c0, bbox=0x465b4c4, clip=0x465b4d8, copy=0x465b4e8) at ../spice-common/common/canvas_base.c:2133
#8  0x00007fdf5f1ca476 in display_handle_draw_copy (channel=0x2562e00 [SpiceDisplayChannel], in=0x46a22f0) at channel-display.c:1254
#9  0x00007fdf5f1cb174 in spice_display_handle_msg (channel=0x2562e00 [SpiceDisplayChannel], msg=0x46a22f0) at channel-display.c:1433
#10 0x00007fdf5f1c09a3 in spice_channel_recv_msg (channel=0x2562e00 [SpiceDisplayChannel], msg_handler=0x7fdf5f1cb0ba <spice_display_handle_msg>, data=0x0) at spice-channel.c:1838
#11 0x00007fdf5f1c0f29 in spice_channel_iterate_read (channel=0x2562e00 [SpiceDisplayChannel]) at spice-channel.c:2000
#12 0x00007fdf5f1c11c9 in spice_channel_iterate (channel=0x2562e00 [SpiceDisplayChannel]) at spice-channel.c:2058
#13 0x00007fdf5f1c199c in spice_channel_coroutine (data=0x2562e00) at spice-channel.c:2215
#14 0x00007fdf5f1f2737 in coroutine_trampoline (cc=0x2562eb8) at coroutine_ucontext.c:56
#15 0x00007fdf5f1f2420 in continuation_trampoline (i0=39202488, i1=0) at continuation.c:49
#16 0x0000003b04e45f30 in ?? () from /lib64/libc.so.6
#17 0x0000000002563280 in ?? ()
#18 0x0000000000000000 in ?? ()

--- Additional comment from Alon Levy on 2012-05-29 09:30:18 EDT ---

ignore the "(qemu)" up there, I run both qemu+remote-viewer from the same script with the same stdout. You can see the error comes closely after a warning - I imagine that warning might be important.

Alon

--- Additional comment from Fedora Admin XMLRPC Client on 2012-10-15 02:12:40 EDT ---

This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 1 Yonit Halperin 2013-01-31 16:53:08 EST
Created attachment 691263 [details]
fix not caching palettes of un-rendered bitmaps
Comment 5 Christophe Fergeau 2013-05-24 10:15:22 EDT
*** Bug 895221 has been marked as a duplicate of this bug. ***
Comment 13 Nikhil Gupta 2013-07-19 15:42:56 EDT
*** Bug 984745 has been marked as a duplicate of this bug. ***
Comment 18 errata-xmlrpc 2013-11-21 03:25:42 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1577.html

Note You need to log in before you can comment on or make changes to this bug.