Bug 984915 - Project installation and deployment via REST API doesn't work
Project installation and deployment via REST API doesn't work
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ER2
: 6.0.0
Assigned To: Mark Proctor
Ivo Bek
Vikram Goyal
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-16 07:19 EDT by Ivo Bek
Modified: 2014-08-06 16:08 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:08:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivo Bek 2013-07-16 07:19:39 EDT
Description of problem:

After the fix for BZ 977300, it's still not possible to compile, test, install, and deploy a project via REST API.

When I send an installation request, I receive following response:
{"jodId":"1373971413351-3","status":"RESOURCE_NOT_EXIST","result":"Repository [test] does not exist","repositoryName":"test","projectName":"proj","buildConfig":{"name":"","value":""}}

There must be something wrong because the repository, named test, is in business central. The same output I receive when I send maven compile or test request. Server log after the maven installation contains:

12:40:54,616 INFO  [stdout] (http-/127.0.0.1:8080-3) -----installProject--- , repositoryName:test, project name:proj
12:40:54,625 INFO  [stdout] (http-/127.0.0.1:8080-3) ********************************************************************
12:40:54,626 INFO  [stdout] (http-/127.0.0.1:8080-3) **************kjar is******************* java.util.zip.ZipFile$ZipFileInflaterInputStream@19de359b
12:40:54,627 INFO  [stdout] (http-/127.0.0.1:8080-3) ********************************************************************
12:40:54,628 INFO  [org.drools.compiler.kie.builder.impl.KieRepositoryImpl] (http-/127.0.0.1:8080-3) Adding KieModule from resource :[ByteArrayResource resource=[B@784fdd6f]
12:40:54,644 INFO  [org.drools.compiler.kie.builder.impl.KieRepositoryImpl] (http-/127.0.0.1:8080-3) KieModule was added:MemoryKieModule[ ReleaseId=org.kie.workbench.services:kie-wb-common-defaultapprover:0.9]
12:40:54,649 WARN  [org.drools.compiler.kie.builder.impl.AbstractKieModule] (http-/127.0.0.1:8080-3) No files found for KieBase defaultKieBase
12:40:54,850 INFO  [stdout] (http-/127.0.0.1:8080-3) approval request result: true
12:40:54,855 INFO  [stdout] (http-/127.0.0.1:8080-3) -----installProject--- , repositoryName:test, project name:proj
12:40:54,857 INFO  [stdout] (http-/127.0.0.1:8080-3) -----FileSystem id--- :system

Also I tried to deploy a project. Response says that everything is ok but deployment isn't created. (I created the build through business central, so it's not the problem that there is nothing to be deployed).

{"jodId":"1373971329455-2","status":"ACCEPTED","result":null,"repositoryName":"test","projectName":"proj","buildConfig":{"name":"","value":""}}

Even server log won't help:
12:42:09,454 INFO  [stdout] (http-/127.0.0.1:8080-5) -----deployProject--- , repositoryName:test, project name:proj

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Marek Baluch 2013-07-18 02:44:09 EDT
There are other ways to deploy a project into the repository. Still this issue prevents automatization of most our tests TaskServer/Clustering/Performance so I would like to ask to consider this issue to be fixed in the Beta release.
Comment 3 Prakash Aradhya 2013-07-18 10:15:57 EDT
Guys,
The repository in 6.0 is new GIT based.  REST interface was originally included with BRMS 5.3 for JCR repo.

Based few email conversations couple months ago, we relaxed the requirement not to offer full REST API for 6.0.  
GIT is lot more flexible than JCR to access through various interfaces.
Please work with engineering team to find the most appropriate path for this automation.

I also appreciate if Docs can work with you and document an alternative path for customers to transition them from REST APIs.
Comment 4 Jervis Liu 2013-07-23 07:46:03 EDT
Fixed
Comment 5 Lukáš Petrovický 2013-07-23 08:18:25 EDT
Please do not forget to move fixed issues to MODIFIED.
Comment 7 Marek Baluch 2013-09-05 05:52:56 EDT
Verified on ER2.

Note You need to log in before you can comment on or make changes to this bug.