Bug 985220 - logcollector does not collect /var/log/sanlock.log from hypervisors
logcollector does not collect /var/log/sanlock.log from hypervisors
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.1.0
Unspecified Unspecified
medium Severity medium
: ---
: 3.3.0
Assigned To: Allon Mureinik
Leonid Natapov
storage
: EasyFix, ZStream
: 985216 (view as bug list)
Depends On:
Blocks: 987042 1019461
  Show dependency treegraph
 
Reported: 2013-07-17 02:40 EDT by David Gibson
Modified: 2016-02-10 11:52 EST (History)
12 users (show)

See Also:
Fixed In Version: 4.12.0-rc2
Doc Type: Enhancement
Doc Text:
The log collector tool now collects /var/log/sanlock.log from hypervisors.
Story Points: ---
Clone Of:
: 987042 (view as bug list)
Environment:
Last Closed: 2014-01-21 11:28:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
abaron: Triaged+


Attachments (Terms of Use)
Patch to add sanlock.py in vdsm plugin of sosreport (528 bytes, patch)
2013-07-17 04:04 EDT, Humble Chirammal
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 17001 None None None Never

  None (edit)
Description David Gibson 2013-07-17 02:40:32 EDT
Description of problem:

/var/log/sanlock.log is useful for debugging sanlock problems.

Version-Release number of selected component (if applicable):

rhevm-log-collector-3.1.0-10.el6ev.noarch
sos-2.2-38.el6.noarch
Comment 1 Humble Chirammal 2013-07-17 04:04:11 EDT
Created attachment 774659 [details]
Patch to add sanlock.py in vdsm plugin of sosreport
Comment 2 Humble Chirammal 2013-07-17 04:05:42 EDT
(In reply to Humble Chirammal from comment #1)
> Created attachment 774659 [details]
> Patch to add sanlock.py in vdsm plugin of sosreport

The patch should collect that information. I will push that to upstream/downstream soon.
Comment 3 Itamar Heim 2013-07-17 04:15:56 EDT
*** Bug 985216 has been marked as a duplicate of this bug. ***
Comment 4 Itamar Heim 2013-07-17 04:18:47 EDT
vdsm 3.2 obsoletes 3.1.z - removing 3.1.z flag
also, iiuc patch is in vdsm side, not log collector side - changing component.
Comment 5 David Gibson 2013-07-17 21:41:09 EDT
I'm a bit unclear on the lifetimes for the RHEV products.  We are still supporting customers with RHEV 3.1, and this logcollector fault makes it more difficult, so why are we removing 3.1.z target?
Comment 8 Leonid Natapov 2013-07-30 09:00:41 EDT
fixed. log collector collects sanlog.log from hosts.
Comment 9 Charlie 2013-11-27 19:34:45 EST
This bug is currently attached to errata RHBA-2013:15291. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 10 errata-xmlrpc 2014-01-21 11:28:40 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0040.html

Note You need to log in before you can comment on or make changes to this bug.