Bug 985260 - Can't change (edit vm) console protocol when VM is down
Can't change (edit vm) console protocol when VM is down
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity high
: ---
: 3.3.0
Assigned To: Michal Skrivanek
Pavel Stehlik
virt
: Regression
: 985320 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-17 04:11 EDT by Aharon Canan
Modified: 2015-09-22 09 EDT (History)
7 users (show)

See Also:
Fixed In Version: is6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-22 10:26:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aharon Canan 2013-07-17 04:11:48 EDT
Description of problem:
trying to set spice console instead of vnc failed while VM is down

Version-Release number of selected component (if applicable):
is5

How reproducible:
100%

Steps to Reproduce:
1. create VM
2. edit VM - advanced - console - set spice instead of vnc
3.

Actual results:
failed

Expected results:
should work

Additional info:
2013-07-17 11:05:24,557 ERROR [org.ovirt.engine.core.utils.ObjectIdentityChecker] (ajp-/127.0.0.1:8702-1) Field createdByUserId can not be updated when status is Down
2013-07-17 11:05:24,557 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (ajp-/127.0.0.1:8702-1) ObjectIdentityChecker.IsUpdateValid:: Not updatable field 'createdByUserId' was updated
2013-07-17 11:05:24,557 WARN  [org.ovirt.engine.core.bll.UpdateVmCommand] (ajp-/127.0.0.1:8702-1) CanDoAction of action UpdateVm failed. Reasons:VAR__ACTION__UPDATE,VAR__TYPE__VM,VM_CANNOT_UPDATE_ILLEGAL_FIELD
2013-07-17 11:05:24,557 INFO  [org.ovirt.engine.core.bll.UpdateVmCommand] (ajp-/127.0.0.1:8702-1) Lock freed to object EngineLock [exclusiveLocks= key: vm01 value: VM_NAME
Comment 3 Michal Skrivanek 2013-07-22 10:26:12 EDT
and you didn't notice *anything* you change in the dialog doesn't work?
This is fixed in is6
Comment 4 Aharon Canan 2013-07-23 03:31:59 EDT
please move to ON_QA instead of close - we need to verify.
Comment 5 Michal Skrivanek 2013-07-23 04:05:04 EDT
- why didn't you do that yourself?;)
btw you should have tested that on latest build which at the time of testing was is6
Comment 6 Michal Skrivanek 2013-07-25 10:46:11 EDT
*** Bug 985320 has been marked as a duplicate of this bug. ***
Comment 8 Itamar Heim 2014-01-21 17:22:50 EST
Closing - RHEV 3.3 Released
Comment 9 Itamar Heim 2014-01-21 17:23:59 EST
Closing - RHEV 3.3 Released
Comment 10 Itamar Heim 2014-01-21 17:27:45 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.