Bug 985275 - RHEV-H will hung on installation process if leave the password blank.
RHEV-H will hung on installation process if leave the password blank.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.5
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
:
: 1001977 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-17 04:40 EDT by cshao
Modified: 2014-01-21 14:45 EST (History)
15 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.1-2.el6
Doc Type: Bug Fix
Doc Text:
Previously the installer accepted an empty password but failed to complete the installation. This happened due to an incorrect password check. Now the password is checked correctly and the user get's feedback about different problems such as password length. Additionally the installer only allows the user to carry on when a valid password is given.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 14:45:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
hung (75.19 KB, image/png)
2013-07-17 04:40 EDT, cshao
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 18029 None None None Never

  None (edit)
Description cshao 2013-07-17 04:40:54 EDT
Created attachment 774679 [details]
hung

Description of problem:
RHEV-H will hung on installation process if leave the password blank. User must press "Ctrl + Alt + Del" or power key to restart the host.

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.5-20130222.0.auto1732.el6
virt-node-3.0.0-3.999.20130716184106gitdb92e70.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. BOOT from PXE and install RHEV-H 6.5.
2. Enter "setting password" page.
3. Leave the password blank and press "Install" key direct.

Actual results:
RHEV-H will hung on installation process if leave the password blank. User must press "Ctrl + Alt + Del" or power key to restart the host.

Expected results:
Pop-up an indication like "You must enter a valid password".

Additional info:
Comment 2 Fabian Deutsch 2013-08-14 13:29:00 EDT
The patch fixes the password page.
The problem was that the empty admin password prevented the installer from installing.
The solution is to enforce an admin password.

Tested as follows:
1. Enter password page (in patched installer) - <Install> button is disabled
2. Enter ab in Password field
3. Hint is shown to eneter at least 3 chars - <Install> is disabled
4. Enter abc
5. Hint is shown to confirm the password - <Install> is disabled
6. Enter abc in Confirm Password field
7. Enter abcd in Password and Confirm Password fields
8. Notice about weak password is shown - <Install> is enabled

9. Clear Password and Confirm password fields
10. Hint about min length of 3 chars is shown - <Install> is disabled

11. Enter valid password (abcd) and hit <Install>
12. Installer starts and completes installation
Comment 3 bohai 2013-08-28 21:13:19 EDT
*** Bug 1001977 has been marked as a duplicate of this bug. ***
Comment 6 cshao 2013-10-24 07:07:10 EDT
rhev-hypervisor6-6.5-20131017.0
ovirt-node-3.0.1-4.el6.noarch

User can't press install key if leave the password blank in current version.

1. Enter password page  - <Install> button is disabled
2. Enter ab in Password field
3. Hint is shown to eneter at least 3 chars - <Install> is disabled
4. Enter abc
5. Hint is shown to confirm the password - <Install> is disabled
6. Enter abc in Confirm Password field
7. Enter abcd in Password and Confirm Password fields
8. Notice about weak password is shown - <Install> is enabled
9. Clear Password and Confirm password fields
10. Hint about min length of 3 chars is shown - <Install> is disabled
11. Enter valid password (abcd) and hit <Install>
12. Installer starts and completes installation

So the bug is fixed, change bug status to VERIFIED.
Comment 9 Cheryn Tan 2013-11-07 19:38:51 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 11 errata-xmlrpc 2014-01-21 14:45:56 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.