Bug 985313 - Newly created virtual machines have VNC as the default console
Newly created virtual machines have VNC as the default console
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.3.0
Unspecified Unspecified
medium Severity unspecified
: ---
: 3.3.0
Assigned To: Arik
Dušan Kajan
virt
:
: 985896 (view as bug list)
Depends On:
Blocks: 1019461
  Show dependency treegraph
 
Reported: 2013-07-17 05:42 EDT by Tareq Alayan
Modified: 2015-09-22 09 EDT (History)
10 users (show)

See Also:
Fixed In Version: is8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 17:13:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 17386 None None None Never

  None (edit)
Description Tareq Alayan 2013-07-17 05:42:06 EDT
Description of problem:
Newly created vms created with VNC as default console

Version-Release number of selected component (if applicable):
is5

How reproducible:
always

Steps to Reproduce:
1. create vm
2. look at the console type
3.

Actual results:
VNC

Expected results:
SPICE

Additional info:
Comment 1 Itamar Heim 2013-07-18 00:47:00 EDT
did you choose optimize for server (vnc) or for desktop (spice)?
andrew - does it make sense to still default to vnc for servers?
Comment 2 Andrew Cathrow 2013-07-18 08:06:50 EDT
We should default to Spice for all.
CPU utilization is actually better for spice than vnc even on run level 3
Comment 3 Itamar Heim 2013-07-18 10:53:53 EDT
*** Bug 985896 has been marked as a duplicate of this bug. ***
Comment 4 Omer Frenkel 2013-07-28 08:17:03 EDT
I verified this is a UI issue (didn't check user portal, though):
i can see that vnc is selected by defult on create vm,
regardless to server/desktop selection.
also tested with REST
created vm with the following xml:
<vm>
    <name>omerRest</name>
    <cluster>
        <name>rhel</name>
    </cluster>
    <template>
        <name>Blank</name>
    </template>
    <memory>536870912</memory>
</vm>

and it was created with spice.
Comment 6 Arik 2013-07-28 11:33:56 EDT
When creating a VM the default display type is now taken from the template it is based on for desktops and servers VMs. The problem is that the default display type of the 'Blank' template is set to VNC.

Regarding the check with REST mentioned in comment #4 - we found that there is a bug that causes the default display type of every VM which is created using REST to be set to SPICE (should be fixed by: http://gerrit.ovirt.org/#/c/17382/).
Comment 8 Dušan Kajan 2013-08-05 04:26:53 EDT
verified on is8
Comment 9 Itamar Heim 2014-01-21 17:13:49 EST
Closing - RHEV 3.3 Released
Comment 10 Itamar Heim 2014-01-21 17:21:36 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.