Bug 985409 - [abrt] dnf-0.3.8-2.git85524ae.fc19: util.py:60:file_timestamp:OSError: [Errno 2] No such file or directory: '/var/cache/dnf/x86_64/19/rpmfusion-nonfree/repodata/915cba40e0cdb6d97cc6fbbe42bbfec93ef0406897c765350d1bb29c6e231b76-primary.xml.gz'
[abrt] dnf-0.3.8-2.git85524ae.fc19: util.py:60:file_timestamp:OSError: [Errno...
Status: CLOSED DUPLICATE of bug 980227
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
abrt_hash:d84b427daf66ab40d94ae5ad53b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-17 08:34 EDT by Karel Volný
Modified: 2013-07-17 09:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-17 09:21:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.82 KB, text/plain)
2013-07-17 08:34 EDT, Karel Volný
no flags Details
File: core_backtrace (1.11 KB, text/plain)
2013-07-17 08:34 EDT, Karel Volný
no flags Details
File: environ (2.45 KB, text/plain)
2013-07-17 08:35 EDT, Karel Volný
no flags Details

  None (edit)
Description Karel Volný 2013-07-17 08:34:48 EDT
Description of problem:
I've just did dnf upgrade

for some reason the downloads were very slow, but other than that everything seemed to go fine

I got the traceback only after the upgrade was completely finished

Version-Release number of selected component:
dnf-0.3.8-2.git85524ae.fc19

Additional info:
reporter:       libreport-2.1.5
cmdline:        /usr/bin/python /bin/dnf upgrade
executable:     /bin/dnf
kernel:         3.9.9-302.fc19.x86_64
runlevel:       N 5
uid:            0

Truncated backtrace:
util.py:60:file_timestamp:OSError: [Errno 2] No such file or directory: '/var/cache/dnf/x86_64/19/rpmfusion-nonfree/repodata/915cba40e0cdb6d97cc6fbbe42bbfec93ef0406897c765350d1bb29c6e231b76-primary.xml.gz'

Traceback (most recent call last):
  File "/bin/dnf", line 35, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 277, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 48, in main
    return 1
  File "/usr/lib/python2.7/site-packages/dnf/yum/base.py", line 124, in __exit__
    self.close()
  File "/usr/lib/python2.7/site-packages/dnf/yum/base.py", line 238, in close
    self._store_persistent_data()
  File "/usr/lib/python2.7/site-packages/dnf/yum/base.py", line 166, in _store_persistent_data
    if r.metadata_expire_in()[1] <= 0]
  File "/usr/lib/python2.7/site-packages/dnf/repo.py", line 410, in metadata_expire_in
    expiration = self.metadata_expire - self.metadata.age
  File "/usr/lib/python2.7/site-packages/dnf/repo.py", line 101, in age
    return self.file_age('primary')
  File "/usr/lib/python2.7/site-packages/dnf/repo.py", line 117, in file_age
    return time.time() - self.file_timestamp(what)
  File "/usr/lib/python2.7/site-packages/dnf/repo.py", line 120, in file_timestamp
    return dnf.util.file_timestamp(self.repo_dct[what])
  File "/usr/lib/python2.7/site-packages/dnf/util.py", line 60, in file_timestamp
    return os.stat(fn).st_mtime
OSError: [Errno 2] No such file or directory: '/var/cache/dnf/x86_64/19/rpmfusion-nonfree/repodata/915cba40e0cdb6d97cc6fbbe42bbfec93ef0406897c765350d1bb29c6e231b76-primary.xml.gz'

Local variables in innermost frame:
fn: '/var/cache/dnf/x86_64/19/rpmfusion-nonfree/repodata/915cba40e0cdb6d97cc6fbbe42bbfec93ef0406897c765350d1bb29c6e231b76-primary.xml.gz'
Comment 1 Karel Volný 2013-07-17 08:34:52 EDT
Created attachment 774753 [details]
File: backtrace
Comment 2 Karel Volný 2013-07-17 08:34:56 EDT
Created attachment 774754 [details]
File: core_backtrace
Comment 3 Karel Volný 2013-07-17 08:35:02 EDT
Created attachment 774755 [details]
File: environ
Comment 4 Ales Kozumplik 2013-07-17 09:21:55 EDT
Hi Karel, this is a dupe of bug 980227 and actually fixed in dnf-0.3.9 so you shouldn't see this again after upgrading to it.

*** This bug has been marked as a duplicate of bug 980227 ***

Note You need to log in before you can comment on or make changes to this bug.