Bug 985454 - [RFE] QoS support for volumes
[RFE] QoS support for volumes
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
4.0
Unspecified Unspecified
low Severity low
: Upstream M3
: 4.0
Assigned To: Eric Harney
Dafna Ron
https://blueprints.launchpad.net/cind...
: FutureFeature, OtherQA
Depends On:
Blocks: RHOS40RFE 988444
  Show dependency treegraph
 
Reported: 2013-07-17 10:11 EDT by Eric Harney
Modified: 2016-04-26 09:24 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Quality of service (QoS) is now configurable for Block Storage volumes. This update provides a framework in Block Storage for both front-end (Compute) and back-end (Block Storage) QoS based on volume type and user-defined specifications. This feature is managed with the Block Storage CLI 'cinder qos-*' commands.
Story Points: ---
Clone Of:
: 988444 (view as bug list)
Environment:
Last Closed: 2013-12-19 18:55:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 29737 None None None Never
OpenStack gerrit 42521 None None None Never
OpenStack gerrit 46979 None None None Never

  None (edit)
Description Eric Harney 2013-07-17 10:11:55 EDT
Implement QoS support for volumes

This patch is to implement generic Quality-of-Service(QoS) support for volumes.
While QoS can mean a lot things, here in this implementation it mainly refers
to throttling/rate-limiting and performance assurance. The goal is 1) to add an
interface so that cloud/Cinder admins can use to express QoS requirements for
volumes; 2) to define common performance characteristics for volume; 3) to
change scheduler so that it can filter out unqualified back-ends.

(from https://review.openstack.org/#/c/29737/)

https://blueprints.launchpad.net/cinder/+spec/pass-ratelimit-info-to-nova
Comment 4 Scott Lewis 2013-08-01 13:37:59 EDT
Matched priority to upstream.
Comment 9 Haim 2013-09-01 08:04:16 EDT
setting need-info on developer.
Comment 13 Haim 2013-11-21 08:45:05 EST
not going to be tested on Havana, we're still missing information on how to approach it, adding to the otherQa track,
Comment 18 errata-xmlrpc 2013-12-19 18:55:03 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.