Bug 988444 - [Doc] [RFE] QoS support for volumes
[Doc] [RFE] QoS support for volumes
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: doc-Installation_and_Configuration_Guide (Show other bugs)
4.0
Unspecified Unspecified
medium Severity medium
: async
: 5.0 (RHEL 7)
Assigned To: Don Domingo
ecs-bugs
https://blueprints.launchpad.net/cind...
docs-rhos5-ups
: Documentation, FutureFeature, Triaged, ZStream
: 989716 (view as bug list)
Depends On: 985454 989716
Blocks: 978544
  Show dependency treegraph
 
Reported: 2013-07-25 11:32 EDT by Stephen Gordon
Modified: 2016-04-26 19:24 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 985454
Environment:
Last Closed: 2015-03-09 23:36:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 29737 None None None Never

  None (edit)
Description Stephen Gordon 2013-07-25 11:32:34 EDT
+++ This bug was initially created as a clone of Bug #985454 +++

Implement QoS support for volumes

This patch is to implement generic Quality-of-Service(QoS) support for volumes.
While QoS can mean a lot things, here in this implementation it mainly refers
to throttling/rate-limiting and performance assurance. The goal is 1) to add an
interface so that cloud/Cinder admins can use to express QoS requirements for
volumes; 2) to define common performance characteristics for volume; 3) to
change scheduler so that it can filter out unqualified back-ends.

(from https://review.openstack.org/#/c/29737/)

https://blueprints.launchpad.net/cinder/+spec/pass-ratelimit-info-to-nova
Comment 2 Don Domingo 2014-02-09 22:14:45 EST
Note: CLI commands for setting QOS are now included in the upstream Config Reference Guide.

http://docs.openstack.org/user-guide/content/cinderclient_commands.html
Comment 4 Don Domingo 2014-02-11 22:56:52 EST
The upstream CLI reference documents the following cinder qos-* commands:

* qos-associate
* qos-create
* qos-delete
* qos-disassociate
* qos-disassociate-all
* qos-get-association
* qos-key
* qos-list
* qos-show

Link:
http://docs.openstack.org/user-guide/content/cinderclient_commands.html
Comment 6 Don Domingo 2014-03-31 22:21:14 EDT
*** Bug 989716 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.