Bug 985514 - Installing cartridges via %posttrans in RPM is unreliable
Installing cartridges via %posttrans in RPM is unreliable
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity high
: ---
: ---
Assigned To: Jhon Honce
libra bugs
:
: 986080 988133 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-17 12:22 EDT by Dan Mace
Modified: 2015-05-14 19:24 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-07 18:55:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Mace 2013-07-17 12:22:11 EDT
Description of problem:

In the past, cartridges were installed on nodes via RPM %post. This turned out to be unreliable for important edge cases. The install was moved to %posttrans, which solved the edge cases, but shares the same fundamental flaw as %post: the install occurs outside the RPM transaction, and any failure during the install is considered non-fatal to the overall RPM transaction.

This is dangerous, because cartridge installation failure (via oo-admin-cartridge) is absolutely fatal to the RPM installation: if the cartridge installation fails, the node is invalid for use for the failed cartridge.

Failure to install a cartridge into the cartridge repository during RPM installation must be fatal to the RPM installation, or must somehow be detected during node validation.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Jhon Honce 2013-07-26 14:59:25 EDT
*** Bug 986080 has been marked as a duplicate of this bug. ***
Comment 2 openshift-github-bot 2013-07-30 22:33:59 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/bf24961cc7a20d705a2eb51af45805384f137177
Bug 985514 - Update CartridgeRepository when mcollectived restarted

* Remove all oo-admin-cartridge calls from spec files
Comment 5 openshift-github-bot 2013-08-01 20:18:32 EDT
Commit pushed to master at https://github.com/openshift/li

https://github.com/openshift/li/commit/9382e34ba1e1d6e0051b8f3adc915cb46c461b7e
Bug 985514 - Update CartridgeRepository when mcollectived restarted

* Remove all oo-admin-cartridge calls from spec files
Comment 6 Meng Bo 2013-08-02 04:13:29 EDT
Verified on devenv-stage_435, with following steps

1. Launch devenv-stage_424.
2. Backup the cartridge_repository for compare
#mkdir ~/repo
#cp -r /var/lib/openshift/.cartridge_repository ~/repo
3. Update the cartridge to latest version
#yum update openshift-origin-cartridge*
4. Review the cartridge repository
#diff -r repo/ /var/lib/openshift/.cartridge_repository/
5. Update the mcollective and restart it
#yum update openshift-origin-msg-node-mcollective.noarch
#service mcollective restart
6. Review the cartridge repository again
#diff -r repo/ /var/lib/openshift/.cartridge_repository/

The changes reflect in step6 but do not reflect in step4.

Move bug to verified.
Comment 7 Jhon Honce 2013-08-05 21:33:01 EDT
*** Bug 988133 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.