Bug 988133 - Sending a USR1 sig causes mcollective to use up 100% cpu. Need different way to reload cartridge cache.
Sending a USR1 sig causes mcollective to use up 100% cpu. Need different way ...
Status: CLOSED DUPLICATE of bug 985514
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jhon Honce
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-24 15:57 EDT by Krishna Raman
Modified: 2015-05-14 19:12 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-05 21:33:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Krishna Raman 2013-07-24 15:57:19 EDT
Description of problem:
Sending a USR1 sig causes mcollective to use up 100% cpu. Need different way to reload cartridge cache.

Version-Release number of selected component (if applicable):
Origin release 2

How reproducible:
Always

Steps to Reproduce:
1. run upgrade test
2.
3.

Actual results:
mcollective unresponsive and using 100% cpu

Expected results:
Cartridge cache reloaded

Additional info:
Comment 1 Krishna Raman 2013-07-24 15:57:40 EDT
Potential fix in https://github.com/openshift/origin-server/pull/3157
Comment 2 Krishna Raman 2013-07-25 12:28:52 EDT
Workaround added https://github.com/openshift/origin-server/pull/3167
Comment 3 Jhon Honce 2013-08-05 21:33:01 EDT

*** This bug has been marked as a duplicate of bug 985514 ***

Note You need to log in before you can comment on or make changes to this bug.