Bug 985515 - productid yum plugin fails in anaconda env because of missing dbus in anaconda runtime image
productid yum plugin fails in anaconda env because of missing dbus in anacond...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.10
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Carter Kozak
IDM QE LIST
:
: 986757 (view as bug list)
Depends On:
Blocks: rhsm-rhel510
  Show dependency treegraph
 
Reported: 2013-07-17 12:28 EDT by Adrian Likins
Modified: 2013-09-30 19:13 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No description necessary
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-30 19:13:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of F2 console from anaconda after running the plugin manually (14.36 KB, image/png)
2013-07-17 12:28 EDT, Adrian Likins
no flags Details
/etc/pki/product/69.pem was installed by anaconda (28.97 KB, image/png)
2013-08-13 12:38 EDT, John Sefler
no flags Details

  None (edit)
Description Adrian Likins 2013-07-17 12:28:55 EDT
Created attachment 774850 [details]
screenshot of F2 console from anaconda after running the plugin manually

Description of problem:

0a95a841719210e2b6b244377d926a6eab9cf535 in master moved
the code for getting a dbus interface from gui/utils.py to
utils.py

the rhsm yum plugin "productid.py" is invoked via the anaconda
process (via yum). The environment in which anaconda is running
does not have the dbus-python package (/usr/lib64/python2.4/site-packages/dbus)
so the productid plugin fails to load.

Note that in rhel5, the file system image is using as it's / filesystem
is basically constructed by hand, often ignoring rpm deps. In this case,
despite productid.py requiring dbus-python, it isnt part of the installer.

We may be able to get it included, but I doubt it (doesn't look like there
is any dbus at all).

So we probably need to either remove or split that dep, or let it handle
it being missing.


screenshot of F2 console from anaconda after running the plugin manually, 

Version-Release number of selected component (if applicable):

Anaconda image from RHEL5.10-Client-20130717.0.n
Comment 1 Adrian Likins 2013-07-22 15:37:30 EDT
*** Bug 986757 has been marked as a duplicate of this bug. ***
Comment 2 Carter Kozak 2013-07-22 16:34:46 EDT
commit 43f86b88d8d2d1a0ad3d514f30e0eec83194cd1a
Author: ckozak <ckozak@redhat.com>
Date:   Mon Jul 22 14:44:23 2013 -0400

    985515: moved DbusIface to fix anaconda productId
Comment 9 John Sefler 2013-08-13 12:38:49 EDT
Created attachment 786212 [details]
/etc/pki/product/69.pem was installed by anaconda

My approach to verifying this bug will be to launch a minimal install (no groups checked and all default packages unchecked by choosing Customize now during anaconda install screens) and verify after it completes that the RHEL product id is installed.

Verifying with RHEL-5.10-Server-Snapshot-4.0/  RHEL5.10-Server-20130807.1

After provisioning a minimal install, only 154 packages were installed. /root/anaconda-ks.cfg contains only:

%packages
@core
sgpio

subscription-manager was not installed, however the product id was indeed installed as /etc/pki/product/69.pem   See screenshot.
Comment 11 errata-xmlrpc 2013-09-30 19:13:31 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1332.html

Note You need to log in before you can comment on or make changes to this bug.