Bug 985597 - [abrt] WARNING: at fs/btrfs/extent-tree.c:5385 __btrfs_free_extent+0x7fe/0x840 [btrfs]()
[abrt] WARNING: at fs/btrfs/extent-tree.c:5385 __btrfs_free_extent+0x7fe/0x84...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fs-maint
Fedora Extras Quality Assurance
abrt_hash:b66bad4d9be1d6f87a5959ad0d0...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-17 16:24 EDT by Juan Orti
Modified: 2013-09-23 16:27 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 16:27:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dmesg (133.11 KB, text/plain)
2013-07-17 16:25 EDT, Juan Orti
no flags Details

  None (edit)
Description Juan Orti 2013-07-17 16:24:48 EDT
Description of problem:
Related to bug #985427

Additional info:
reporter:       libreport-2.1.5
WARNING: at fs/btrfs/extent-tree.c:5385 __btrfs_free_extent+0x7fe/0x840 [btrfs]()
Hardware name: System Product Name
Modules linked in: bnep bluetooth vhost_net macvtap macvlan ebtable_nat xt_CHECKSUM tun nf_conntrack_netbios_ns nf_conntrack_broadcast ipt_MASQUERADE ip6table_nat nf_nat_ipv6 ip6table_mangle ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 iptable_nat nf_nat_ipv4 nf_nat bridge stp llc iptable_mangle nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack ebtable_filter ebtables ip6table_filter ip6_tables btrfs zlib_deflate raid6_pq libcrc32c xor vfat fat eeepc_wmi asus_wmi sparse_keymap rfkill iTCO_wdt iTCO_vendor_support snd_hda_codec_hdmi snd_hda_codec_realtek mperf coretemp kvm_intel uvcvideo videobuf2_vmalloc kvm snd_hda_intel snd_usb_audio snd_hda_codec videobuf2_memops snd_usbmidi_lib videobuf2_core snd_hwdep snd_seq snd_rawmidi videodev snd_seq_device media microcode mceusb snd_pcm rc_core i2c_i801 r8169 lpc_ich mfd_core mii snd_page_alloc snd_timer snd mei soundcore wmi uinput dm_crypt usb_storage i915 crc32_pclmul crc32c_intel i2c_algo_bit ghash_clmulni_intel drm_kms_helper drm i2c_core video
Pid: 4892, comm: btrfs Not tainted 3.9.9-302.fc19.x86_64 #1
Call Trace:
 [<ffffffff8105cc56>] warn_slowpath_common+0x66/0x80
 [<ffffffff8105cd2a>] warn_slowpath_null+0x1a/0x20
 [<ffffffffa03d291e>] __btrfs_free_extent+0x7fe/0x840 [btrfs]
 [<ffffffffa042e564>] ? btrfs_merge_delayed_refs+0x1f4/0x3d0 [btrfs]
 [<ffffffffa03d61f6>] run_clustered_refs+0x376/0xc30 [btrfs]
 [<ffffffffa0409bef>] ? free_extent_buffer+0x4f/0xa0 [btrfs]
 [<ffffffffa03dab40>] btrfs_run_delayed_refs+0xd0/0x500 [btrfs]
 [<ffffffffa0434c04>] ? relocate_tree_blocks+0x354/0x600 [btrfs]
 [<ffffffffa03ebc17>] __btrfs_end_transaction+0xc7/0x310 [btrfs]
 [<ffffffffa03ec433>] btrfs_end_transaction_throttle+0x13/0x20 [btrfs]
 [<ffffffffa0435c1c>] relocate_block_group+0x4ec/0x690 [btrfs]
 [<ffffffffa0435f7d>] btrfs_relocate_block_group+0x1bd/0x300 [btrfs]
 [<ffffffffa040d4d9>] btrfs_relocate_chunk.isra.31+0x59/0x470 [btrfs]
 [<ffffffffa0409bef>] ? free_extent_buffer+0x4f/0xa0 [btrfs]
 [<ffffffffa0411b99>] btrfs_shrink_device+0x1e9/0x420 [btrfs]
 [<ffffffffa0413da2>] btrfs_rm_device+0x2a2/0x850 [btrfs]
 [<ffffffffa041cf4d>] btrfs_ioctl+0xc1d/0x1ca0 [btrfs]
 [<ffffffff8164aac4>] ? __do_page_fault+0x1f4/0x510
 [<ffffffff8115f208>] ? __vma_link_rb+0xb8/0xe0
 [<ffffffff811ab495>] do_vfs_ioctl+0x305/0x520
 [<ffffffff8129495e>] ? file_has_perm+0x8e/0xa0
 [<ffffffff811ab731>] sys_ioctl+0x81/0xa0
 [<ffffffff8164adee>] ? do_page_fault+0xe/0x10
 [<ffffffff8164f319>] system_call_fastpath+0x16/0x1b

Potential duplicate: bug 892352
Comment 1 Juan Orti 2013-07-17 16:25:01 EDT
Created attachment 774953 [details]
File: dmesg
Comment 2 Josh Boyer 2013-09-18 16:45:56 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.11.1-200.fc19.  Please test this kernel update and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.
Comment 3 Josef Bacik 2013-09-23 16:27:44 EDT
This is extent tree corruption.  Please make sure you have the btrfs-progs from git.kernel.org and run btrfsck on your device.  If it complains try running btrfsck --repair on your device and see if it fixes the corruption.  If not please file a bugzilla at bugzilla.kernel.org and set the component to btrfs.

Note You need to log in before you can comment on or make changes to this bug.