Bug 985843 - Can't install Fedora 20
Can't install Fedora 20
Status: CLOSED DUPLICATE of bug 985627
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-18 07:17 EDT by Krzysztof Daniel
Modified: 2014-01-12 19:28 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-23 15:55:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of dead installation (12.77 KB, image/png)
2013-07-18 07:17 EDT, Krzysztof Daniel
no flags Details

  None (edit)
Description Krzysztof Daniel 2013-07-18 07:17:22 EDT
Created attachment 775258 [details]
Screenshot of dead installation

I downloaded a boot.iso from http://dl.fedoraproject.org/pub/fedora/linux/development/rawhide/x86_64/os/images/ and tried to boot in VM. I had to switch to VNC, because spice did not work at all (white screen after installation started).
Comment 1 Steve Tyler 2013-07-22 04:56:57 EDT
The exception in the screenshot is:
AttributeError: 'NoneType' object has no attribute 'unpack'
Comment 2 Krzysztof Daniel 2013-07-22 12:39:16 EDT
I finally installed it, but the list of problems is pretty long - first of all - NetworkManager is not started properly - and it causes anaconda failure. 

The only way to get F20 installed was to create f19 image, add rawhide repos, update, and then cycle service NetworkManager start/stop a couple of times until it started working.
Comment 3 Steve Tyler 2013-07-22 13:03:20 EDT
(In reply to Krzysztof Daniel from comment #0)
...
> I downloaded a boot.iso from
> http://dl.fedoraproject.org/pub/fedora/linux/development/rawhide/x86_64/os/
> images/
...

That link returns "404 Not Found" now ...
Comment 4 Steve Tyler 2013-07-22 13:08:23 EDT
If you can switch to the installer shell console (ctrl-alt-f2), the anaconda log files are in /tmp. If there is an anaconda-tb-* file in /tmp, could you attach it?
Comment 5 Krzysztof Daniel 2013-07-22 13:27:27 EDT
No such file: just
anaconda, packaging, storage, ifcfg, program, all with .log extension,  but nothing interesting there.
Comment 6 Steve Tyler 2013-07-22 13:52:07 EDT
How are you starting the installer? text mode?

In graphical mode, you should be getting an exception reporting dialog that lets you report a bug. Can you reproduce the exception in graphical mode?
Comment 7 Krzysztof Daniel 2013-07-22 13:57:47 EDT
I start empty VM image with boot.iso as a cdrom. I select 'Install Fedora rawhide'. It looks like GRUB. Then I get green [OK] messages, and then

Starting installer, one moment.
Then the screenshot follows.
Comment 8 Steve Tyler 2013-07-22 23:59:37 EDT
OK, thanks. I'm not sure what is going on, then. Maybe the kernel command line has "text" on it by default in that image, or the exception occurs before X is started. Anyway, if you can reproduce this with an image that is online, please post a comment.
Comment 9 Krzysztof Daniel 2013-07-23 02:45:21 EDT
I also used http://koji.fedoraproject.org/koji/taskinfo?taskID=5639955.

Steps to reproduce are:
* start live image
* start command line, type liveinst -d

The same effect, the same stack trace as on the screenshot.

Starting installer, one moment...
/usr/lib64/python2.7/site-packages/gi/overrides/GLib.py:53: PyGIDeprecationWarning: threads_init longer needs to be called. See: https://bugzilla.gnome.org/show_bug.cgi?id=686914
  PyGIDeprecationWarning)
anaconda 20.2-1 for Fedora 20 (pre-release) started.
Traceback (most recent call last):
  File "/sbin/anaconda", line 968, in <module>
    setupDisplay(anaconda, opts, addon_paths)
  File "/sbin/anaconda", line 483, in setupDisplay
    if not nm_is_connecting() and not nm_is_connected():
  File "/usr/lib64/python2.7/site-packages/pyanaconda/nm.py", line 96, in nm_is_connecting
    return nm_state() == NetworkManager.State.CONNECTING
  File "/usr/lib64/python2.7/site-packages/pyanaconda/nm.py", line 82, in nm_state
    return proxy.get_cached_property("State").unpack()


Only after executing this series of commands:
[liveuser@localhost ~]$ su
[root@localhost liveuser]# service NetworkManager stop
Redirecting to /bin/systemctl stop  NetworkManager.service
^C
[root@localhost liveuser]# service NetworkManager start
Redirecting to /bin/systemctl start  NetworkManager.service
Job for NetworkManager.service canceled.
Job for NetworkManager.service canceled.
[root@localhost liveuser]# 

Anaconda was able to start (and after a few tries I was able to complete wizards, but never to actually install anything).

In general, the installer is *very* slow (RHEL and F19 VMs work fine) and it takes tens of seconds between a click and a reaction.
Comment 10 Steve Tyler 2013-07-23 14:26:06 EDT
Thanks, Krzysztof. I didn't think of trying a nightly:
http://alt.fedoraproject.org/pub/alt/nightly-composes/

Confirming your report with:
$ qemu-kvm -m 4096 -hda f19-test-3.img -cdrom ~/xfr/fedora/nightly-composes/Fedora-20-Nightly-x86_64-Live-xfce-20130722.09-1.iso -vga std -boot menu=on

After the Live image boots, there is no ip address assigned, yet NetworkManager is running. Restarting NetworkManager hangs. After killing the restart, a second restart succeeds. This all looks like a systemd/NetworkManager/LiveCD problem and not an anaconda problem.

[liveuser@localhost ~]$ sudo su

[root@localhost liveuser]# ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: ens3: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 52:54:00:12:34:56 brd ff:ff:ff:ff:ff:ff

[root@localhost liveuser]# systemctl status NetworkManager
...

[root@localhost liveuser]# systemctl restart NetworkManager

^C
[root@localhost liveuser]# systemctl status NetworkManager
...

[root@localhost liveuser]# systemctl restart NetworkManager

[root@localhost liveuser]# ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: ens3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 52:54:00:12:34:56 brd ff:ff:ff:ff:ff:ff
    inet 10.0.2.15/24 brd 10.0.2.255 scope global ens3
       valid_lft forever preferred_lft forever
    inet6 fe80::5054:ff:fe12:3456/64 scope link 
       valid_lft forever preferred_lft forever

[root@localhost liveuser]# systemctl status NetworkManager
...
Comment 11 Steve Tyler 2013-07-23 15:48:18 EDT
(In reply to Steve Tyler from comment #10)
...
> ... This all looks like a
> systemd/NetworkManager/LiveCD problem and not an anaconda problem.
...

This sounds identical:
Bug 985627 - NM fails to bring up any interfaces at first boot on Rawhide since kernel-3.11.0-0.rc0.git7.1.fc20.x86_64
Comment 12 Adam Williamson 2013-07-23 15:55:49 EDT
Well, not really identical. I clearly identified separate problems and filed separate bugs. This report is a mess.

See also:

https://bugzilla.redhat.com/show_bug.cgi?id=986068
https://bugzilla.redhat.com/show_bug.cgi?id=986069

*** This bug has been marked as a duplicate of bug 985627 ***
Comment 13 Steve Tyler 2013-07-23 16:03:54 EDT
(In reply to Adam Williamson from comment #12)
> Well, not really identical. I clearly identified separate problems and filed
> separate bugs. This report is a mess.
Ain't you special, Adam.
The analysis clearly evolved in this bug ...
Comment 14 Adam Williamson 2013-07-23 16:06:10 EDT
Or, as I put it, "this report is a mess". :)

Note You need to log in before you can comment on or make changes to this bug.