Bug 986069 - AttributeError: 'F18_Url' object has no attribute 'partition'
AttributeError: 'F18_Url' object has no attribute 'partition'
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:e9f201dd262d5a98f00c47db887...
:
: 986020 989040 (view as bug list)
Depends On:
Blocks: F20AlphaBlocker
  Show dependency treegraph
 
Reported: 2013-07-18 17:51 EDT by Adam Williamson
Modified: 2013-08-20 11:12 EDT (History)
13 users (show)

See Also:
Fixed In Version: anaconda-20.5-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-20 11:12:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (401.34 KB, text/plain)
2013-07-18 17:51 EDT, Adam Williamson
no flags Details
File: anaconda.log (3.33 KB, text/plain)
2013-07-18 17:51 EDT, Adam Williamson
no flags Details
File: environ (517 bytes, text/plain)
2013-07-18 17:51 EDT, Adam Williamson
no flags Details
File: lsblk_output (2.07 KB, text/plain)
2013-07-18 17:51 EDT, Adam Williamson
no flags Details
File: messages (140.65 KB, text/plain)
2013-07-18 17:51 EDT, Adam Williamson
no flags Details
File: nmcli_dev_list (480 bytes, text/plain)
2013-07-18 17:51 EDT, Adam Williamson
no flags Details
File: os_info (297 bytes, text/plain)
2013-07-18 17:51 EDT, Adam Williamson
no flags Details
File: program.log (36.62 KB, text/plain)
2013-07-18 17:51 EDT, Adam Williamson
no flags Details
File: storage.log (202.40 KB, text/plain)
2013-07-18 17:51 EDT, Adam Williamson
no flags Details
File: ifcfg.log (486 bytes, text/plain)
2013-07-18 17:52 EDT, Adam Williamson
no flags Details
screenshot showing Aborted message in terminal and abrt notification on desktop after AttributeError exception (738.68 KB, image/png)
2013-07-30 06:30 EDT, Steve Tyler
no flags Details

  None (edit)
Description Adam Williamson 2013-07-18 17:51:25 EDT
Description of problem:
Running liveinst on a freshly-built Rawhide desktop live image, after restarting NetworkManager.service (running it before restarting NetworkManager.service triggered #986068). Welcome screen showed up but the crash occurred immediately after.

Version-Release number of selected component:
anaconda-20.2-1.fc20.x86_64

The following was filed automatically by anaconda:
anaconda 20.2-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/pykickstart/commands/method.py", line 51, in __getattr__
    return getattr(self.handler.url, name)
  File "/usr/lib/python2.7/site-packages/pykickstart/commands/method.py", line 76, in __getattr__
    return FC3_Method.__getattr__(self, name)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/livepayload.py", line 71, in setup
    osimg = storage.devicetree.getDeviceByPath(self.data.method.partition)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/__init__.py", line 671, in payloadInitialize
    payload.setup(storage)
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
AttributeError: 'F18_Url' object has no attribute 'partition'

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=20130718-desktop-x86_64 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 slub_debug=- BOOT_IMAGE=vmlinuz0 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.0-0.rc1.git1.1.fc20.x86_64
other involved packages: pykickstart-1.99.34-1.fc20.noarch, python-libs-2.7.5-3.fc20.x86_64
product:        Fedora
release:        Fedora release 20 (Rawhide)
type:           anaconda
version:        rawhide
Comment 1 Adam Williamson 2013-07-18 17:51:29 EDT
Created attachment 775517 [details]
File: anaconda-tb
Comment 2 Adam Williamson 2013-07-18 17:51:32 EDT
Created attachment 775518 [details]
File: anaconda.log
Comment 3 Adam Williamson 2013-07-18 17:51:36 EDT
Created attachment 775519 [details]
File: environ
Comment 4 Adam Williamson 2013-07-18 17:51:39 EDT
Created attachment 775520 [details]
File: lsblk_output
Comment 5 Adam Williamson 2013-07-18 17:51:43 EDT
Created attachment 775521 [details]
File: messages
Comment 6 Adam Williamson 2013-07-18 17:51:46 EDT
Created attachment 775522 [details]
File: nmcli_dev_list
Comment 7 Adam Williamson 2013-07-18 17:51:51 EDT
Created attachment 775523 [details]
File: os_info
Comment 8 Adam Williamson 2013-07-18 17:51:55 EDT
Created attachment 775524 [details]
File: program.log
Comment 9 Adam Williamson 2013-07-18 17:51:59 EDT
Created attachment 775525 [details]
File: storage.log
Comment 10 Adam Williamson 2013-07-18 17:52:03 EDT
Created attachment 775526 [details]
File: ifcfg.log
Comment 11 Adam Williamson 2013-07-18 17:52:43 EDT
Looks rather like an Alpha blocker: instacrash in the live installer.
Comment 12 Steve Tyler 2013-07-18 22:49:33 EDT
This looks like a dupe:
Bug 986020 - anaconda-20.2
Comment 13 Brian Lane 2013-07-24 12:17:08 EDT
anaconda assumes that the method object will have the appropriate attrs available when it sets the ksdata.method.method string
Comment 14 David Shea 2013-07-29 10:34:47 EDT
*** Bug 989040 has been marked as a duplicate of this bug. ***
Comment 15 Manfred Blankenfeld 2013-07-29 11:48:12 EDT
The same bug with anaconda 20.3

ManfredB
Comment 16 Steve Tyler 2013-07-29 12:07:47 EDT
This looks like a duplicate:
Bug 986020 - anaconda-20.2
Comment 17 Adam Williamson 2013-07-29 12:14:19 EDT
*** Bug 986020 has been marked as a duplicate of this bug. ***
Comment 18 Adam Williamson 2013-07-29 20:35:19 EDT
I'm not sure if it was supposed to or not, but pykickstart-1.99.35-1.fc20 does not fix this, I just tested.
Comment 20 Manfred Blankenfeld 2013-07-30 02:38:04 EDT
Ok, but how to use it?

I installed pykickstart-1.99.35-1, but I don´t understand how I can change the aliases.

ManfredB
Comment 21 Steve Tyler 2013-07-30 06:13:36 EDT
Manfred: If you are asking how to reproduce the AttributeError exception, here is how I did it using this nightly[1]:

Fedora-20-Nightly-x86_64-Live-desktop-20130728.10-1.iso:
http://koji.fedoraproject.org/koji/taskinfo?taskID=5668680

1. Start the Live image in a VM:
$ qemu-kvm -m 4096 -cdrom ~/xfr/fedora/nightly-composes/Fedora-20-Nightly-x86_64-Live-desktop-20130728.10-1.iso -vga std -boot menu=on

2. From the desktop, start a terminal.
3. $ liveinst
   A bug reporting dialog is displayed, but it is not responsive to clicks.
   The dialog disappears almost immediately as liveinst exits with an Aborted message in the terminal.
   An abrt notification is displayed.
4. $ sudo less /tmp/anaconda-tb-*.
   The file has a traceback for an AttributeError exception.
   Version is anaconda 20.3-1.

NB: The screen is black for about 30 seconds before the desktop is displayed. 

[1] All nightlies are here:
http://alt.fedoraproject.org/pub/alt/nightly-composes/
Comment 22 Steve Tyler 2013-07-30 06:30:15 EDT
Created attachment 780532 [details]
screenshot showing Aborted message in terminal and abrt notification on desktop after AttributeError exception

Tested with:
$ qemu-kvm -m 4096 -cdrom ~/xfr/fedora/nightly-composes/Fedora-20-Nightly-x86_64-Live-desktop-20130728.10-1.iso -vga std -boot menu=on
Comment 23 Chris Lumens 2013-07-30 10:13:38 EDT
That commit message was wrong - the pykickstart commit should reference bug 989330.  This bug is going to be fixed in anaconda instead.
Comment 24 Adam Williamson 2013-07-31 14:30:09 EDT
I tried to see if I could confirm the fix with an updates.img, but it doesn't seem to work. http://www.happyassassin.net/extras/updates-986069.img should have the fix in it, but install attempts still fail with this error. I'm not 100% sure if the patch is wrong, or if it's just impossible to test a fix to /usr/sbin/anaconda with an updates.img in the live situation, since it's that script itself which *applies* the updates.img . /usr/sbin/anaconda does show 'ksdata.method.method= "harddrive"' after running the install attempt, though, and running the installer *twice* doesn't help, the second attempt still fails.
Comment 25 Steve Tyler 2013-07-31 14:35:24 EDT
In the Live environment, you might be able to apply the patch directly to the Python code before starting the installer. I've done that successfully a few times.

Find the file with:
$ rpm -ql anaconda | grep whatever.py
Comment 26 Adam Williamson 2013-07-31 15:42:29 EDT
doesn't appear to be necessary; bcl says the change is applied by liveinst before anaconda is run. it looks like the fix just doesn't work.
Comment 27 Manfred Blankenfeld 2013-08-01 16:35:43 EDT
NO!

anaconda-20.4.1.fc20.x86_64 has the same bug.

I cannot load my bug-report here.
My anaconda-20.4-1.fc20.x86_64.txt is too long to paste it here.

ManfredB
Comment 28 Manfred Blankenfeld 2013-08-01 16:47:12 EDT
This error comes after choosing another language as US_English.

I tested it: no language change and the installer starts.

My language: German -nodeadkeys but this is not right - therefore the bug.

ManfredB
Comment 29 Adam Williamson 2013-08-02 01:25:10 EDT
Manfred: um, it seems very unlikely you'd hit *this* bug depending on what language you select. Are you sure it's the same traceback? "The installer crashed" does not mean it's the same bug.
Comment 30 Manfred Blankenfeld 2013-08-02 01:41:47 EDT
Sorry, the first one I wrote my comment, I had not tested enough.
So I could not compare the very long bug with the bug-report from anaconda-22.3.

My tests were:

1. Start installer
2. My keyboard-language was German (VirtualBox is in German, therefore the language was preset.
3. When I use only German as my keyboard-language, there comes the bug.
4. Go on klick includes English and German - no bug.

This way I could not know the first one I started anaconda. This is the reason I wrote "the same bug", but it isn´t the same, now I know.

Sorry for my bad comment.

ManfredB
Comment 31 Brian Lane 2013-08-02 14:56:14 EDT
I forgot that chris' patches hadn't been pushed yet. All of them will be in 20.5
Comment 32 Adam Williamson 2013-08-20 11:12:19 EDT
This is fixed in 20.5 and 20.6, as confirmed by me and Chris Tyler in https://bugzilla.redhat.com/show_bug.cgi?id=997690 (we couldn't reach that one if this one was still happening).

Note You need to log in before you can comment on or make changes to this bug.