Bug 985861 - [abrt] lightdm-gtk-1.5.1-3.fc19: g_malloc: Process /usr/sbin/lightdm-gtk-greeter was killed by signal 11 (SIGSEGV)
[abrt] lightdm-gtk-1.5.1-3.fc19: g_malloc: Process /usr/sbin/lightdm-gtk-gree...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lightdm-gtk (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
abrt_hash:2885df7e04cdf863ed4b5138960...
:
: 989598 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-18 07:41 EDT by Marcel Wysocki
Modified: 2013-09-15 20:30 EDT (History)
5 users (show)

See Also:
Fixed In Version: lightdm-1.6.2-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-15 20:30:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (714.35 KB, text/plain)
2013-07-18 07:42 EDT, Marcel Wysocki
no flags Details
File: cgroup (160 bytes, text/plain)
2013-07-18 07:42 EDT, Marcel Wysocki
no flags Details
File: core_backtrace (64.43 KB, text/plain)
2013-07-18 07:42 EDT, Marcel Wysocki
no flags Details
File: dso_list (7.02 KB, text/plain)
2013-07-18 07:42 EDT, Marcel Wysocki
no flags Details
File: environ (315 bytes, text/plain)
2013-07-18 07:42 EDT, Marcel Wysocki
no flags Details
File: limits (1.29 KB, text/plain)
2013-07-18 07:42 EDT, Marcel Wysocki
no flags Details
File: maps (37.21 KB, text/plain)
2013-07-18 07:42 EDT, Marcel Wysocki
no flags Details
File: open_fds (519 bytes, text/plain)
2013-07-18 07:42 EDT, Marcel Wysocki
no flags Details
File: proc_pid_status (928 bytes, text/plain)
2013-07-18 07:42 EDT, Marcel Wysocki
no flags Details
File: var_log_messages (354 bytes, text/plain)
2013-07-18 07:42 EDT, Marcel Wysocki
no flags Details
lightdm.log (35.62 KB, text/x-log)
2013-08-16 11:21 EDT, Heiko Adams
no flags Details
x-0.log (2.57 KB, text/x-log)
2013-08-16 11:21 EDT, Heiko Adams
no flags Details
x-0-greeter.log (279 bytes, text/x-log)
2013-08-16 11:22 EDT, Heiko Adams
no flags Details

  None (edit)
Description Marcel Wysocki 2013-07-18 07:41:56 EDT
Version-Release number of selected component:
lightdm-gtk-1.5.1-3.fc19

Additional info:
reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        /usr/sbin/lightdm-gtk-greeter
crash_function: g_malloc
executable:     /usr/sbin/lightdm-gtk-greeter
kernel:         3.9.9-301.fc19.x86_64
runlevel:       N 5
uid:            994
xsession_errors: 

Truncated backtrace:
Thread no. 1 (6 frames)
 #2 g_malloc at gmem.c:159
 #3 g_strdup at gstrfuncs.c:364
 #4 g_value_set_string at gvaluetypes.c:1040
 #5 gtk_tree_model_get_valist at gtktreemodel.c:1763
 #6 gtk_tree_model_get at gtktreemodel.c:1727
 #7 set_session at lightdm-gtk-greeter.c:271
Comment 1 Marcel Wysocki 2013-07-18 07:42:02 EDT
Created attachment 775279 [details]
File: backtrace
Comment 2 Marcel Wysocki 2013-07-18 07:42:05 EDT
Created attachment 775280 [details]
File: cgroup
Comment 3 Marcel Wysocki 2013-07-18 07:42:09 EDT
Created attachment 775281 [details]
File: core_backtrace
Comment 4 Marcel Wysocki 2013-07-18 07:42:12 EDT
Created attachment 775282 [details]
File: dso_list
Comment 5 Marcel Wysocki 2013-07-18 07:42:17 EDT
Created attachment 775283 [details]
File: environ
Comment 6 Marcel Wysocki 2013-07-18 07:42:20 EDT
Created attachment 775284 [details]
File: limits
Comment 7 Marcel Wysocki 2013-07-18 07:42:24 EDT
Created attachment 775285 [details]
File: maps
Comment 8 Marcel Wysocki 2013-07-18 07:42:27 EDT
Created attachment 775286 [details]
File: open_fds
Comment 9 Marcel Wysocki 2013-07-18 07:42:30 EDT
Created attachment 775287 [details]
File: proc_pid_status
Comment 10 Marcel Wysocki 2013-07-18 07:42:34 EDT
Created attachment 775288 [details]
File: var_log_messages
Comment 11 Heiko Adams 2013-08-16 10:52:12 EDT
*** Bug 989598 has been marked as a duplicate of this bug. ***
Comment 12 Heiko Adams 2013-08-16 10:58:11 EDT
Same problem here. Would be nice if some one could take some action on this because lightdm-gtk-greeter is not useable atm and nothing happend for nearly one month!
Comment 13 Rex Dieter 2013-08-16 11:00:04 EDT
Mind trying out this build?
http://koji.fedoraproject.org/koji/buildinfo?buildID=444454
Comment 14 Rex Dieter 2013-08-16 11:00:43 EDT
And, for your latest problem, providing another backtrace would be extremely helpful too (if possible).
Comment 15 Heiko Adams 2013-08-16 11:17:35 EDT

(In reply to Rex Dieter from comment #13)
> Mind trying out this build?
> http://koji.fedoraproject.org/koji/buildinfo?buildID=444454

No this doesn't solve the problem. I'll attach my lightdm logs to this bug. Maybe that helps you.
Comment 16 Rex Dieter 2013-08-16 11:19:40 EDT
I would like a backtrace, to confirm your crash is indeed the same as this one.
Comment 17 Heiko Adams 2013-08-16 11:21:16 EDT
Created attachment 787326 [details]
lightdm.log
Comment 18 Heiko Adams 2013-08-16 11:21:52 EDT
Created attachment 787327 [details]
x-0.log
Comment 19 Heiko Adams 2013-08-16 11:22:45 EDT
Created attachment 787340 [details]
x-0-greeter.log
Comment 20 Heiko Adams 2013-08-16 11:27:16 EDT
(In reply to Rex Dieter from comment #16)
> I would like a backtrace, to confirm your crash is indeed the same as this
> one.

Sorry, I can't provide a backtrace because abrt says the crash-data is incomplete.
Comment 21 Rex Dieter 2013-08-16 11:34:10 EDT
Yeah, a gripe I have with abrt too, in cases like that I would still like to see the backtrace.

Given that abrt doesn't give you any data, we have no evidence your crash is the same as this one.

That said, we can try.  Since it seems related to the set_session function, can either of you post the contents of:
~/.dmrc (if it exists)

and use d-feet or qdbusviewer to browse the system dbus under
org.freedesktop.Accounts and browse to /org/freedesktop/Accounts/User<XXX> and post the value of the "XSession" property.
Comment 22 Heiko Adams 2013-08-16 11:41:22 EDT
My .dmrc:

>
> [Desktop]
> Session=xfce
>
(with blank lines at first and last)

The value of the "XSession" property is "xfce"
Comment 23 Heiko Adams 2013-09-09 05:16:52 EDT
For me this is fixed with LightDM 1.6.1 from Koji
Comment 24 Fedora Update System 2013-09-09 15:04:09 EDT
lightdm-1.6.1-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/lightdm-1.6.1-1.fc19
Comment 25 Fedora Update System 2013-09-10 22:06:33 EDT
Package lightdm-1.6.1-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lightdm-1.6.1-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-16388/lightdm-1.6.1-1.fc19
then log in and leave karma (feedback).
Comment 26 Fedora Update System 2013-09-12 21:07:23 EDT
Package lightdm-1.6.2-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lightdm-1.6.2-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-16388/lightdm-1.6.2-1.fc19
then log in and leave karma (feedback).
Comment 27 Fedora Update System 2013-09-15 20:30:53 EDT
lightdm-1.6.2-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.