Bug 985905 - RFE: enable debian and arch dependency solving
RFE: enable debian and arch dependency solving
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libsolv (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 985915
  Show dependency treegraph
 
Reported: 2013-07-18 09:22 EDT by Miroslav Suchý
Modified: 2014-09-30 19:41 EDT (History)
3 users (show)

See Also:
Fixed In Version: libsolv-0.3.0-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-22 09:06:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Suchý 2013-07-18 09:22:02 EDT
Description of problem:
On Fedora machine, I need to be able to resolve Debian and ARCH dependency (because of perl-BSSolv, which is need for obs-server)

With this patch, libsolv is built with those featurese enabled:
diff --git a/libsolv.spec b/libsolv.spec
index da11940..574fff9 100644
--- a/libsolv.spec
+++ b/libsolv.spec
@@ -92,7 +92,11 @@ make ARGS="-V" test
        -DENABLE_PYTHON=1 \
        -DENABLE_RUBY=1 \
        -DUSE_VENDORDIRS=1 \
-       -DFEDORA=1
+       -DFEDORA=1 \
+       -DENABLE_DEBIAN=1 \
+       -DENABLE_ARCHREPO=1 \
+       -DENABLE_LZMA_COMPRESSION=1
#       -DMULTI_SEMANTICS=1
 
 make %{?_smp_mflags}
 
@@ -112,6 +116,9 @@ rm $RPM_BUILD_ROOT/usr/bin/testsolv
 %files tools
 %_bindir/deltainfoxml2solv
 %_bindir/dumpsolv
+%_bindir/deb2solv
+%_bindir/archpkgs2solv
+%_bindir/archrepo2solv
 %_bindir/installcheck
 %_bindir/mergesolv
 %_bindir/repo2solv.sh
Comment 1 Ales Kozumplik 2013-07-18 11:04:04 EDT
Hello Michael,

I wanted to ask if we can safely enable this for the Fedora libsolv package? I am especially worried about the MULTI_SEMANTICS bit. What do you think?

Thank you, Ales
Comment 2 Michael Schröder 2013-07-18 12:57:13 EDT
MULTI_SEMANTICS doesn't hurt, it just offers more flexibility. So don't be worried.

(From the perspective of a build service admin, I wouldn't link perl-BSSolv against the system's libsolv library, but use a copy of libsolv, just to make sure the build service doesn't break if the system's libsolv is changed. But I also know that having multiple copies of a library is against Fedora's policy...)
Comment 3 Ales Kozumplik 2013-07-19 03:38:16 EDT
Thanks!

Miroslav, do you still want this then? If yes I can do quick testing and make an updated rawhide build with the new defines enabled.

Ales
Comment 4 Ales Kozumplik 2013-07-19 10:26:36 EDT
Tests are passing OK and the change is in distgit, but I can not proceed with the build due to https://fedorahosted.org/fedora-infrastructure/ticket/3882

After the weekend, hopefully.
Comment 5 Ales Kozumplik 2013-07-22 09:06:04 EDT
The build with the required flags is in Rawhide[1]. After some exposure there I will try to propagate this to F19.

Closing this.

[1] http://koji.fedoraproject.org/koji/buildinfo?buildID=436496

Note You need to log in before you can comment on or make changes to this bug.