Bug 986027 - Alt+Tab key combo only recognized by Windows client
Alt+Tab key combo only recognized by Windows client
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: mingw-virt-viewer (Show other bugs)
3.2.0
Unspecified Unspecified
high Severity high
: ---
: 3.3.0
Assigned To: Marc-Andre Lureau
Desktop QE
: Regression, ZStream
Depends On:
Blocks: 1029620
  Show dependency treegraph
 
Reported: 2013-07-18 15:43 EDT by wdaniel
Modified: 2015-09-22 09 EDT (History)
17 users (show)

See Also:
Fixed In Version: mingw-virt-viewer-0.5.6-6.el6_4
Doc Type: Bug Fix
Doc Text:
When pressing Alt-Tab on a Windows virt-viewer client, the command was passed to the client instead of the guest. This update fixes this special keys grab regression, so Alt-Tab is caught by the guest only.
Story Points: ---
Clone Of:
: 1029620 (view as bug list)
Environment:
Last Closed: 2014-01-21 09:46:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Spice log from Windows client (96.92 KB, text/x-log)
2013-07-18 15:43 EDT, wdaniel
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 538313 None None None Never

  None (edit)
Description wdaniel 2013-07-18 15:43:25 EDT
Created attachment 775473 [details]
Spice log from Windows client

Description of problem:

Customer states that after upgrading to 3.2.1 and reconnecting to their VM via spice, Windows catches the Alt+Tab key combo and the VM never sees it.

Version-Release number of selected component (if applicable):
3.2.1

How reproducible:
Not Sure

Actual results:
Windows catches and recognizes the key strokes, VM does not

Expected results:
Alt+Tab should be passed to the Spice client and perform whatever function it is assigned inside the guest.
Comment 1 Marc-Andre Lureau 2013-08-05 08:28:30 EDT
Please give more details how to reproduce.

What is the version of the client.

Is the guest configured with qxl driver, running agent, and tablet?

Can you reproduce the bug from a RHEL client?
Comment 2 wdaniel 2013-08-12 10:42:29 EDT
Marc-Andre,

From the customer:

"I am using the latest SPICE client, Virtual Machine Viewer 0.5.3-28.el6ev. All of my guests are RHEL 6.4, so yes, it happens on RHEL guests. I am using xorg-x11-drv-qxl-0.1.0-4.el6.x86_64.

Thanks,
Kenny"

I think he may have misunderstood the question, it doesn't sound like he has any RHEL clients to test with.
Comment 3 wdaniel 2013-08-23 10:27:51 EDT
(In reply to Marc-Andre Lureau from comment #1)
> Please give more details how to reproduce.
> 
> What is the version of the client.
> 
> Is the guest configured with qxl driver, running agent, and tablet?
> 
> Can you reproduce the bug from a RHEL client?

Marc-Andre, 

I was able to confirm with the customer, he does not have any RHEL clients to reproduce this with.
Comment 4 Marc-Andre Lureau 2013-08-23 10:45:33 EDT
Afaik, alt-tab has always been working correctly with windows.

Can the customer try to be more specific? Have they tried with bare-bone windows (without any additional softawre installed or customization). Also, alt-tab is only catched by the client if the client has the focus and the pointer is over the display. Do they use a different configuration?

As long as nobody is able to reproduce this bug, we can't work on it.
Comment 5 wdaniel 2013-08-28 11:20:44 EDT
(In reply to Marc-Andre Lureau from comment #4)
> Afaik, alt-tab has always been working correctly with windows.
> 
> Can the customer try to be more specific? Have they tried with bare-bone
> windows (without any additional softawre installed or customization). Also,
> alt-tab is only catched by the client if the client has the focus and the
> pointer is over the display. Do they use a different configuration?
> 
> As long as nobody is able to reproduce this bug, we can't work on it.

Marc-Andre,

The customer has confirmed he's seen this behavior on multiple new Windows installs, and the issue was introduced once the 3.2 virt-viewer was pushed out. He says that even while the VM has focus, Atl+Tab is still grabbed by Windows. I'll try doing some testing on my own as well - is there anything else I can look for in particular?
Comment 6 Marc-Andre Lureau 2013-08-28 11:30:10 EDT
(In reply to wdaniel from comment #5)
> Marc-Andre,
> 
> The customer has confirmed he's seen this behavior on multiple new Windows
> installs, and the issue was introduced once the 3.2 virt-viewer was pushed
> out. He says that even while the VM has focus, Atl+Tab is still grabbed by
> Windows. I'll try doing some testing on my own as well - is there anything
> else I can look for in particular?

Yes, check the event log for any warning/error.

We do have a global keyboard, and that has always been working afaik, but there might be cases when it fails?

Also, please keep the needinfo flag as long as no one is able to give instructions to reproduce.
Comment 7 wdaniel 2013-08-30 16:50:37 EDT
Marc-Andre,

Looking specifically for the word 'error', we see a frequency of error codes, but 2 in particular stand out:

1359397793 INFO [3820:1700] COSpiceX::event_thread: exit_code=0 error_code=1
1359402606 INFO [3820:5348] COSpiceX::event_thread: exit_code=0 error_code=1
1359404451 INFO [3820:2648] COSpiceX::event_thread: exit_code=0 error_code=1
1359572576 INFO [3088:4896] COSpiceX::event_thread: exit_code=0 error_code=1
1359638074 INFO [3088:3220] COSpiceX::event_thread: exit_code=0 error_code=1
1359645908 INFO [2200:2592] COSpiceX::event_thread: exit_code=0 error_code=1
1359650632 INFO [2200:1332] COSpiceX::event_thread: exit_code=0 error_code=1

and

1366226576 INFO [5660:8300] COSpiceX::event_thread: exit_code=1 error_code=1032
1366226584 INFO [5660:9184] COSpiceX::event_thread: exit_code=1 error_code=1032
1366228474 INFO [8356:8352] COSpiceX::event_thread: exit_code=1 error_code=1032
1366228483 INFO [8356:7176] COSpiceX::event_thread: exit_code=1 error_code=1032

No warnings present in the log, just these error codes. Any insight as to what these represent?
Comment 8 Marc-Andre Lureau 2013-08-30 17:03:58 EDT
(In reply to wdaniel from comment #7)
> Marc-Andre,
> 
> Looking specifically for the word 'error', we see a frequency of error
> codes, but 2 in particular stand out:
> 
> 1359397793 INFO [3820:1700] COSpiceX::event_thread: exit_code=0 error_code=1
> 1359402606 INFO [3820:5348] COSpiceX::event_thread: exit_code=0 error_code=1
> 1359404451 INFO [3820:2648] COSpiceX::event_thread: exit_code=0 error_code=1
> 1359572576 INFO [3088:4896] COSpiceX::event_thread: exit_code=0 error_code=1
> 1359638074 INFO [3088:3220] COSpiceX::event_thread: exit_code=0 error_code=1
> 1359645908 INFO [2200:2592] COSpiceX::event_thread: exit_code=0 error_code=1
> 1359650632 INFO [2200:1332] COSpiceX::event_thread: exit_code=0 error_code=1
> 
> and
> 
> 1366226576 INFO [5660:8300] COSpiceX::event_thread: exit_code=1
> error_code=1032
> 1366226584 INFO [5660:9184] COSpiceX::event_thread: exit_code=1
> error_code=1032
> 1366228474 INFO [8356:8352] COSpiceX::event_thread: exit_code=1
> error_code=1032
> 1366228483 INFO [8356:7176] COSpiceX::event_thread: exit_code=1
> error_code=1032
> 
> No warnings present in the log, just these error codes. Any insight as to
> what these represent?

no, this doesn' t seem to be directly related to virt-viewer, but rather of the activex somehow (where did you get it? virt-viewer logs are in Windows Event Log, you can consult with Event Viewer)
Comment 9 wdaniel 2013-09-11 17:17:40 EDT
(In reply to Marc-Andre Lureau from comment #8)
> (In reply to wdaniel from comment #7)
> > Marc-Andre,
> > 
> > Looking specifically for the word 'error', we see a frequency of error
> > codes, but 2 in particular stand out:
> > 
> > 1359397793 INFO [3820:1700] COSpiceX::event_thread: exit_code=0 error_code=1
> > 1359402606 INFO [3820:5348] COSpiceX::event_thread: exit_code=0 error_code=1
> > 1359404451 INFO [3820:2648] COSpiceX::event_thread: exit_code=0 error_code=1
> > 1359572576 INFO [3088:4896] COSpiceX::event_thread: exit_code=0 error_code=1
> > 1359638074 INFO [3088:3220] COSpiceX::event_thread: exit_code=0 error_code=1
> > 1359645908 INFO [2200:2592] COSpiceX::event_thread: exit_code=0 error_code=1
> > 1359650632 INFO [2200:1332] COSpiceX::event_thread: exit_code=0 error_code=1
> > 
> > and
> > 
> > 1366226576 INFO [5660:8300] COSpiceX::event_thread: exit_code=1
> > error_code=1032
> > 1366226584 INFO [5660:9184] COSpiceX::event_thread: exit_code=1
> > error_code=1032
> > 1366228474 INFO [8356:8352] COSpiceX::event_thread: exit_code=1
> > error_code=1032
> > 1366228483 INFO [8356:7176] COSpiceX::event_thread: exit_code=1
> > error_code=1032
> > 
> > No warnings present in the log, just these error codes. Any insight as to
> > what these represent?
> 
> no, this doesn' t seem to be directly related to virt-viewer, but rather of
> the activex somehow (where did you get it? virt-viewer logs are in Windows
> Event Log, you can consult with Event Viewer)

Customer came back saying that while reproducing the issue nothing appears in Windows Event log... not sure where else to look to troubleshoot this.
Comment 10 Marc-Andre Lureau 2013-10-02 08:58:58 EDT
moving back to 3.3, the alt-tab regression fix was found during 873341 investigation.
Comment 18 Charlie 2013-11-27 20:27:40 EST
This bug is currently attached to errata RHEA-2013:15512. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 20 errata-xmlrpc 2014-01-21 09:46:44 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0034.html

Note You need to log in before you can comment on or make changes to this bug.