Bug 986036 - [Doc] Set up quantum networks/subnets/routers for allinone for parity with Nova Networking
[Doc] Set up quantum networks/subnets/routers for allinone for parity with No...
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: doc-Getting_Started_Guide (Show other bugs)
3.0
All Linux
unspecified Severity urgent
: async
: 3.0
Assigned To: Bruce Reeler
ecs-bugs
: Documentation, ZStream
Depends On: 986024
Blocks: 1011085
  Show dependency treegraph
 
Reported: 2013-07-18 16:14 EDT by Terry Wilson
Modified: 2016-11-18 10:45 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 986024
Environment:
Last Closed: 2014-01-05 22:57:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Terry Wilson 2013-07-18 16:14:19 EDT
+++ This bug was initially created as a clone of Bug #986024 +++

The experience with installing via packstack with Quantum/Neutron is poor, compared with installing with Nova networking. This is primarily due to the fact that with Quantum/Neutron it is necessary to manually create networks/subnets/routers to be able to launch a VM.

We should implement things in such a way that:

$ packstack --allinone

with quantum/neutron enabled leaves things in a state that is as close to what a user would get functionality-wise with Nova networking (i.e. the user should be able to follow the instructions at http://openstack.redhat.com/Running_an_instance) with as few changes as possible.

(this work is already done, but this bug is to track actually getting everything in the release)

--- Additional comment from Terry Wilson on 2013-07-18 16:11:29 EDT ---

New answer file options:

CONFIG_KEYSTONE_DEMO_PW
  The demo tenant password. Automatically configured/no prompting just like the ADMIN_PW. Only actually used if CONFIG_PROVISION_DEMO=y
CONFIG_PROVISION_DEMO
  Whether to provision demo quantum networks/subnets/routers
  Requires: CONFIG_QUANTUM_INSTALL=y and CONFIG_QUANTUM_USE_NAMESPACES=y
CONFIG_PROVISION_TEMPEST
  Whether to set up tempest for running tests against the Openstack install
  Requires: CONFIG_QUANTUM_INSTALL=y and CONFIG_QUANTUM_USE_NAMESPACES=y
CONFIG_PROVISION_ALL_IN_ONE_OVS_BRIDGE
  Whether to set up the L3 external bridge with the appropriate IP address to act as the gateway for VMs.

The --allinone option will automatically enable CONFIG_PROVISION_DEMO and CONFIG_PROVISION_ALL_IN_ONE_OVS_BRIDGE if CONFIG_QUANTUM_INSTALL=y (which it is by default). --allinone --os-quantum-install=n still works for installing w/o quantum.

Additional changes:
1) A new 'demo' keystone tenant is added along with a keystonerc_demo file which can be sourced like the existing keystonerc_admin. Users should log into horizon using the 'demo' account instead of the 'admin' account due to the ownership of the private and public networks.

2) When launching a VM via horizon, the user will additionally need to go to the "Network" tab and select the "private" network.

3) Current instructions specify creating an security group rule to allow SSH traffic. It might be helpful to have them add an ICMP rule as well (entering -1 for the two fields to allow all ICMP)
Comment 4 Bruce Reeler 2013-09-27 02:05:20 EDT
Added new keys and information from comment 0 above,  to "Procedure 4.1. Quick Start Deployment using PackStack", "Table 4.1. PackStack Configuration Keys" in sect 4.3, and paragraph describing using demo tenant in  "6.1. Accessing the Dashboard"

Note You need to log in before you can comment on or make changes to this bug.